Человеческий фактор: успешные проекты и команды

Том Демарко, Тимоти Листер

Человеческий фактор:
успешные проекты и команды

Tom DeMarco, "Peopleware: Productive Projects and Teams"

Аннотация

Книга Тома Демарко и Тимоти Листера «Человеческий фактор: успешные проекты и команды» — перевод 2-го издания всемирно известного бестселлера об управлении проектами разработки ПО. Первое издание содержало революционные по тем временам (1987 г.) идеи, которые выдержали проверку временем. Авторы скорректировали свои выводы и добавили несколько новых глав. Ценность этой книги в том, что в ней описываются принципы, за каждым из которых стоит реальная история. Все главы содержат наблюдения и новаторские подходы, которые заставят читателей и руководителей увидеть важные вопросы в новом, более разумном ракурсе. С юмором и мудростью, обретёнными за годы руководства и консультирования, Демарко и Листер демонстрируют, что сложнейшие проблемы разработки ПО имеют человеческую, а не техническую природу. Они не дают простых ответов, но дают правильные, подкреплённые научными исследованиями. Издание предназначено в первую очередь руководителям проектов, но будет полезно и рядовым программистам.

«Не обращайте внимания на человека за портьерой», — говорит Великий Оз.
Волшебник Страны Оз

Всем друзьям и коллегам,
которые научили нас не обращать внимания
на человека за портьерой.

    • Отзывы на первое издание
    • Благодарности
    • Предисловие ко второму изданию
    • Предисловие к первому изданию
      I. УПРАВЛЕНИЕ ЧЕЛОВЕЧЕСКИМ РЕСУРСОМ
    • 1. А в это время где-то гибнет проект
      2. Сделал чизбургер — продай его
      3. Вена ждёт тебя
      4. Качество? Если успеем
      5. Ещё раз о законе Паркинсона
      6. Лаетрил
    • II. ОФИСНАЯ СРЕДА
      7. Мебельная полиция
      8. «С девяти до пяти здесь совершенно невозможно работать»
      9. Экономия на пространстве
    • ИНТЕРМЕДИЯ
      10. Работа ума и работа тела
      11. Телефон
      12. Верните дверь на место
      13. Танцы с зонтиком
    • III. ПОДХОДЯЩИЕ ЛЮДИ
      14. Фактор Хорнблауэра
      15. Как нанять жонглёра
      16. Счастлив работать здесь
      17. Самоизлечение системы
    • IV. СОЗДАНИЕ ПРОДУКТИВНЫХ КОМАНД
      18. Целое больше суммы его частей
      19. Чёрная Команда
      20. Травля команд
      21. Ужин со спагетти
      22. Открытое кимоно
      23. Химия формирования команд
      V. УДОВОЛЬСТВИЕ ОТ РАБОТЫ? ЗДЕСЬ?
      24. Хаос и порядок
      25. Свободные электроны
      26. Хольгер Датчанин
    • VI. НАСЛЕДИЕ PEOPLEWARE
      27. Снова о травле команд
      28. Конкуренция
      29. Программы модернизации процессов
      31. Человеческий капитал
      32. Обучение организаций
      33. Самый страшный грех в руководстве — это…
    • Библиография

Отзывы на первое издание

«Демарко и Листер — одновременно и великолепные рассказчики, и проницательные наблюдатели в области руководства проектами.»
Джон Тейлор (John H. Taylor), E.I. du Pont de Nemours & Co.
«…захватывающее чтение — авторы иллюстрируют своё изложение и решения историями из собственного опыта консультирования. Эта хорошо продуманная книга так убедительна, потому что её советы подкреплены научными обоснованиями.»
Журнал PC World
«Авторы подкрепляют свои утверждения эмпирическими данными, полученными в ходе исследований, участие в которых приняли более 900 программистов и аналитиков. Все главы содержат наблюдения и новаторские подходы, которые заставят читателей и руководителей увидеть важные вопросы в новом более разумном ракурсе. Изложенные идеи важны, а книга заслуживает места на книжной полке любого руководителя разработкой ПО и любого консультанта по управлению.»
Т. Кейперс Джоунс (Т. Capers Jones)
«Листер и Демарко безжалостно разрушают аксиомы канонической мудрости, поочерёдно используя хорошо подобранные примеры, колючие эпиграммы, чёткую логику и даже научные данные … если даже вы не согласны с их идеями, вам понравится стиль изложения, и книга спровоцирует вас на размышления. Найдите книгу, прочтите её. Затем отдайте её своему руководителю. Или своим подчинённым (если хватит смелости).»
Алан Кемпбелл (Alan Campbell),
Computing, Лондон
«…представляет в новом свете поведение людей в проектах по разработке.»
Тому Мацубара (Tomoo Matsubara),
Hitachi Software Engineering Co., Ltd.
«…их наблюдения постигают суть вещей. И в результате получается мудрость.»
Уэйр Майерс (Ware Myers),
IEEE Computer Society

Благодарности

К первому изданию

Удивительно, как иногда в титрах простого фильма с тремя актёрами присутствуют ещё от пятидесяти до ста человек. Названия их должностей временами столь загадочны, что нет возможности понять, чем же в действительности занимались эти люди. Тем не менее без их участия фильма не было бы.
Точно так же создание книги, даже столь небольшой, как эта, требует усилий множества людей. У нас, конечно, не было стилистов, осветителей и их ассистентов, однако нам оказали огромную помощь друзья и коллеги, сыгравшие роли насмешников, авторов изящных оборотов, упрямых читателей рукописи, разоблачителей идей, рассказчиков смешных историй, корректировщиков тона повествования, уничтожителей обособленных причастных оборотов, обнаружителей глупостей, а также истребителей слишком многочисленных для одной войны боевых историй. Отдельно следует упомянуть нашего редактора Дженис Уормингтон (Janice Wormington), которая направляла наши усилия и щедро делилась своей энергией, своими знаниями и своим (обычно) хорошим юмором.
Марк Уоллес (Mark Wallace) из Information Engineering и Линда Прауз (Linda Prowse) из Hewlett-Packard великодушно и терпеливо, причём много раз, читали ранние варианты рукописи, предлагая многочисленные улучшения. Каждый из перечисленных далее является (сознательно или неявно) автором по меньшей мере одной идеи: Колин Кордер (Colin Corder), Арт Дэвидсон (Art Davidson), Венди Икин (Wendy Eakin), Джас-тин Коднер (Justin Kodner), Стив Мак-Менамин (Steve McMenamin), Лу Мацукелли (Lou Mazzucchelli), Нэнси Мибон (Nancy Meabon), Кен Орр (Ken Orr), Мейлир Пейдж-Джоунс (Meilir Page-Jones), Джон Пал мер (John Palmer), Джеймс и Сюзанна Робертсон (James, Suzanne Robertson), Джон Тейлор (John Taylor), Дэйв Томела (Dave Tommela). Мы находимся в особом долгу перед профессиональными разработчиками, принимавшими участие в наших исследованиях производительности и в «военных манёврах» в период с 1977 по 1987 годы. Спасибо всем.
Изложенная на страницах книги философия является отчасти продуктом деятельности заботливых и доброжелательных руководителей, с которыми нам приходилось работать. Упомянем Джонни Йоханессена (Johnny Johanessen) и Эла Стокерта (Al Stockert) из Bell Telephone Laboratories, Свен-Олофа Рефтмарка (Sven-Olof Reftmark) и Гарри Нордстрома (Harry Nordstrom) из шведского отделения Philips, Жерара Бовена (Gerard Bau-vin) из La SLIGOS, Рона Хестера (Ron Hester), который теперь работает в IMI Systems, Билла Плогера (Bill Plauger) из Whitesmiths, Ltd., Нэнси Римкус (Nancy Rimkus) из American Express, а также Джерри Винера (Jerry Wiener), где бы он ни был.

Ко второму изданию

Благодарности за издание 1999 года мы выражаем сотрудникам издательства Dorset House — Дэвиду Мак-Глинтоку (David McGlintock), Майклу Лумельски (Michael Lumelsky), Мэтту Мак-Дональду (Matt McDonald), а также Венди Икин (Wendy Eakin) — за редактуру и мудрые советы относительно новых глав. За особую проницательность и более общие советы спасибо Петеру Хрушке (Peter Hruschka), Стиву Мак-Менамину (Steve McMenamin), Марку Вейзу (Mark Weisz), Брюсу Тейлору (Bruce Taylor), известному как Walter «Bunny» Formaggio, Джеймсу Баху (James Bach), Ричарду Коэну (Rich Cohen), Тому Мацубара (Tomoo Matsubara), Цуенео Ямаура (Tsueneo Yamaura), а также Вероне Чард (Verona Chard).

Предисловие ко второму изданию

Мы пишем эти слова по горячим следам десятой годовщины первого издания «Peopleware».
Когда книга увидела свет много лет назад, мы были уверены, что дело сделано, однако время, а также письма по обычной и электронной почте убедили нас в обратном. Было похоже, что нас выдвинули на должность опекунов международного центра документирования эволюции управления человеческими ресурсами. Читатели со всех уголков земного шара присылали нам истории о новых видах травли команд разработчиков, облавах мебельной полиции и сопротивлении оной, а также о всевозможных глупостях руководителей, связанных с визуальным наблюдением, шумом на рабочем месте и способами мотивирования, которые только лишают мотивации. Мы получали письма об организациях, где работа столь увлекательна, что сотрудники испытывают стеснение, обналичивая зарплатные чеки, а руководители проектов преуспели в формировании стабильных и процветающих общин, призванных решать рабочие задачи.
Кроме того, мы обнаружили, что можем ещё очень многое сказать по теме. Наш собственный опыт в вопросах управления человеческим ресурсом продолжал расти в процессе проектного консультирования и работы с руководителями наших клиентов. Медленно, но верно исполин Хольгер Датчанин приходил в движение. (Чтобы понять, о чем речь, прочтите главу 26.) Когда он призывает вас, игнорировать этот зов можно только на свой страх и риск. Вот так появилось второе издание.
Перечитывая «Peopleware» постаревшими глазами, мы обнаружили нечто такое, что не было очевидным в момент выхода первого издания: эта книга не столько собрание очерков (так мы обозначили её содержимое в предисловии к первому изданию), сколько книга историй. За каждым из описанных принципов стоит своя история. Существует и другая история — о том, как эти принципы повлияли на наши собственные карьеры.
В первом издании нерассказанной осталась история самой книги «Peopleware» — история о том, как она была написана и какое влияние оказала на авторов. Это книга о сотрудничестве, написанная в сотрудничестве. Это книга о командах, которая была создана командой — авторами, редакторами, художниками, рецензентами. Создание этой книги лучше всего прочего проиллюстрировало одну из самых важных её тем — владеть фрагментом хорошо сделанной работы почему-то приятнее, чем владеть всем безраздельно. Такая мысль может казаться странной, но если вы когда-либо входили в гармоничную рабочую группу или правильную команду, то поймёте, о чем речь.
Во втором издании мы добавили ещё одну часть, шестую, а в первые пять внесли лишь некоторые мелкие изменения. К пересмотру заключений первого издания нас привела одна из новых практик рабочего взаимодействия — голосовая почта. В главе 11 первого издания мы пытались убедить читателей, что временная остановка с целью ответа на телефонный звонок в момент интенсивной умственной активности может иметь только один результат — рассредоточение и потерю производительности. Очень похоже, что вы согласились — с момента выхода этой книги мы никогда и никому не можем дозвониться. Обращение с телефоном изменилось как в лучшую, так и в худшую сторону, и в пересмотренной концовке главы 11 мы расскажем о том, что узнали о помехах и разумном управлении рабочей средой благодаря голосовой почте.
Новая часть VI «Наследие Peopleware» включает главы о командах и их травле, о программах по улучшению процессов, о внутреннем соперничестве, об изменениях и управлении изменениями, о человеческом капитале, о трате времени, о корпоративном обучении и о том, что мы называем аристотелевой политикой.
Август 1998
Том Демарко
Камден, Мэн
Тим Листер
Нью-Йорк

Предисловие к первому изданию

Если вам приходилось участвовать в серьёзных проектах по разработке, вы практически наверняка знакомы с мудростью поговорки «Первый блин комом». Только закончив работу, вы обладаете полноценным знанием о том, как её следовало делать. Очень редко удаётся сделать шаг назад и выполнить работу заново, но приятно было бы иметь такую возможность.
Эта же мысль справедлива и для карьеры в целом. Мы вдвоём потратили около тридцати лет на управление проектами и консультирование в этой области. В основном мы приобретали знания в результате того, что первый блин выходил комом. И ни разу нам не была доступна роскошь вести любой из этих проектов заново, чтобы сделать все абсолютно безошибочно. Поэтому мы написали книгу.
Она состоит из серий кратких очерков, каждый из которых посвящён одной тропинке, приводящей руководителей к сожалению о содеянном. Как правило, их побуждает к ошибочным действиям какой-то аспект управленческого фольклора, столь вездесущего и популярного, но зачастую некорректного. Мы и сами поддались искушению пройти по всем этим тропинкам. Если цель написания книги достигнута, она поможет вам избежать хотя бы некоторых ошибок.
Фольклор пестрит простыми рецептами: возьмите оценку трудоёмкости, данную сотрудником, и умножьте её на два. Не снижайте давления; не позволяйте людям работать дома, они станут филонить. На страницах книги есть какие угодно рецепты, кроме простых. Они привлекают ваше внимание к сложным потребностям человеческой индивидуальности, к острой внутриполитической обстановке офисной среды, к головоломке удержания ценных кадров, к интригующим и порой неимоверно раздражающим вопросам командной работы и наконец — к труднодостижимому состоянию удовлетворения.
Данный труд является для нас очень личным, поэтому время от времени повествование идёт от первого лица, и инициалы позволят вам понять, кому из авторов принадлежат эти слова.
Сентябрь 1987
Том Демарко
Камден, Мэн
Тим Листер
Нью-Йорк

I. УПРАВЛЕНИЕ ЧЕЛОВЕЧЕСКИМ РЕСУРСОМ

Мы, руководители, в большинстве своём подвержены одной характерной ошибке: мы склонны управлять людьми так, словно они — модульные компоненты. Вполне очевидно, откуда берётся эта тенденция. Вспомните, как происходит подготовка к руководству: считается, что мы вполне подходим на руководящие роли, если хорошо себя зарекомендовали в качестве исполнителей, техников и разработчиков. От исполнителей часто требуется организация ресурсов в модули: фрагменты программного кода, микросхемы и другие рабочие блоки. Подобным модулям присущи свойства чёрного ящика, так что их внутреннее своеобразие можно спокойно игнорировать. Они задуманы как предметы, имеющие стандартные интерфейсы.
Мы полагаемся на модульные методы в течение многих лет, и не удивительно, что в качестве начинающих руководителей пытаемся применить их для управления человеческими ресурсами. Увы, для человеческих ресурсов эти методы не совсем пригодны.
Первая часть этой книги начинает наше исследование совершенно иного способа думать о людях и управлять ими. И этот способ требует привыкания к совершенно не модульному характеру человеческого ресурса.

1. А в это время где-то гибнет проект

С тех пор как компьютеры стали доступны широким массам пользователей, разработчики создали, должно быть, десятки тысяч бухгалтерских программ. Вероятно, ещё десяток (или больше) таких проектов кто-то ведёт прямо сейчас, когда вы читаете эти строки. И как раз в это время один из них терпит крушение.
Представьте себе! Проект, не требующий никаких технических новшеств, разваливается на глазах. Бухгалтерский учёт — это колесо, которое изобретали заново столь часто, что многие разработчики-ветераны способны участвовать в таком проекте чуть ли не с закрытыми глазами. И все же подобные предприятия время от времени оканчиваются неудачей.
Предположим, после одной из таких катастроф вас попросили сделать вскрытие. (Мечтать не вредно: существует нерушимый отраслевой стандарт, запрещающий изучать провалы.) Предположим, что вам выпал шанс выяснить причины неудачи, прежде чем участники проекта успели разбежаться кто куда. Среди причин, потопивших проект, не будет ни слова о технологии. Можно с уверенностью сказать, что в наши дни системы бухгалтерского учёта технически возможны. Должно быть иное объяснение.
Начиная с 1977 года мы ежегодно проводили исследования проектов разработки и анализ их результатов. Мы оценивали размеры, стоимость, недостатки, факторы ускорения, а также соответствие развития проекта предполагаемым срокам. К настоящему моменту мы собрали более пятисот историй различных проектов, и в каждой из них мы видим реальный труд разработчиков[1].
Около пятнадцати процентов всех проектов закончились ничем — были отменены, прерваны, отложены или их результатом стали никому не нужные продукты. В случае крупных проектов картина ещё хуже. Крах постиг двадцать пять процентов проектов, длительность которых составляла от двадцати пяти человеко-лет[2]. В ранних исследованиях мы отбрасывали провалы и изучали данные прочих проектов. Однако начиная с 1979 года мы обязательно связывались с участниками неудавшихся проектов и узнавали, что пошло не так. В подавляющем большинстве случаев не было ни одной объясняющей неудачу причины из области технологии.

Суть вопроса

Чаще всего участники наших опросов в качестве причины краха называли «политику». Следует учесть, что люди трактуют это понятие достаточно широко. В «политику» входят такие несвязанные или слабо связанные между собой вещи, как проблемы коммуникации, проблемы с персоналом, разочарование в начальнике или заказчике, недостаточная мотивация и высокая текучесть кадров. Человек часто употребляет слово политика для описания любого аспекта работы, имеющего отношение к людям, но в языке есть гораздо более точный термин для таких аспектов: они составляют социологию проекта. Трудности действительно политического толка составляют лишь крохотное, незначительное подмножество всех трудностей.
Если считать проблему политической по природе, то в отношении к ней неизбежно появляется фатализм. Вы знаете, что способны справиться с техническими сложностями, но, если честно, кто из нас чувствует себя уверенно в области политики? Если же понять, что природа проблемы социологическая, а не политическая, то решить эту проблему будет намного проще. Социология проекта и команды может выходить за рамки вашей компетенции, но не способностей.
Как ни называй проблемы, связанные с людьми, именно они, вероятнее всего, станут причиной неприятностей в вашем следующем проекте, а вовсе не вопросы проектирования, реализации и методологии. По сути, именно эта мысль и проходит красной нитью через всю книгу:

Серьёзные проблемы в нашей работе имеют не столько технологическую сколько социологическую природу.

Многие руководители готовы согласиться с тем, что сталкиваются больше с человеческим фактором, нежели с техническими сложностями.
Однако они редко учитывают это на практике. Они руководят так, будто их главной заботой является именно технология. Они проводят столько времени в размышлениях о самых запутанных и интересных головоломках, которые предстоит решать подчинённым, будто сами собираются делать эту работу, а не руководить коллективом. Они находятся в вечном поиске технологического прибамбаса, который должен автоматизировать часть работы (более подробно об этом эффекте рассказано в главе 6 «Лаетрил»), тогда как направление их деятельности, связанное с человеческим ресурсом, зачастую получает низший приоритет.
Причиной такому феномену служит отчасти процесс воспитания среднего руководителя. Его учили тому, как выполнять работу, а не как руководить работой. Редко когда новый руководитель может похвастаться чем-то, что указывало бы на его способность или склонность к руководству. У них мало опыта руководства и отсутствует осмысленная практика. Но каким же образом новым руководителям удаётся убедить себя, что они могут спокойно тратить большую часть своего времени на размышления о технологии и совсем чуть-чуть (или нисколько) на размышления о человеческой стороне проблемы?

Миражи высоких технологий

Ответ, возможно, кроется в явлении, которое мы окрестили миражами высоких технологий. Это распространённая убеждённость людей, имеющих дело с любым аспектом новой технологии (а кто из нас не имеет?), что они работают в сфере действительно высоких технологий. Они потворствуют развитию этой иллюзии, объясняя на какой-нибудь вечеринке, что работают «в области компьютеров» или же «в области телекоммуникаций» или занимаются «электронным переводом денежных средств», намекая тем самым, что принадлежат к миру высоких технологий. Между нами говоря, обычно это не так. Исследователи, совершающие фундаментальные прорывы в перечисленных областях, действительно из мира высоких технологий. А мы лишь используем результаты их труда. Компьютеры и прочие элементы новых технологий служат нам для организации собственных предприятий. Наши рабочие единицы — команды, проекты и взаимосвязанные рабочие группы, а потому наша область деятельности — преимущественно человеческое взаимодействие. Наш успех напрямую зависит от качественного человеческого взаимодействия всех участников предприятия, а наши неудачи являются прямым следствием недостатка человеческого взаимодействия.
Главная причина, по которой мы склонны сосредоточивать усилия на технической, а не на человеческой стороне работы, — вовсе не приоритет первой перед второй. Технические вопросы проще решать. Гораздо проще организовать установку нового оптического привода, чем выяснить, почему Хорас в замешательстве или почему Сьюзен выражает недовольство компанией уже после нескольких месяцев работы. Человеческие взаимодействия сложны, их проявления не бывают очевидными и прозрачными, но они имеют большее значение, чем любой другой аспект работы.
И если вы концентрируетесь больше на технологии, чем на социологии, то уподобляетесь персонажу водевиля, который потерял ключи на тёмной улице, а ищет их на соседней, потому что, как объясняет он сам: «Там не так темно».

2. Сделал чизбургер — продай его

Разработка по природе своей отличается от производства. Однако руководителям предприятий по разработке и смежных с ними свойственен образ мышления, уходящий корнями исключительно в производственную среду.
Представьте на секунду, что вы — менеджер местного предприятия быстрого питания. Перечисленные ниже меры повышения эффективности производства, причём в любой комбинации, будут полностью оправданны:
  • Исключить ошибки. Заставить машину (коллектив) работать гладко, насколько возможно.
  • Занять жёсткую позицию в отношении сотрудников, склонных филонить на рабочем месте.
  • Считать служащих взаимозаменяемыми винтиками.
  • Оптимизировать стабильное состояние. (Даже не задумываясь о том, как производство вышло на полную мощность или каким образом его возможно остановить.)
  • Стандартизировать процедуру. Делать все по инструкции.
  • Исключить эксперименты — за это получают деньги те, кто сидит в штаб-квартире.
    Подобные меры были бы разумными для бизнеса быстрого питания (или любой производственной среды), но вы работаете в другой сфере. Подход «сделал чизбургер — продай его» может стать фатальным для вашей разработки. Он способен лишь подавить дух сотрудников и отвлечь их внимание от проблем, подлежащих решению. Такой стиль управления противоречит сути работы.
    Чтобы эффективно управлять людьми в области интеллектуального труда[3], необходимо принимать меры, противоположные перечисленным выше. Эти противоположные меры описаны в последующих разделах.

    Допустимость ошибок

    Для большинства работников, занятых в сфере интеллектуального труда, допускаемые время от времени ошибки — вполне естественная и безопасная составляющая деятельности. Но иногда между ошибкой в работе и грехом проводятся почти библейские ассоциации. Для того чтобы изменить подобное отношение, необходимо принять действительно серьёзные меры.
    В разговоре с группой руководителей проектов по разработке программного обеспечения мы представили стратегию, которую считаем случаем итеративного проектирования . Идея заключается в том, что некоторые проектные решения изначально содержат недостатки, и такие решения следует выбрасывать, а не пытаться исправить. При проектировании следует ожидать появления подобных тупиков. Усилия, потраченные на тупиковую разработку, — небольшая цена за возможность начать с чистого листа. К нашему удивлению, многие руководители считают, что такой подход станет неразрешимой политической проблемой для их собственного начальства: «Как мы можем выбросить продукт, в производство которого наша компания вложила деньги?» Похоже, они считают, что лучше все же спасать дефектный вариант, пусть это в перспективе и обойдётся дороже.
    Поощрение атмосферы, не позволяющей допускать ошибки, просто заставляет людей занимать оборонительные позиции. Они не пробуют подходы, способные закончиться отрицательным результатом. Вы же поощряете такое поведение, пытаясь упорядочить процесс и использовать жёсткие методологии, ради исключения ошибок запрещающие сотрудникам принимать ключевые стратегические решения. Любые меры, препятствующие совершению ошибок, могут лишь ненамного поднять уровень технологии, а вот социология команды может пострадать весьма серьёзно.
    Противоположный подход — поощрение нечастых ошибок. Время от времени спрашивайте у своих подчинённых, с какими тупиковыми ситуациями они столкнулись, и постарайтесь объяснить, что ответ «такого не было» — не самый лучший. Когда люди совершают ошибки, их следует поздравлять, потому что они получают деньги в том числе и за ошибки.

    Менеджмент, простецкое определение

    Менеджмент — понятие достаточно сложное, чтобы ему можно было дать простое определение, однако этот нюанс ускользнул от одного менеджера высшего звена, с которым мы общались на профессиональном конвенте в Лондоне. Своё понимание предмета он суммировал так: «Менеджмент — это умение пинать сотрудников». Это равнозначно мнению, что руководители в основном думают, а подчинённые лишь выполняют их волю. Опять же, для производства чизбургеров это, быть может, вполне продуктивный подход, но и только; он не действует для предприятия, в котором люди работают головой, а не руками. В подобной сфере мозг каждого участника должен участвовать в процессе. Посредством пинков вы сможете в лучшем случае активизировать сотрудников, но не добиться от них творческого подхода, вдумчивости и изобретательности.
    Даже если бы воздействие на пятую точку давало кратковременный прирост производительности, в перспективе оно могло бы оказаться не столь полезным: нет ничего более обескураживающего для любого работника, чем чувство, что его собственной мотивации не хватает и потому требуются «добавки» со стороны начальства.
    Самое печальное в таком подходе к руководству — это то, что он практически никогда не оправдан. Большинство сотрудников любят свою работу, и чаще всего не требуются жёсткие меры, чтобы они продолжали работать. Напротив, может возникнуть необходимость сделать так, чтобы они работали меньше, но более осмысленно (эту идею мы развиваем в главе 3).

    Человеческие запчасти

    В производственной сфере людей удобно считать частями рабочего механизма. Когда часть механизма износилась, её заменяют на другую. Замена совместима с оригиналом, поэтому новую можно, грубо говоря, заказать по каталогу.
    Многие руководители проектов по разработке придерживаются такого же подхода. Они идут на все, убеждая себя, что нет незаменимых людей. Из страха, что ключевой человек уйдёт, они заставляют себя считать, что ключевых людей попросту не существует. Разве не в этом, в конце концов, сущность менеджмента — делать так, чтобы работа не останавливалась в случае ухода отдельных людей? Эти руководители ведут себя так, словно существует волшебный магазин человеческих запчастей, куда можно позвонить с примерно такой просьбой: «Пришлите мне нового Джорджа Гарденайера, только пусть он будет не такой дерзкий».
    Один мой клиент поднял вопрос о повышении зарплаты одному из превосходных сотрудников и, к своему удивлению, узнал, что этому человеку нужно нечто другое, не деньги. Сотрудник сообщил, что дома у него часто появляются хорошие идеи, но работа через медленный коммутируемый терминал слишком неудобна. Не может ли компания провести ему домой выделенную линию и купить высокопроизводительный терминал? Компания так и сделала. В последующие годы она даже создала и обставила для этого сотрудника маленький домашний офис. Но этот мой клиент — нетипичный случай. Интересно, что сделал бы менее восприимчивый руководитель? Слишком уж многие руководители остро реагируют на любые попытки сотрудников подчеркнуть собственную индивидуальность.
    Т. Д.
    Вот один пример такого менее восприимчивого руководителя, взятый из жизни. Этот начальник крайне остро реагировал на индивидуальность своих подчинённых. Один весьма талантливый сотрудник большую часть года проводил на площадках клиентов и, как следствие, жил на командировочные. Анализ расходов этого сотрудника показал, что расходы на питание сильно отличаются от расходов других «путешественников» по этой статье. На еду он тратил в полтора раза больше других. В негодующем открытом письме начальник заклеймил «гастрономического преступника». Между прочим, общие расходы этого сотрудника не выбивались из ряда: излишние расходы на еду он компенсировал экономией в других областях. Он не обходился компании дороже, он просто был не таким, как все.
    Уникальность каждого человека — постоянный раздражитель для руководителя, слепо уверовавшего в стиль управления, взятый из производственной сферы. Руководитель, умеющий работать с людьми, напротив, осознает, что именно уникальность участников является залогом активности и эффективности внутрипроектных отношений.

    Стабилизация проекта означает его смерть

    Образ мышления, характерный для производства, находящегося в стабильном состоянии, особенно плохо сочетается с ведением проектов. Мы склонны забывать, что самоцель существования проекта состоит в том, чтобы выйти из бизнеса. Единственное стабильное состояние в жизни проекта — трупное окоченение. Управление проектом должно сосредоточиваться на динамике его развития, разумеется, за исключением случаев, когда вы управляете проектом уже прерванным или находящимся на грани отмены. Но почему-то ценность людей для нового проекта мы вычисляем, исходя из их стабильных показателей: сколько кода они могут написать или сколько могут задокументировать. И слишком мало внимания уделяем тому, какой именно качественный вклад каждый из них может внести в развитие предприятия.
    Несколько лет назад я вёл курс проектирования в одной фирме, и один из менеджеров высшего звена буквально преследовал меня просьбой оценить некоторых слушателей (сотрудников его проекта). Особенно его интересовала одна женщина. Его сомнения выражались так: «Не совсем понимаю, какая польза от неё проекту — она не гениальный разработчик, не очень разбирается в тестировании, да и вообще в чем-либо ещё». Небольшое расследование выявило любопытный факт: за двенадцать лет работы в компании эта женщина участвовала исключительно в проектах, закончившихся гигантским успехом. Её вклад был неочевиден, но проект с её участием неизменно был удачным. Понаблюдав за ней на занятиях с неделю и переговорив с её коллегами, я пришёл к выводу, что эта женщина — великолепный катализатор. В её присутствии команда начинала работать легко. Она помогала людям общаться и ладить. Проекты с её участием не были скучными. Попытавшись донести эту мысль до руководителя, я потерпел неудачу. Он попросту не считал катализатор жизненно необходимым для проекта.
    Т. Д.
    Катализатор важен, потому что проект постоянно находится в движении. Человек, способный заставить проект шевелиться, стоит двух, просто выполняющих работу.

    У нас есть время только выполнить работу, но не думать о ней

    Если на вас лежит ответственность за выполнение задания, какую долю времени следует потратить непосредственно на выполнение? Не сто процентов. Необходимо предусмотреть время на мозговые штурмы, на изучение новых подходов, на поиск экономичных решений, на чтение, подготовку, да и просто безделье.
    Вспоминая годы, когда мы сами руководили проектами, мы пришли к заключению, что подходили к этому вопросу неправильно. Слишком много времени тратили на попытки получить результат и недостаточно на ключевой вопрос: а нужны ли вообще эти результаты? Принцип стабилизированных чизбургеров даже рядом не валялся с идеей о размышлениях на работе. Единственная его цель — по максимуму свести все усилия к действию. Если надо как-то объяснить недостаток времени на размышления, то этим объяснением всегда становятся сжатые сроки. Можно подумать, существует работа, не подверженная давлению сроков.
    Потребность в более взвешенном подходе возрастает по мере того, как растут ставки. Лишь когда требуются поистине титанические усилия, мы начинаем постигать другой режим, в котором больше времени уделяется размышлениям о работе и меньше собственно выполнению работы. Чем больше требуется героических усилий, тем важнее, чтобы люди в команде учились взаимодействовать эффективно и получать от этого удовольствие. Именно проект, сдача которого запланирована на нереальную фиксированную дату, более всего нуждается в частых мозговых штурмах и даже в неформальной проектной тусовке или любом подобном мероприятии — во всем, что помогает объединить отдельных участников в эффективное целое.
    Но ведь все эти нежности совершенно неуместны. Каждый знает и действует с пониманием, ведь так? Не так. Мы столь слепо стремимся к Достижению Чего-Либо, Чего Угодно, что тратим лишь скудные пять процентов своего времени на деятельность, посвящённую планированию, исследованию новых методов, обучению, чтению книг, прогнозированию, бюджетному планированию, а также распределению кадров. (Показатель в пять процентов получен путём анализа проектов по системной разработке, но применим, похоже, более широко к целой категории работников, сидящих на окладе[4].)
    Статистика по чтению литературы обескураживает особенно сильно: средний разработчик программного обеспечения, к примеру, не имеет ни единой книги по предмету собственной работы и не может похвастать тем, что читал такую книгу[5]. Это ужасающий факт для тех, кто обеспокоен качеством работы в отрасли, а уж для тех, кто пишет книги, как мы, совершенно катастрофический.

    3. Вена ждёт тебя

    Несколько лет назад мы с руководителем крупного проекта из Южной Калифорнии делились боевым опытом. Он стал перечислять последствия, которые проект и безумное количество потраченных на него рабочих часов имели для его сотрудников. Два развода можно было отнести непосредственно на счёт сверхурочных, а сын одного из сотрудников попал в какую-то нехорошую историю, связанную с наркотиками, вероятно, потому, что его папа был слишком занят в тот год и не мог уделять время своим родительским обязанностям. И наконец, нервный срыв руководителя группы тестирования.
    Пока он перечислял все эти ужасы, я постепенно осознал, что он просто хвастает — на свой странный манер. Надо думать, если добавить ещё один-два развода и самоубийство, проект стал бы абсолютно успешным, по крайней мере, в его глазах.
    Т. Д.
    Несмотря на все разговоры в ключе «надо работать с умом», существует распространённое мнение, что менеджмент на самом деле существует исключительно для того, чтобы заставить людей работать интенсивнее и больше, в основном за счёт их личной жизни. Не смолкают горны руководителей, оповещающие о сверхурочных часах и о том, как увеличить продолжительность этих часов.

    Испанская теория управления

    Историки уже давно вывели абстракции различных систем ценностей. Так, испанская теория утверждает, что ценности на Земле имеют некую конечную фиксированную стоимость и путь к накоплению богатства — узнать, как эффективнее всего эту стоимость извлекать из природных ресурсов или рабского человеческого труда. Английская же теория постулирует, что ценности можно создавать и нужны для этого изобретательность и технология. Короче говоря, англичане провернули промышленную революцию, пока испанцы крутили свои колёса и пытались эксплуатировать землю и индейцев в Новом Свете. Испанцы перевезли неимоверные объёмы золота через океан и получили в результате лишь грандиозную инфляцию (огромные суммы золотом против слишком малого количества полезных товаров).
    Испанская теория ценностей жива и здорова в сознании многих руководителей. Это становится ясно, как только они заговаривают о производительности. Увеличение производительности по идее означает увеличение объёма полезной работы, выполняемой за определённый период времени, но слишком часто на практике выходит, что это стремление получить больше за оплаченный час работы. Разница велика. Руководители, следующие испанской теории, мечтают о достижении новых уровней производительности посредством простого механизма неоплаченных сверхурочных. Они делят выполненную в течение недели работу на сорок часов, а не на те восемьдесят или девяносто, которые в действительности затратил работник.
    Это не совсем производительность (скорее мошенничество), но такова повседневная деятельность многих американских менеджеров. Кнутом и пряником они заставляют своих людей работать дольше. Они внушают, насколько важна дата выдачи продукта (хотя дата эта может быть совершенно произвольной, конец света не наступит только из-за того, что проект на месяц опоздал). Они заставляют людей принимать безнадёжно жёсткие графики, заставляют принести в жертву все, чтобы уложиться в сроки, и делают все возможное, чтобы заставить людей работать дольше и усерднее.

    Письмо из дома

    Возможно, ваш персонал на работе находится под воздействием принципа «работай больше и усерднее», однако дома человек находится во власти совсем иных мыслей. Например, таких: «Жизнь проходит. Нестираное бельё переполняет шкаф, детей некому обнять, супруг(а) начинает смотреть налево. Карусель жизни совершает лишь один оборот, и есть только один шанс добиться успеха. А ты тратишь свою жизнь на COBOL…»
    But you know when the truth is told,
    That you can get what you want or you can just get old.
    You're going to kick off before you even get halfway through.
    When will you realize... Vienna waits for you?
    «The Stranger», Billy Joeli[6]

    (Но если совсем уж по правде сказать,
    Можешь выиграть приз или старым ты стать,
    И концы ты отдашь, полпути не пройдя,
    Когда ты поймёшь, что… Вена ждёт тебя?)

    Вена, которая, по словам Билли Джоэла, ждёт тебя, — это последняя остановка на твоём жизненном пути. Когда ты окажешься там, все будет кончено. Если вам кажется, что участников проекта никогда не интересуют такие серьёзные вещи, подумайте получше. Ваши люди очень остро понимают, что человеку дана лишь одна короткая жизнь, и они слишком хорошо знают, что в этой жизни должно быть что-то поважнее, чем их глупая работа.

    Сверхурочные не существуют

    Сверхурочные сотрудников, сидящих на окладах, — это плод воображения наивного руководителя. Да, в паре лишних субботних часов, позволяющих уложиться в сроки и сдать проект в понедельник, может быть очевидная польза, но за ними всегда следует равносильный период компенсации, сокращения рабочего времени, позволяющий сотрудникам вернуться в ритм привычной жизни. В конечном итоге каждый час сверхурочных компенсируется часом недоработки. В краткосрочной перспективе такой компромисс может принести пользу проекту, но в долгосрочной польза нивелируется.
    Slow down you crazy child,
    And take the phone off the hook and disappear for a while.
    It's all right. You can afford to lose a day or two.
    When will you realize... Vienna waits for you?

    (Замедли свой бег, безумный ребёнок,
    Отключи телефон и передохни,
    Все в порядке, позволь себе день или два,
    Когда ты поймёшь, что… Вена ждёт тебя?)

    Для руководителя, следующего испанской теории, недоработанное время невидимо точно так же, как и сверхурочные, поскольку он всегда считает, что в рабочей неделе сорок часов независимо от того, сколько на самом деле потратили сотрудники. Это время невозможно увидеть в чьём-либо расписании. Это время разговоров по телефону, бесед в курилке или просто отдыха. Нет такого человека, который мог бы постоянно работать намного больше сорока часов в неделю, сохраняя уровень интенсивности, необходимый для творчества.
    Сверхурочные похожи на спринт: он имеет смысл на последней стометровке марафонской дистанции для тех людей, у которых ещё остались силы, но если начать спринт на первом километре, вы только зря потеряете время. Если заставлять людей постоянно бежать в темпе спринта, они лишь потеряют уважение к руководителю. Лучшие из сотрудников уже все это проходили — они будут молчать и закатывать глаза, пока руководитель бредит, что эту работу просто необходимо закончить к апрелю. После этого они воспользуются компенсирующими недоработками и в конечном итоге каждую неделю будут работать не более сорока часов. Так реагируют лучшие; все остальные — просто трудоголики.

    Трудоголики

    Трудоголики не компенсируют свои сверхурочные. Они согласны работать лишние часы, пусть и с понижающейся эффективностью. При достаточном давлении трудоголик способен далеко зайти по пути разрушения собственной личной жизни. Но это все лишь на время. Рано или поздно даже самых отъявленных трудоголиков осенит:
    Slow down, you're doing fine,
    You can't be everything you want to be before your time.
    Although it's so romantic on the borderline tonight.
    But when will you realize... Vienna waits for you?

    (Замедли свой бег, все в порядке,
    Ты достигнешь всего, когда время придёт,
    И пусть на границе сегодня романтика,
    Когда ты поймёшь, что… Вена все ещё ждёт?)
    Переварив эту идею, сотрудник навсегда перестаёт быть полезным для проекта. Осознание того, что большие ценности (семья, любовь, дом, молодость) принесены в жертву меньшим (работа), разрушительно. Оно заставляет человека, совершившего столь глупую жертву, искать отмщения. Он не пойдёт к шефу, чтобы спокойно и вдумчиво объяснить, что положение вещей должно измениться; он просто уйдёт — ещё один человек, который сгорел на работе. Так или иначе, его больше не будет.
    Трудоголизм — это заболевание, но оно не похоже на алкоголизм, затрагивающий лишь некоторых из нас. Трудоголизм больше похож на насморк — с каждым случается время от времени. И мы вспомнили об этой болезни не затем, чтобы обсудить причины и лечение, а чтобы поднять вопрос об отношении руководителя к трудоголикам. Если вы станете эксплуатировать таких людей до изнеможения, в стиле испанской теории, то рано или поздно потеряете их. Неважно, насколько отчаянно проект нуждается в их сверхурочных часах, вы не должны допускать, чтобы эти часы вычитались из личной жизни сотрудников. Потеря хорошего сотрудника того не стоит. Эта мысль выходит за узкие рамки вопросов трудоголизма и продолжается в более сложной области осмысленной производительности.

    Производительность: выигранные сражения и проигранные войны

    В следующий раз, слушая чьи-либо соображения по поводу производительности, обратите внимание, употребляет ли говорящий слово текучка. Скорее всего — нет. За многие годы мы стали свидетелями многочисленных споров о производительности и прочли сотни статей по этой теме, но ни один специалист не мог ничего внятного сказать о текучести кадров. Но какой смысл обсуждать одно, не вспоминая о другом? Рассмотрим некоторые типичные меры, предпринимаемые для повышения производительности:
  • Давление на людей, цель которого — получить больше человеко-часов
  • Автоматизация процесса разработки продукта
  • Пренебрежение качеством продукта (более подробно в главе 4)
  • Стандартизация процедур
    Каждая из этих мер может сделать работу менее интересной и захватывающей. Следовательно, процесс повышения производительности связан с риском увеличения текучести рабочей силы. Разумеется, производительность невозможно увеличивать без этого. Просто всегда следует учитывать текучесть кадров, принимая решение стремиться к увеличению производительности. В противном случае можно получить «повышение», которое будет компенсировано потерей ключевых сотрудников.
    В большинстве организаций даже нет статистики текучести кадров. Практически никто не может вычислить, сколько стоит замена опытного сотрудника. А когда речь идёт о производительности, все делают вид, что текучка не существует или бесплатна. Подходящий пример — проект Eagle в Data General[7]. С точки зрения испанской теории проект триумфальный: трудоголики, занятые в проекте, вкладывали бесконечные часы неоплачиваемых сверхурочных, чтобы поднять производительность на недосягаемые высоты. По окончании проекта практически все разработчики уволились. Какова была стоимость этой потери? Никто не позаботился включить её в уравнение.
    Производительность следует определять как отношение выгоды к затратам, где выгода — экономия, выраженная в долларах, плюс прибыль от выполненной работы, а затраты — полная стоимость проекта, включая стоимость замены сотрудников, сгоревших на работе.

    Резюме

    В прошлом году я консультировал проект, продвигавшийся столь гладко, что его руководитель была уверена — продукт будет сдан в срок. Её вызвали на совещание руководства и попросили сделать доклад о ходе работ. Она гарантировала, что продукт будет готов к установленному сроку — к первому марта, в полном соответствии с изначальными планами. Начальство почесало в затылках, получив столь неожиданные хорошие новости, и снова вызвало её на следующий день. Поскольку она успевает закончить проект к первому марта, сказали они, то решено перенести сроки сдачи на пятнадцатое января.
    Т. Д.
    Сроки, в которые проект мог реально уложиться, совершенно не интересовали этих «испанских теоретиков», поскольку с таким расписанием люди не находились бы под давлением. Пусть лучше будет безнадёжное расписание, которое позволит извлекать максимум труда из работников.
    Весьма вероятно, что вы встречали одного или нескольких таких теоретиков на своём трудовом пути. Можно, конечно, посмеиваться над их близорукостью, но не думайте, что вы сами уже слезли с этой иглы. Каждый из нас хотя бы изредка поддаётся соблазну на короткий срок увеличить давление, чтобы заставить людей работать более интенсивно. При этом приходится закрывать глаза на снижение эффективности и конечную текучесть кадров, но игнорировать отрицательные побочные эффекты очень просто. Гораздо сложнее помнить вот такую неприятную истину:

    Под давлением люди работают не лучше, а всего лишь быстрее.

    Чтобы работать быстрее, им приходится жертвовать качеством продукта и собственным удовлетворением от работы.

    4. Качество? Если успеем

    Психологическая теория двадцатого века гласит, что характер человека находится под влиянием немногочисленных основных инстинктов, таких как выживание, самооценка, продолжение рода, территориальный инстинкт и так далее. Эти инстинкты записаны в аппаратной прошивке мозга. Их можно анализировать на интеллектуальном уровне, не поддаваясь эмоциям (что мы сейчас и делаем), но когда инстинкты проявляются на чувственном уровне, от страстей избавиться невозможно. Малейшее воздействие на любую из этих встроенных ценностей может вывести человека из равновесия.
    Сильные эмоции являются показателем того, что одна из инстинктивных ценностей находится под угрозой. Начинающий руководитель может полагать, что работу можно сделать, не затрагивая человеческих эмоций, но если у вас есть хотя бы небольшой опыт руководства, вы полностью уверены в обратном. Наша работа даёт много возможностей для проявления эмоций.
    Скорее всего, вы легко вспомните по меньшей мере один случай, когда эмоциональный всплеск был вызван чем-то, связанным исключительно с работой. Подумайте об этом случае и задайтесь вопросом (вероятно, в который уже раз) — откуда взялись все эти эмоции? Не имея никакой информации о данном конкретном случае, мы готовы спорить, что причиной была угроза самооценке. В личной жизни причины эмоциональных реакций многочисленны и разнообразны, но на рабочем месте главным источником душевных потрясений является самооценка, находящаяся под угрозой.
    Мы склонны считать, что существует сильная связь между самооценкой и качеством создаваемого продукта — не количеством , а именно качеством. (Почему-то сдача большого количества продукции среднего уровня не приносит удовлетворения, хотя именно таковы могут быть требования момента.) Любой шаг, который может угрожать качеству продукта, весьма вероятно станет для сотрудников источником эмоций, направленных против вас.

    Бегство от совершенства

    Руководители ставят под угрозу качество продукта, устанавливая невозможные сроки его сдачи. Но они вовсе не задумываются об этом; они полагают, что такие действия ставят перед сотрудниками интересную задачу, которая поможет им стремиться к совершенству.
    Опытные (вернее, заезженные) сотрудники знают, что все не так. Они понимают, что под дулом автомата их старания будут чрезмерно стеснены. У них не будет возможности распорядиться ресурсами так, чтобы своевременно сдать продукт. Не говоря уже о привлечении дополнительных участников или перераспределении функций. Единственное, чем можно будет пожертвовать, — это качество. Крайняя степень давления сроков заставит их принести качество в жертву. Они станут заметать проблемы под ковёр, чтобы разобраться с ними в последний момент или вовсе оставить в продукте на «радость» конечному пользователю. Они будут сдавать продукты нестабильные и незавершённые. Они возненавидят свою работу, но какой у них выбор?
    Практичный боевой руководитель внутри вас ответит на это: «Кое-кто из моих ребят может до бесконечности возиться с задачей во имя „качества“. Но рынку абсолютно плевать на такой уровень качества — он в истерике требует продукта, причём уже со вчерашнего дня, и примет его в том виде, какой у нас есть сейчас». Во многих ситуациях вы будете правы насчёт рынка, но решение заставить людей выдать продукт, не соответствующий их собственным стандартам качества, практически всегда будет ошибкой.
    Мы, руководители, склонны считать качество лишь одним из свойств продукта, чем-то, что можно регулировать в зависимости от потребностей рынка. Качество — вроде шоколадного соуса на пломбире домашнего приготовления — каждый добавляет по вкусу.
    Взгляд создателя на качество совсем иной. Поскольку самооценка сильно связана с качеством продукта, он, создатель, устанавливает собственные стандарты. Удовлетворительный для него минимум более-менее соответствует высшему уровню качества, достигнутому им в прошлом. И это неизбежно более высокий стандарт, чем тот, что необходим рынку и за который рынок готов платить.
    «Рынку абсолютно плевать на такой уровень качества». Прочтите эти слова и прослезитесь, потому что они почти всегда правдивы. Люди могут с пеной у рта говорить о качестве и горько жаловаться на его отсутствие, но когда приходит время платить за качество, их действительные ценности выходят на поверхность. В проекте по разработке программного обеспечения вы можете представить пользователям следующее объяснение: «На основе эмпирических данных мы можем прогнозировать, что Среднее Время Между Сбоями для этого продукта в настоящий момент составляет примерно один час и двенадцать минут. Если мы сдадим продукт вовремя, то есть сегодня, он будет иметь низкую стабильность. Если мы затратим ещё три недели, то можем прогнозировать увеличение СВМС до двух тысяч часов, что есть вполне достойный результат». После этого можете ожидать потока недовольного бормотания со всех сторон. Пользователи объяснят, что качество ценят точно так же, как все, но три недели стоят серьёзных денег.
    Что касается индустрии программного обеспечения, то она приучила клиентов принимать как должное внутрикорпоративные прикладные программы со средней плотностью изъянов от одного до трех на сотню строк кода! И — какова ирония — этот катастрофический результат зачастую относят на низкую сознательность разработчиков в том, что касается качества. То есть тех же, кого обвиняют в желании «до бесконечности возиться с программой во имя качества», ещё и осуждают за низкое качество. Давайте-ка найдём тех, кто действительно виноват. Тот, кто платит пианисту, почему-то предлагает играть плохую музыку. Сообщество пользователей программного обеспечения продемонстрировало свои стандарты качества, регулярно подвергая процесс разработки неимоверному временному давлению, а затем принимая продукты низкого качества[8].
    Такие слова могут показаться обличительной речью, направленной против пользователей программного обеспечения и стандартов рынка в целом, но не стоит воспринимать их подобным образом. Мы должны исходить из того, что люди, финансирующие наш труд, находятся в здравом уме и способны принять разумный компромисс между качеством и стоимостью. Основная идея здесь в том, что осознаваемая клиентом потребность в качестве зачастую не столь велика, как аналогичная потребность разработчика. Существует естественное противоречие. Снижение качества продукта, вероятно, приведёт к тому, что некоторые люди откажутся от покупки, но сокращение рыночной доли — прямое следствие любого подобного снижения качества — зачастую компенсируется увеличением прибылей на каждую проданную единицу продукта.
    Бегство от совершенства — так мы называем ситуацию, когда стандарты качества устанавливает покупатель, а не создатель. Стандарты, основанные на существующем рыночном качестве, имеют смысл лишь до тех пор, пока вы не обращаете внимания на настроение и эффективность труда разработчиков.

    В долгосрочной перспективе рыночные стандарты качества обходятся дороже. Какой урок отсюда следует?

    Качество, серьёзно превосходящее запросы конечного пользователя, есть средство достижения более высокой производительности.
    Если вы сомневаетесь в этом, вообразите следующий глубокомысленный эксперимент: спросите сто человек с улицы, какая культура или нация прославилась благодаря высокому качеству. Предсказываем, что более половины людей сегодня ответят «японская». Теперь спросите у другой сотни людей, какая культура или нация известна высокой производительностью. И опять можно ожидать, что большинство ответят «японская». Нация, признанная лидером в области качества, столь же известна своей высокой продуктивностью.
    Постойте. Как же возможно, что более высокое качество сосуществует с более высокой производительностью? Ведь это противоречит прописной истине, что повышение качества продукта означает увеличение его себестоимости. Вот подсказка Тадзимы (Tajima) и Мацубары (Matsubara), двух авторитетных комментаторов японского феномена:
    В Японии компромисс между качеством и стоимостью не существует. Здесь почто все считают, что высокое качество приводит к сокращению стоимости[9].

    Качество ничего не стоит, но…

    Именно об этом Филип Кросби (Philip СговЬу) написал книгу «Quality Is Free» (Качество бесплатно), опубликованную в 1979 году. В этой работе Кросби привёл многочисленные примеры и чётко доказал, что если исполнитель работы устанавливает удовлетворяющий его самого стандарт качества, то увеличение производительности компенсирует удорожание более высокого качества[10].
    Нас терзает ужасное подозрение, что книга Кросби принесла скорее вред, чем пользу. Беда в том, что подавляющее большинство руководителей не затруднилось эту книгу прочитать, хотя название слышали все. Название и стало восприниматься как основная идея книги. Руководители по всему миру проявляют энтузиазм в отношении качества: «Нет пределов для качества, и у нас будет столько бесплатного качества, сколько мы захотим!». Навряд ли это можно назвать беспокойством о качестве. Такое отношение совершенно противоположно тому, за которое ратует Кросби.
    На самом деле идею связи качества и производительности следует представить немного иными словами:

    Качество не стоит ничего, но только для тех, кто готов дорого за него заплатить.

    Организация, готовая заплатить за качество ноль долларов и ноль центов, получит то, за что заплатила. Правило «Качество? Если успеем!» гарантирует отсутствие всякого качества в продукте.
    Примером организации, пожинающей обильный урожай производительности за счёт высоких авторских стандартов качества, является Hewlett-Packard. Качество в этой компании возведено в ранг культа. В такой среде обычно не услышишь аргумент, что для создания более качественного продукта потребуется больше времени или денег. В результате разработчики осознают, что качество создаваемых ими продуктов превосходит потребности рынка. Возможность руководствоваться собственными критериями даёт им большее удовлетворение от работы, а компании — одни из самых низких показателей текучести кадров в отрасли.

    Право вето

    В отдельных японских компаниях, в частности Hitachi Software и некоторых подразделениях Fujitsu, команда проекта имеет право налагать вето на сдачу продукта, если по мнению команды этот продукт не готов. Не имеет значения, готов ли клиент принять низкокачественный продукт, команда может настоять на том, чтобы сдача продукта была отложена до тех пор, пока он не будет удовлетворять собственным стандартам разработчиков. Разумеется, руководители проектов там находятся под тем же давлением, что и у нас: от них требуют результатов немедленно — покажите нам хоть что-нибудь прямо сейчас. Однако культура качества в достаточной степени распространена, так что эти японские руководители понимают, насколько неправильно склонять сотрудников к компромиссам в области качества.
    Сможете ли вы наделить своих людей правом вето? Да, нервы потребуются стальные, по крайней мере, поначалу. Главной вашей заботой станет Закон Паркинсона, способный заработать против вас. Эта тема настолько важна, что мы посвятили ей целую главу.

    5. Ещё раз о законе Паркинсона

    В 1954 году англичанин Сирил Паркинсон выразил мнение, что работа растёт, заполняя любое отведённое под неё время. Сейчас это мнение известно как закон Паркинсона[11].
    Если не знать, что весьма немногие руководители проходят обучение менеджменту, можно подумать, что существует спецшкола, в которой они посещают интенсивный курс по закону Паркинсона и его вариациям. Даже руководители, не знающие вообще ничего о менеджменте, цепляются за эту аксиоматическую истину — закон Паркинсона, руководящую людьми и их отношением к работе. Он даёт им крайнюю убеждённость в том, что единственный способ добиться выполнения работы — это установить невозможно оптимистические сроки её сдачи.

    Закон Паркинсона и закон Ньютона

    В законе Паркинсона вовсе нет ничего аксиоматичного. Это даже не закон в том смысле, в каком является им закон Ньютона. Ньютон был учёным, он исследовал гравитационный эффект, следуя строжайшему научному методу. Его теория была принята лишь после тщательных проверок и экспериментов. Закон Ньютона выдержал испытание временем — около двухсот лет исследований.
    Паркинсон учёным не был. Он не собирал данные и, вероятно, даже не понимал правил статистических заключений. Паркинсон был юмористом. Его «закон» получил такое распространение не потому, что он соответствовал действительности. Просто шутка была забавная.
    Разумеется, закон Паркинсона кажется нам забавным, поскольку в нем есть частичка истины. Паркинсон приводит примеры действия своего закона в рамках вымышленной правительственной бюрократической машины, прообразом которой, по мнению некоторых, является Британская почтовая служба. Бюрократия подвержена таким проблемам, потому что её сотрудники почти не получают удовлетворения непосредственно от рабочих задач. Но вы-то, вероятно, не состоите в бюрократии. А если и состоите, то изо всех сил стараетесь устроить так, чтобы ваших людей её воздействие не затрагивало, потому что в противном случае они никогда ничего не сделают. В результате ваши люди имеют возможность получать от работы удовлетворение. Из этого следует простая истина, которую имеет смысл озвучить:

    Закон Паркинсона наверняка не применим к вашим людям.

    Их жизнь слишком коротка, чтобы они стали отлынивать от работы. Раз им нравится работа, они не склонны растягивать её до бесконечности, поскольку это лишь отсрочит удовлетворение, ради которого все они стараются. Они не меньше вашего желают выполнить работу, но только с тем условием, что им не придётся нарушать собственные стандарты качества.

    А нашего Ивана вы видели?!

    Каждый руководитель хотя бы раз в жизни вынужден иметь дело с сотрудником, который избегает работы, или же не имеет стандарта качества, или просто не может сделать работу. Разве это не подтверждает закон Паркинсона?
    В здоровой рабочей обстановке причинами стагнации для некоторых людей становятся недостаток компетенции, нехватка уверенности, а также неопределённость цели проекта и отсутствие интеграции с командой. Ни в одном из этих случаев временное давление помочь не способно. Скажем, когда сотрудник вяло работает и кажется, что он не задумывается о качестве своих результатов, это верный признак того, что бедняга подавлен сложностью работы. Ему не нужно более сильное давление. Ему нужна смена деятельности, возможно, просто перевод в другую компанию.
    Даже в тех редких случаях, когда давление на человека остаётся единственным вариантом, руководитель должен это давление оказывать последним. Эффект гораздо сильнее, когда давление исходит от команды. Нам встречались случаи однородных команд, где руководителям пришлось бы занимать очередь, чтобы покричать на единственного человека, который не старается вмести со всеми.
    В последующих главах мы ещё не раз вернёмся к командам и разумному их формированию. А пока речь не о том, что действует. Речь о том, что не действует: не действует отношение к сотрудникам, основанное на законе Паркинсона. Оно способно лишь унизить и лишить мотивации.

    Университет Нового Южного Уэльса: некоторые данные

    Конечно же, влияние закона Паркинсона на умы не исчезнет лишь потому, что мы к этому призываем. А вот достоверные данные, доказывающие, что закон Паркинсона не применим к большинству работников, помогли бы переубедить руководителей. (Забудем на секунду, что Паркин-сон не привёл вообще никаких данных в подтверждение своего закона, а лишь пережёвывал его на протяжении нескольких сотен страниц.)
    Два уважаемых исследователя Университета Нового Южного Уэльса[12], Майкл Лоуренс (Michael Lawrence) и Росс Джеффри (Ross Jeffery), ежегодно выполняют обзор проектов. Они оценивают действующие проекты в отрасли, следуя общему стандарту сбора данных. Каждый год они сосредоточивают внимание на новом аспекте проектной работы. В обзоре 1985 года содержались данные, отражающие неприменимость закона Паркинсона. Они не могут служить свидетельством, полностью опровергающим закон, но их достаточно, чтобы возникли некоторые сомнения[13].
    Лоуренс и Джеффри поставили задачу определить влияние на производительность различных методов оценки. Они хотели доказать (или опровергнуть) популярное верование, что разработчики (в данном случае программисты) работают интенсивнее, если пытаются следовать собственным критериям. Для каждого из 103 изученных проектов Лоуренс и Джеффри определили параметры производительности, сходные с параметрами конструктивной модели стоимости (Constructive Cost Model — СоСоМо), которые пропагандирует Барри Бём (Barry Boehm)[14]. Затем они разделили выборку на подгруппы на основе того, каким образом были получены исходные оценки. Некоторые результаты представлены в табл. 5.1.4[15].
    Таблица 5.1. Производительность как функция оценки сложности (частичный результат)

    Пока что результаты подтверждают популярное мнение: программисты, похоже, чуть более продуктивны, когда могут оценивать необходимое время самостоятельно, в отличие от случаев, когда оценку выполняет руководитель, не советуясь с ними. Когда же руководитель советуется с разработчиком, результат получается промежуточный.
    Для 21 проекта из числа изученных в тот год оценки выполнялись третьей стороной, как правило, системным аналитиком. И эти проекты показали более высокую производительность (табл. 5.2.):

    Последняя строка уже идёт вразрез с популярным мнением. Почему программисту приходится работать интенсивнее, чтобы уложиться в оценку аналитика, чем в случае, когда оценку выполняет он сам? Есть соблазн объяснить такие показатели простыми погрешностями в данных. Но если вы согласитесь с нами в том, что плохие прогнозы всегда являются фактором, снижающим мотивацию, не будет никакой необходимости пытаться пренебречь полученными данными. Системные аналитики более склонны к точным оценкам, чем программисты или руководители. Системный аналитик, как правило, владеет той же информацией о поставленной задаче, но его не сдерживает природный оптимизм исполнителя или политические и финансовые взгляды шефа. Более того, системные аналитики имеют больший опыт в оценке, они способны предсказывать результаты более точно, поскольку уже занимались этим в прошлом и делали соответствующие выводы.
    Отрицательные прогнозы и безнадёжно малые сроки поглощают энергию автора. Кейперс Джоунс (Capers Jones), известный своими количественными исследованиями проектов по разработке, сформулировал эту мысль так: «Когда расписание проекта совершенно необоснованно и нереалистично, и притом никакой объём сверхурочных не позволяет уложиться в сроки, команда, работающая над проектом, начинает испытывать злость и отчаяние… боевой дух падает до предела»[16]. При этом не имеет особого значения, исходит ли это «совершенно необоснованное и нереалистичное» расписание от начальства или от самих создателей продукта. Оказавшись в безвыходной ситуации, люди просто не работают эффективно.
    Самая удивительная часть исследования 1985 года появилась последней, когда Лоуренс и Джеффри исследовали производительность в 24 проектах, для которых вообще не было сделано никаких предварительных оценок. Эти проекты с большим отрывом опередили все остальные (табл. 5.2)[17]:
    Таблица 5.3. Производительность как функция оценки сложности (полный результат)

    Проекты, в которых шеф не оказывал временного давления вообще («Разбудите меня, когда все будет готово»), характеризовались самой высокой производительностью[18]. Конечно, изложенное не позволяет сказать, что закон Паркинсона вообще никак не действует на разработчиков. Но наводит на интересные мысли, не так ли?
    Решение о том, оказывать ли временное давление на проект, следует принимать так же, как решение о наказании ребёнка. Если вы безупречно выбираете время и правомерность очевидна, положительный эффект вероятен. Если же вы делаете это постоянно, то это уже признак ваших собственных проблем.

    Вариация на тему закона Паркинсона

    Слегка перефразировав закон Паркинсона, мы получим утверждение, до боли правдивое для многих организаций:

    Организационная работа увеличивается в масштабах, занимая весь рабочий день.

    Этот эффект может впервые проявиться при основании компании, и из года в год положение ухудшается. Это одна из причин, по которой в давно сформировавшхся компаниях не так интересно работать. Немногие оставшиеся сотрудники Dutch East India Company (основанная в 1651 году, она была когда-то самой крупной компанией в мире) сегодня проводят по сорок часов в неделю, заполняя формуляры. Обратите внимание, как в данном случае компания, а не её сотрудники, демонстрирует поведение, подчиняющееся закону Паркинсона. Мы вернёмся к этой теме во второй части.

    6. Лаетрил

    Лаетрил — это бесцветный экстракт из мягкого содержимого абрикосовых косточек. В Швеции его можно купить в бакалее по цене, сравнимой с ценой миндальной эссенции. Как и любая другая эссенция, он применяется для выпечки. В Мексике его продают по пятьдесят долларов за каплю как «лекарство» от смертельного рака. Разумеется, он ничего не лечит. Все свидетельства подтверждают лишь то, что это грубое мошенничество. Но смертельно больные принимают заверения толкачей лаетрила — и неважно, насколько вопиющие, поскольку других вариантов все равно нет. Находясь в достаточно сильном отчаянии, люди не слишком склонны искать реальные подтверждения.
    Точно так же «находятся в достаточно отчаянном положении» руководители, и это отчаяние делает их легковерными жертвами тех видов лаетрила технологического, которые по слухам способны повышать производительность. Редко когда находятся свидетельства, подтверждающие действенность «лекарственных» средств. И руководители также обходятся без свидетельств — им просто некогда их искать.

    Худейте во сне

    В один прекрасный день в порыве глупости я начал вырезать из газет рекламные объявления, обещавшие увеличить производительность на сто или более процентов. Довольно быстро я набрал их целый ворох. Многообразие рекламируемых средств фантастического повышения производительности не могло не поразить. Семинары, комплексные программы, методологии, книги, способы календарного планирования, аппаратные средства наблюдения, вычислительные языки и бюллетени. Возвращаясь вечером того дня на метро домой, на обложке «Нью-Йорк Пост» я вдруг увидел ещё одно объявление, которое гласило: «Худейте во сне». И оно вполне подходило ко всем остальным.
    Т. Д.
    Все мы очень обеспокоены вопросом повышения производительности. От этой проблемы уже не избавиться посредством простых решений, все такие решения были найдены и задействованы уже очень давно. Однако некоторые организации чувствуют себя намного лучше других. Мы убеждены, что их лидеры не используют какие-либо исключительно продвинутые технологии. Их более высокую производительность можно полностью объяснить более эффективными способами работы с людьми, иным подходом к планированию рабочего пространства и иной корпоративной культурой, а также реализацией мер, которые мы обсудим в частях II, III и IV. Относительная малозначимость технологии может несколько обескураживать, по меньшей мере, в первое время, поскольку принимать предлагаемые нами меры по изменению корпоративной культуры нелегко, а эффекты этих мер проявляются далеко не скоро. Гораздо интереснее было бы вырезать из журнала купон, приложить к нему несколько тысяч зелёных, послать по почте, а в ответ получить какой-нибудь чудесный трюк повышения производительности. Конечно, этот трюк может вам и не помочь, но простые способы не решать проблему более привлекательны, чем сложные способы решать её, не так ли?

    Семь сирен

    Ложные надежды, порождаемые простыми технологическими способами нерешения проблемы, подобны Сиренам, соблазнявшим несчастного Одиссея. Каждая тянется к вам со своим собственным чарующим посланием, предлагая привлекательный, но никуда не ведущий ложный путь. Пока вы верите этим сиренам, вы будете сопротивляться нелёгкому труду, необходимому для построения здоровой корпоративной культуры.
    Терзающие вас сирены — свойство отрасли, в которой вы работаете. Мы обнаружили семь сирен в области, которую лучше всего знаем. Вот сирены разработки программного обеспечения:

    Семь ложных надежд руководителя проекта по разработке программного обеспечения

    1. Существует ещё не изученный новый трюк, который поднимет производительность до небес.
    Ответ : вы недостаточно глупы, чтобы пропустить нечто столь фундаментальное. Вы постоянно исследуете новые подходы и пробуете те, что кажутся наиболее осмысленными. Ни одна из мер уже принятых и ни одна из тех, что вы ещё можете принять, не позволит поднять производительность до небес. Что они, однако, могут, — так это держать всех в форме: людям нравится думать, учиться и расти. Мысль же о том, что существует волшебное новшество, которое вы пропустили, — это мысль пораженческая, и ею умело пользуются те, кто волшебные новшества продают.
    2. Другие руководители умудряются получить прирост производительности в сто, двести и даже более процентов!
    Ответ : Забудьте об этом. Как правило, волшебный инструмент, который вам предлагают, работает на этапах программирования и тестирования. Но как только программирование и тестирование заканчиваются, уже невозможно получить прирост в сто процентов. Остаются ещё анализ, контракты, спецификации, подготовка, приёмка, реконструкция и переключение с одной системы на другую.
    3. Технологии развиваются с такой скоростью, что невозможно за всем
    4. успевать.
    Ответ : Да, технологии развиваются быстро, но (вот опять иллюзия высоких технологий) ваши труды по большей части к высоким технологиям не относятся. Машины изменились очень сильно, но бизнес, связанный с разработкой программного обеспечения, всегда был довольно статичен. Мы все так же тратим большую часть времени на требования и спецификации, на низкотехнологичные аспекты нашей работы. Производительность индустрии программного обеспечения растёт на 3-5% в год, что лишь немногим больше, чем показатели в автомобильной или сталелитейной индустрии[19].
    5. Смена языка даст гигантские преимущества.
    Ответ : Выбор языка имеет значение, потому что он влияет на способ решения проблемы, но опять же, язык оказывает влияние лишь на этапе реализации. Благодаря преувеличениям, некоторые из новых языков попадают в разряд лаетрила. Не исключено, что новое приложение лучше написать, например на PowerBuilder™, а не на COBOL, но даже до появления PowerBuilder существовали способы лучшие, чем COBOL: специализированные инструменты, упрощаюшие запросы и обновления. Если последние несколько десятилетий вы не проспали у голубого телеэкрана, то смена языка не сильно вам поможет. Она может повысить производительность процентов на пять (вряд ли с этим стоит считаться), но не более того.
    6. Из-за отставания следует немедленно удвоить производительность.
    Ответ : Отставание разработки, о котором так много говорят, — это миф. Все мы знаем, что в конечном итоге любой проект обходится дороже, чем было запланировано в начале. Поэтому стоимость системы, не созданной в прошлом году (потому что не было ресурсов), принято оптимистично считать равной половине стоимости этой же системы, будь она создана, или даже менее того. Проект, попавший в капкан мифического отставания, находится там потому, что выгода от него явно недостаточна, чтобы служить причиной вообще этот проект затевать, даже если оценки стоимости крайне оптимистичны. Если бы вы знали реальную стоимость проекта, то верно понимали бы его смысл: экономическая неудача. Этот проект из отстающих следует перевести в категорию предназначенных для мусорной корзины.
    6. Все уже автоматизировано; не пора ли напрочь автоматизировать персонал, разрабатывающий программное обеспечение?
    Ответ : Это ещё одна вариация на тему иллюзии высоких технологий — вера в то, что разработчики программ выполняют работу, легко поддающуюся автоматизации. Их основная работа — человеческое взаимодействие, позволяющее преобразовать изложенные пользователями потребности в формальное представление. Кто-то должен делать эту работу независимо от того, какие формы принимает цикл жизни продукта. И вряд ли возможно данную задачу автоматизировать.
    7. Люди будут лучше работать, если как следует на них надавить.
    Ответ : Нет, не будут. Но будут меньше любить свою работу.
    Как видим, один сплошной негатив. Если давление на людей способствует снижению производительности, а установка самых последних техно-фенечек тоже не сильно спасает, чем же должен заниматься руководитель?

    Это и есть руководство

    На заре моей карьеры разработчика мне выпала честь работать в проекте под руководством Шерон Ввйнберг (Sharon Weinberg). Сейчас она является президентом компании Codd and Date Consulting Group. Эта женщина — яркий пример того, что я теперь привык называть просвещённым руководством. Как-то раз шёл снег, и я, переборов своё болезненное состояние, притащился на работу, чтобы собрать нашу шаткую систему воедино — в демонстрационную версию для пользователей. Шерон зашла и обнаружила меня за консолью. Она исчезла и вернулась через несколько минут с миской супа. Когда она влила в меня этот суп, я почувствовал прилив бодрости и спросил, как она умудряется находить время на такие вещи, ведь ей ещё нужно решать столько вопросов, связанных с руководством проектом. Она улыбнулась своей неповторимой улыбкой и сказала: «Том, это и есть руководство».
    Т. Д.
    Шерон знала то, что знают инстинктивно все хорошие руководители: назначение руководителя не в том, чтобы заставить людей работать, а в том, чтобы создать им условия для работы.

    II. ОФИСНАЯ СРЕДА

    Для того чтобы дать людям возможность работать, необходимо справиться со всеми теми факторами, которые иногда делают работу невозможной. Причины потерь часов и дней многочисленны, но они не очень отличаются одна от другой. Чаще всего это в той или иной форме недостатки среды, в которой приходится работать. Телефон звонит не переставая, мастер по ремонту принтеров остановился поболтать, копировальная машина сломалась, какой-то гражданин звонит, чтобы уточнить время сдачи крови. Отдел кадров продолжает вопить, что нужны обновлённые отчёты о квалификации сотрудников, расписание сдавать в три часа дня, снова телефонные звонки в безумных количествах… и день пропал. В некоторые дни невозможно потратить хотя бы минуту на что-либо, имеющее отношение к непосредственной задаче.
    Если бы только руководители подвергались всем этим диверсиям, ситуация была бы не столь ужасной — сотрудники могли бы мирно работать. Но, как вам известно, на практике все не так. Рабочий день каждого человека буквально зачумлён неожиданными перерывами и крушениями планов. Пропадают целые дни, и никто не может чётко объяснить, куда они подевались. Если интересно, почему все вокруг происходит вопреки вашим планам, подумайте вот о чем:

    Есть миллион способов потерять рабочий день и ни одного, который бы компенсировал потерю.

    Часть II посвящена некоторым причинам потери времени и мерам, которые можно предпринять для создания стабильной, способствующей работе обстановки.

    7. Мебельная полиция

    Предположим, в дополнение к своим текущим обязанностям вы теперь отвечаете за рабочее пространство и удобства, доступные вашим сотрудникам. Вам придётся выбирать вид рабочего места для каждого человека, а также его площадь и возможные расходы на его создание. Как вы поступите? Вероятно, пожелаете сначала разобраться, каким образом ваши люди используют своё рабочее пространство, сколько каждому требуется поверхности рабочего стола, сколько часов ежедневно каждый из них работает в одиночестве, работает с другим человеком и так далее. Вы также исследуете влияние шума на производительность труда. В конце концов, ваши люди работают в сфере интеллектуальной, им нужно работать мозгами, а шум влияет на их способность концентрироваться.
    Вы станете искать простые механические способы защитить своих сотрудников от вмешательства посторонних факторов. А имея достаточную свободу действий, исследуете преимущества закрытого пространства (офисы на одного, двух, трех сотрудников) перед открытым. Это позволит достигнуть разумного компромисса между стоимостью с одной стороны и комфортом и тишиной с другой. Наконец, вы учтёте социальные потребности людей и создадите зоны, где они смогут общаться, не мешая работать другим.
    Вряд ли вас удивит, что люди, контролирующие рабочее пространство и удобства в вашей компании (особенно если она большая), не тратят много времени на вышеперечисленные моменты. Они не собирают информацию, не стремятся понять сложные вопросы вроде производительности. Отчасти причина в том, что сами они заняты деятельностью иного рода и не подвергаются отрицательному воздействию плохо спроектированной среды. Часто они представляют собой что-то вроде мебельной полиции. Подход мебельной полиции прямо противоположен вашему собственному.

    Полицейский менталитет

    Комиссар мебельной полиции — это тот, кто бродит по новому офису за день до переезда ваших сотрудников и думает примерно следующее:
    «Посмотрите только на это восхитительное однообразие! Невозможно отличить пятый этаж от шестого! Но когда все эти люди въедут сюда, единообразию придёт конец. Они начнут вешать фотографии и придавать индивидуальность своим крошечным отсекам, устроят здесь полный бардак. Они, небось, будут пить кофе прямо над моим замечательным ковром и даже есть здесь… (вздрагивает) свой обед. Боже мой, боже мой…»
    Именно этот человек провозглашает правила, предписывающие наводить порядок на столе каждый вечер и запрещающие вешать что-либо в офисах, за исключением, быть может, календаря компании. В одной известной нам фирме мебельная полиция даже включила в прикреплённый к каждому телефонному аппарату перечень аварийных номеров специальный номер, по которому следует звонить в случае, когда кто-то пролил кофе. Нам не пришлось быть свидетелями такого происшествия, но можно предположить, что в случае «аварии» техники в белом несутся по коридорам в электрокаре со стробоскопом и надрывной сиреной.
    В перерыве семинара один человек рассказал мне, что в его компании не разрешается оставлять что-либо на рабочем столе на ночь, за исключением фотографии установленного размера, на которой изображена семья сотрудника. Оставьте что-то ещё и утром найдёте на своём столе мерзкую записку (помимсГвсего прочего, на корпоративном бланке) от мебельной полиции. Один человек был настолько оскорблён подобными записками, что едва сдерживал свой гнев. Зная о его состоянии, коллеги сыграли с ним шутку: купили дешёвую рамку для фотографий, причём выбрали рамку с изображением типичной американской семьи, а затем заменили фотографию его семьи свежекупленной. Под фотографией они прикрепили имитацию записки от мебельной полиции. В записке говорилось, что, поскольку его семья не проходит по уровню корпоративных стандартов, ему выдаётся «официальное семейное фото компании», которое он может держать на своём столе.
    Т. Д.

    Единообразный пластиковый подвал

    Чтобы более тонко прочувствовать полицейский менталитет, взгляните на план этажа (рис. 7.1), распространённый сегодня в организациях по всей стране.

    Эта схема даёт элементарный ответ на сложный вопрос: у кого должны быть окна? Ни у кого. Проблема с окнами в том, что их не хватает на всех. Если у одних сотрудников будут окна, а у других нет, то рабочее место, скажем Джорджа, станет отличаться от других рабочих мест визуально. Но мы ведь этого не можем допустить, правда?
    А теперь изучим побочный эффект. На самых востребованных маршрутах — от лифта к отсеку и из отсека в отсек — нет ни одного окна. Подобный план этажа вообще не предусматривает какого-либо применения окнам — коридоры с окнами всегда пустынны. Впервые мы встретились с такой планировкой на двадцатом этаже нового небоскрёба — великолепные виды во всех направлениях, виды, которыми почти никогда никто не любовался. Люди в этом здании могли бы с тем же успехом работать в подвале[20].
    С точки зрения мебельной полиции подвальная планировка предпочтительна, поскольку упрощает создание единообразных структур. Однако людям лучше работается при естественном освещении. Они чувствуют себя лучше, имея окна, и это самочувствие преобразуется непосредственно в более высокое качество труда. Более того, люди не желают работать в идеально единообразном пространстве. Они желают изменять свои рабочие места в соответствии со своими вкусами и предпочтениями. Эти факты типичны для целого класса неудобств, проистекающих из необходимости работать с живыми людьми.
    Ежегодно мы бываем в десятках различных организаций. Такой опыт быстро убеждает, что многочисленные планировки офисов игнорируют перечисленные неудобные факты. Практически без исключений рабочие места людей, занятых в сфере интеллектуального труда, характеризуются высоким уровнем шума, не позволяют спокойно работать, не обеспечивают уединения и устроены по одному шаблону. Некоторые лучше других, но не более функциональны. Никому не удаётся нормально работать на таком месте. Человек, способный непрерывно трудиться в тихой комнатушке с двумя большими складывающимися столами и закрывающейся дверью, получает вместо этого зашумленный модульный отсек и пластиковые аксессуары в количестве семидесяти трех штук. И никто не интересуется, как это влияет на эффективность работы.
    Может показаться, что мы слишком суровы по отношению к добропорядочным гражданам, планирующим офисное пространство Америки. Если вам так кажется, то вот ещё одно проявление умонастроения этих планировщиков. Настолько чудовищное, что непонятно, почему его терпят вообще: система объявлений. Трудно поверить, но в некоторых компаниях громкие объявления регулярно прерывают мыслительные процессы тысячи сотрудников — только для того, чтобы найти одного единственного: БОМ! [21] ВНИМАНИЕ, ВНИМАНИЕ! ВЫЗЫВАЕТСЯ ПОЛ ПОРТУЛАКА. ПОЛ ПОРТУЛАКА, ПОЗВОНИТЕ, ПОЖАЛУЙСТА, В ЦЕНТР ОБЪЯВЛЕНИЙ. Если занять удачную позицию, то иногда можно увидеть, как от тридцати до сорока сотрудников поднимают головы в ответ на первоначальное «БОМ!» и вежливо выслушивают все сообщение, а затем снова опускают головы, пытаясь вспомнить, что делали до этого момента.
    Планировщики с полицейским менталитетом создают рабочие места так, как создавали бы тюрьмы: они оптимизируют их в целях сокращения стоимости содержания. Мы бездумно доверили им дизайн рабочих мест, в то время как в большинстве организаций, испытывающих проблемы с производительностью, нет более плодотворной области, чем улучшение рабочих мест. Пока сотрудники находятся в шумных и стерильных загонах, не дающих нормально работать, нет смысла улучшать что-либо кроме рабочих мест.

    8. «С девяти до пяти здесь совершенно невозможно работать»

    В фольклоре сотрудников, занимающихся разработкой во всех секторах нашей экономики, есть и такая поговорка: «Сверхурочные — это жизнь». Подразумевается, что работу невозможно сделать в отведённое под неё разумное время. Нам такое предположение кажется весьма сомнительным. Сверхурочные действительно обычны, скажем, в отрасли разработки программного обеспечения, но эта отрасль вряд ли смогла бы добиться столь феноменального процветания, если бы создаваемое программное обеспечение не стоило больше, чем было затрачено на разработку. Как же объяснить тот факт, что программисты, а также прочие работники интеллектуальной сферы столько трудятся сверхурочно?
    Существует вызывающий беспокойство вариант, что сверхурочные — это средство увеличить не столько количество, сколько среднее качество продукции. Подтверждения можно найти в распространённых утверждениях вроде этих:
    «Лучше всего мне работается ранним утром — до того как приходят остальные.»
    «Поздним вечером я могу выполнить объём работы, рассчитанный на два или три дня.»
    «Целый день с утра наш офис — просто зоопарк, зато к шести вечера все стихает и можно, наконец, что-то сделать.»
    Чтобы получить возможность работать продуктивно, люди приходят пораньше, или остаются на вечер, или просто пытаются избежать появления в офисе — остаются на день дома, чтобы сделать важный фрагмент работы. Одна из участниц нашего семинара рассказывала, что шеф не разрешает ей работать дома, поэтому накануне сдачи важного отчёта она взяла больничный, чтобы успеть его сделать.
    Необходимость оставаться дома, задерживаться на работе, приходить раньше, чтобы спокойно поработать, — убийственное обвинительное заключение против офисной среды. Поразительно не то, что так часто нет возможности поработать на своём рабочем месте, поразительно, что все знают об этом и ничего никогда не делают, чтобы исправить положение.

    Политика дефолта

    Одна калифорнийская компания, которую я консультирую, заботится о потребностях сотрудников. В прошлом году руководство компании провело исследование, в ходе которого всех программистов (более тысячи человек) попросили перечислить лучшие и худшие аспекты их работы. Менеджер, руководивший исследованием, был в восторге от последовавших изменений в компании. Он рассказал мне, что второй по распространённости проблемой была слабая связь с руководителями высшего звена. Узнав об этом, компания организовала кружки качества, пятиминутки жалоб и прочие программы коммуникации. Я вежливо выслушал подробности о пресловутых программах и, когда он закончил, спросил, какая проблема оказалась самой первой. «Среда, — ответил он. — Людей раздражает шум». «Какие же шаги компания предприняла, чтобы решить эту проблему?» — поинтересовался я. «О, с этим мы ничего поделать не смогли, — сказал он. — Это уже не в наших силах».
    Т. Д.
    Здесь более всего обескураживает следующее: этот менеджер не особенно стеснялся того, что ему не удалось предпринять какие-то шаги к улучшению рабочей среды. Такое ощущение, что программисты пожаловались на слишком сильную гравитацию, и руководство после должных размышлений пришло к выводу, что с этим ничего нельзя сделать, так как это проблема, решение которой выходит за пределы человеческих возможностей. Это политика абсолютного дефолта.
    Изменение среды не выходит за пределы человеческих возможностей. Конечно, почти в каждой компании существует властная структура, мебельная полиция, управляющая всем хозяйством. Но разве нельзя донести до них здравые мысли или отобрать у них власть? В оставшейся части главы мы представим некоторые из причин, по которым следует сделать именно это, а в последующих главах приведём некоторые соображения относительно конкретных действий.

    Военные манёвры разработчиков: наблюдаемые факторы производительности

    С 1977 года мы ежегодно проводили открытое исследование производительности. К настоящему моменту в исследованиях приняли участие более трехсот организаций со всего мира. Начиная с 1984 года это ежегодное исследование проводилось в виде открытого конкурса, команды-участницы которого состояли из программистов различных организаций. Команды писали код заданного приложения и тестировали этот код на время. Мы назвали эти соревнования военными манёврами разработчиков (Coding War Games). Проходят они следующим образом:
  • Боевую единицу составляют два разработчика из одной организации. Участники пары работают не совместно, но друг против друга, а также против всех других пар.
  • Оба участника пары выполняют совершенно одинаковую работу: проектируют, создают и тестируют среднего размера программу по нашей спецификации.
  • Выполняя упражнения, участники записывают потраченное время в специальный журнал.
  • Когда все участники завершают тестирование, результаты проходят наши стандартные процедуры приёмки.
  • Участники работают на своих привычных рабочих местах, используют те же языки, инструменты, терминалы и компьютеры, что и для всех своих проектов.
  • Все результаты сохраняются в тайне.
    За период с 1984 по 1986 годы более 600 разработчиков из 92 компаний приняли участие в манёврах[22]. Интерес отдельного участника состоит в том, чтобы оценить своё положение относительно других. Интерес компании в том, чтобы оценить свою эффективность относительно других компаний, участвующих в состязаниях. А наш интерес в том, чтобы как можно больше узнать о факторах, влияющих на производительность. Эти факты мы и обсудим ниже в данной главе.

    Индивидуальные различия

    Одним из первых результатов военных манёвров стало доказательство огромной разницы между участниками соревнований. Разумеется, на этот факт и раньше обращали внимание. На рис. 8.1 представлены результаты, полученные из различных источников, и он иллюстрирует масштабы различий между индивидуумами[23]:

    Похоже, что при измерении вариаций производительности для выборки индивидуумов действуют три основных правила:
  • Отношение производительности лучших сотрудников к производительности худших составляет примерно 10:1.
  • Наиболее производительный сотрудник в 2,5 раза более производителен, чем средний.
  • Наиболее производительная половина сотрудников имеет в 2 раза большую производительность, чем менее производительная половина.
    Эти правила действуют практически на любые параметры производительности, которые возможно определить. Так, к примеру, лучшая половина выборки сделает заданную работу минимум в полтора раза быстрее остальных; представители другой половины, которые чаще ошибаются, сделают две трети всех ошибок и так далее.
    Результаты военных манёвров разработчиков достаточно точно соответствовали такому распределению. В качестве примера рассмотрим рис. 8.2, на котором показано распределение затрат времени на достижение первого промежуточного финиша (чистая компиляция, готовность к тестированию) для манёвров 1984 года[24]:

    Лучшая производительность в 2,1 раза превышает среднюю. Лучшая половина опережает худшую в соотношении 1,9:1. Результаты последующих манёвров были практически идентичны этим.

    Что не влияет на производительность

    Исследуя результаты состязаний, мы обнаружили, что следующие факторы слабо влияли на производительность или не влияли вовсе:
  • Язык : Разработчики, использовавшие старые языки, такие как COBOL или Fortran, выполняли задание не хуже тех, кто писал на Pascal и С. Внутри каждой языковой группы распределение производительности было таким же, как в целом по выборке. Единственным исключением из этого наблюдения стал язык ассемблера: участники, писавшие на ассемблере, сильно отстали от всех остальных языковых групп. (Впрочем, люди, пишущие на ассемблере, привыкли к такому положению вещей.)
  • Опыт : Люди с десятилетним опытом не превосходили по производительности тех, у кого опыта было всего два года. Опыт и производительность никак не коррелировали, разве что люди, менее шести месяцев имевшие дело с языком, работали не так эффективно, как другие участники.
  • Количество недочётов : Около трети участников выполняли упражнение с нулевым количеством недочётов. В целом не было отмечено снижения производительности из-за более высокой точности работы. (Более того, в среднем эта треть участников выполняла задание быстрее, чем участники, допускавшие недочёты.)
    Зарплата : Уровень зарплаты достаточно сильно варьировался для выборки. Между зарплатой и производительностью наблюдалась весьма слабая связь. Лучшая половина получала на десять процентов больше худшей, но работала почти в два раза эффективнее. Распределение производительности для любого уровня зарплаты было примерно таким же, как для выборки в целом[25].
    Опять же ничего удивительного, поскольку большинство таких особенностей отмечалось ранее. Немного более удивительными были факторы, которые, как мы выяснили, на производительность влияли.

    Об этом не стоит рассказывать боссу

    Среди обнаруженных нами факторов, положительно влияющих на производительность, оказался и весьма неожиданный: большое значение имел выбор напарника. Если вам доставался производительный напарник, все получалось и у вас. Если ваш напарник никак не мог закончить работу, не могли закончить её и вы. Если он совсем не мог завершить упражнение, вероятнее всего, то же получалось и у вас. В среднем разница в производительности для участников пары не превышала 21%.
    Почему это так важно? Дело в том, что, хотя пары не работали совместно, участники каждой пары происходили из одной организации. (В большинстве случаев организацию представляли лишь два участника.) Они работали в одной физической среде и происходили из одной корпоративной культуры. Тот факт, что у них была практически одинаковая производительность, позволяет предположить, что широкое распределение способностей среди участников манёвров невозможно в организации: любые два человека из одной организации, как правило, имеют близкую производительность. Это означает, что лучшие работники накапливаются в определённых организациях, в то время как в других собираются худшие. Этот эффект Харлан Миллз (Harlan Mills) предсказал в 1981 году:
    Такой разброс[26] в производительности отдельных программистов понятен, но существует точно такой же разброс в производительности организаций, разрабатывающих программное обеспечение[27].
    Software Productivity
    Наше исследование показало огромные различия между 92 организациями, принявшими в нем участие. В целом по выборке лучшая организация (показавшая лучшую среднюю производительность своих сотрудников) работает в 11,1 раза быстрее, чем худшая. Код, созданный участниками из быстрейшей организации, оказался не только самым быстрым, он также прошёл основные приёмочные испытания.
    Это вызывает серьёзную тревогу. В течение многих лет руководители проявляли определённый фатализм в отношении индивидуальных различий. Они утверждали, что различия присущи людям, так что с ними ничего нельзя поделать. Гораздо труднее проявлять фатализм по поводу эффекта накопления. В некоторых компаниях дела обстоят гораздо хуже, чем в других. Что-то в среде и корпоративной культуре этих компаний противодействует привлечению и сохранению хороших сотрудников или не позволяет им эффективно работать.

    Влияние рабочего места

    Суровая правда жизни такова, что многие компании предоставляют разработчикам места столь тесные, шумные и подверженные внешним воздействиям, что невозможно работать, не испытывая раздражения. Один этот факт может объяснить пониженную эффективность, а также тенденцию перехода хороших сотрудников в другие компании.
    Гипотеза о том, что свойства рабочего места могут сильно влиять на эффективность труда разработчика, легко поддаётся проверке. Достаточно разработать набор фиксированных тестовых задач, сходных с теми, которые разработчики обычно выполняют во время работы, и понаблюдать, насколько хорошо люди справляются с этими задачами в различной обстановке. Военные манёвры разработчиков проектировались именно с этой целью.
    Для того чтобы собрать некоторые данные о рабочем месте, мы предложили каждому участнику (до конкурса) заполнить анкету, посвящённую физическим аспектам места, в котором предстояло работать. Мы предложили вопросы, касающиеся физических параметров (площадь, высота перегородок, к примеру) и субъективных впечатлений («Чувствуете ли вы свою востребованность на рабочем месте?» и «Достаточно ли тихо на вашем рабочем месте?»). Затем мы сопоставили ответы участников с показанными результатами.
    Тенденция становится очевидной, если проследить характеристики рабочих мест тех, кто хорошо показал себя в соревнованиях (по совокупности параметров производительности), и сравнить их результаты с результатами участников, не проявивших себя столь хорошо. Мы решили сравнить первую четверть участников с четвёртой. Средняя производительность участников первой четверти в 2,6 раза выше средней производительности участников последней четверти. Свойства рабочей среды приведены в табл. 8.1:
    Таблица 8.1. Свойства среды, лучших и худших в плане производительности участников военных манёвров разработчиков

    Первая четверть, то есть участники, быстрее и эффективнее других выполнившие задание, имеют рабочие места, существенно отличающиеся от тех, что достались последней четверти. Наиболее производительные работают в более тихих, более уединённых, более просторных и лучше защищённых от внешнего вмешательства местах[28].

    Что мы доказали?

    Представленные данные ещё не доказывают, что более качественные рабочие места способствуют повышению производительности. Они, возможно, лишь указывают, что люди с более высокой производительностью склонны работать в организациях, предоставляющих такие рабочие места. Имеет ли это значение для вас? В долгосрочной перспективе какая в сущности разница — помогают ли тишина, пространство и уединение вашим сотрудникам делать работу лучше или же они помогают вам привлекать и сохранять более толковых сотрудников?
    Если мы что-то и доказали, так это то, что политика дефолта в отношении характеристик рабочих мест ошибочна. Если вы участник команды, члены которой работают головой, или если вы руководите такой командой, то среда рабочего пространства имеет к вам непосредственное отношение. Недостаточно просто заявить «С девяти до пяти здесь совершенно невозможно работать», а потом обратить своё внимание на другие задачи. Глупо, что люди не могут работать в привычные рабочие часы. Настало время принять меры.

    9. Экономия на пространстве

    Если ваша организация хоть немного похожа на те, что мы изучили за последние три года, её политика в отношении рабочей среды ориентирована на менее уединённые, менее просторные, более шумные рабочие места. Разумеется, причиной тому — стоимость. Копейка, сэкономленная на рабочем месте, — это копейка, заработанная на конечном результате, по крайней мере, такова логика. Тех, кто этого мнения придерживается, следует упрекнуть в исследовании затрат и выгод, проводимом без учёта выгод. Они знают стоимость, но не имеют ни малейшего понятия о том, что содержит вторая часть уравнения. Само собой, экономия за счёт дешёвых рабочих мест привлекательна, но в сравнении с чем? Очевидный правильный ответ — экономию следует оценивать относительно риска потери эффективности труда.
    Учитывая существующее положение со стоимостью рабочих мест, удивительно, насколько незначительны потенциальные сбережения в сравнении с потенциальными рисками. Полная стоимость рабочего места одного разработчика составляет небольшой процент от его зарплаты. Насколько небольшой зависит от таких факторов, как стоимость площадей и уровень зарплаты, а также от выбора между арендой и покупкой офиса. В целом он лежит в диапазоне от 6 до 16% [29]. Например, программисту или аналитику, работающему на принадлежащих компании площадях, вы заплатите примерно 15 долларов на каждый доллар, затраченный на рабочее место и удобства. Если учесть ещё стоимость соцпакета этого сотрудника, то общие вложения в его содержание могут запросто составить до двадцати стоимостей рабочего места.
    Соотношение двадцать к одному предполагает высокий риск в случае снижения стоимости рабочего места. Попытки сохранить крохотную долю одного доллара могут потребовать принести в жертву серьёзную долю двадцати долларов. Рассудительный руководитель не станет даже думать о переводе людей в более дешёвое, более шумное и менее просторное помещение, не оценив прежде всего влияние такого хода на эффективность труда. Так что по идее планировщики, претворяющие в жизнь десятилетнюю программу по превращению нашего офисного пространства в модный вариант открытой планировки[30], прежде всего должны были провести тщательный анализ производительности. Иначе они показали бы явно безответственное безразличие к среде.

    Моровая язва

    К сожалению, безответственное безразличие к среде стало приметой времени. Мы демонстрируем его, разграбляя природные ресурсы, так чем же рабочие места лучше? В своём фантастическом романе-предсказании Джон Браннер (John Brunner) описывает загрязнение воздуха, почвы и воды, не прекратившееся и в конце двадцатого века. Невзирая на серьёзность загрязнения, почти никто не жалуется. Словно огромное стадо невозмутимых баранов, обитатели мира Браннера пытаются игнорировать проблему, и в конечном итоге выживание человека становится невозможным. И лишь тогда они замечают, что происходит. Браннер назвал свою книгу «The Sheep Look Up» (И агнцы воззрели горе)[31].
    Служащие американских офисов едва ли куда-либо взирали, пока их среда все больше деградировала, становясь не разумной, но глупой. Ещё не так давно они работали вдвоём-втроём в изолированных офисах с дверями и окнами. (Вы ведь помните стены, двери и окна?) В таких условиях человек мог работать в тишине или проводить совещания с коллегами, не мешая соседям.
    Затем на нас без объявления войны, словно моровая язва, свалилась открытая планировка. Приверженцы нового формата не представили ни единого мало-мальски серьёзного свидетельства того, что эффективность не пострадает. Да они и не могли этого сделать. Осмысленные измерения производительности — задача сложная, нахрапом её не решить. В различных секторах трудовой деятельности такие измерения следует выполнять различными способами. Требуется компетенция, внимательный анализ и сбор большого объёма данных.
    Люди, принёсшие нам открытую планировку, просто не способны были проделать эту работу. Но они были хорошими политиками — аккуратно обошли вопрос возможного снижения производительности, очень громко заявив, что новая планировка приведёт к повышению производительности, причём к серьёзному повышению: аж на три сотни процентов. Они публиковали статьи, и содержание многих было высосано из пальца. Они давали своим высказываниям громкие названия. Для примера приведём заголовок из журнала Data Management: «Открытая планировка форсирует производительность работников». После столь многообещающего названия автор перешёл сразу к сути вопроса:
    Основные области, на которые следует обращать внимание при проектировании офиса открытой планировки для предприятия, занимающегося обработкой информации, — это система обеспечения электроэнергией, возможности для работы компьютерной техники, а также поддержка со стороны производителей и поставщиков оборудования[32].
    Точка. И все. Все «основные области». Ни слова о том, что в этом месте предстоит работать человеку.
    Точно так же в этой статье, как и в других, отсутствует всякое понимание того, что же такое производительность сотрудника. В статье отсутствовали сведения, подтверждающие заголовок. Единственным доказательством того, что открытая планировка улучшает производительность, почему-то всегда служило упрямое повторение этого утверждения.

    Мы прерываем обличительные речи, чтобы познакомить вас с фактами

    Прежде чем начать вычерчивать планы своего нового объекта в Санта-Терезе, компания IBM нарушила все отраслевые стандарты и внимательно изучила рабочие привычки тех, кому предстояло трудиться на этом объекте. Исследование разработал архитектор Джеральд Мак-Кью (Gerald McCue) при содействии планировщиков из IBM. Исследователи наблюдали рабочий процесс в динамике — и в старом офисе, и моделируя будущие рабочие места. Они следили за тем, как программисты, инженеры, сотрудники контроля качества и руководители выполняют свои привычные задачи. По результатам исследования был сделан вывод, что минимальные параметры рабочего места для людей, которых переводят в новый офис, должны выглядеть так:
  • 9 квадратных метров площади на сотрудника;
  • 2,7 квадратных метра рабочей поверхности на сотрудника;
  • защита от шума в виде закрытых офисов или двухметровых барьеров
  • (в конечном итоге примерно половина всех профессиональных кадров
  • была размещена в одно— и двухместных кабинетах).
    Мотивация к созданию новой лаборатории с учётом такого минимума была простая: людям, участвовавшим в исследовании, в силу их профессии нужны пространство и тишина, чтобы работать с хорошей отдачей. Сокращение стоимости и, как следствие, не удовлетворяющие установленным требованиям рабочие места, привели бы к потере эффективности. Экономия была бы компенсирована, причём с лихвой. Прочие исследования охватывали те же вопросы и заканчивались примерно такими же результатами. Исследование Мак-Кью отличалось от других лишь в одном отношении: IBM последовала рекомендациям и построила место, где люди могут работать. (Мы предвидим, что эта компания далеко пойдёт[33].)
    Теперь посмотрим, что ответят остальные компании на минимальное стандартное рабочее место от IBM. На рис. 9.1 представлено распределение площади рабочего места на человека для участников наших исследований 1984 и 1985 годов.

    [34]
    Лишь у 16 процентов участников на одно рабочее место пришлось 9 и более квадратных метров. Лишь 11 процентов участников работают в закрытых офисах или за перегородками высотой более метра восьмидесяти. В группе получивших от 1,8 до 2,7 квадратных метров на место оказалось больше людей, чем в группе получивших по 9 метров. (1,8 квадратных метра — это даже меньше, чем площадь рабочего стола в Санта-Терезе; попробуйте поработать на таком пространстве.)
    По всей выборке военных манёвров разработчиков 58 процентов участников жаловались, что рабочие места недостаточно тихие, 61 процент — что они недостаточно уединённые, 54 процента заявили, что их домашнее рабочее место лучше предоставленного компанией.

    Качество рабочего места и качество продукта

    Компании, предоставляющие сотрудникам тесные и шумные рабочие места, утешают себя верой в то, что эти факторы не особо значимы. К примеру, они отговариваются от всех жалоб на шум, когда сотрудники начинают кампанию за более просторное и уединённое пространство. В конце концов, подумаешь, немного шума. Зато никто не будет спать на рабочем месте.
    Чтобы определить, воздействует ли восприимчивость к шуму на качество труда, мы разделили нашу выборку на две части. В первую вошли те, кто считал рабочее место достаточно тихим, во вторую — те, кто так не считал. Затем мы определили, сколько сотрудников в каждой группе выполнило конкурсное задание без единой ошибки.
    Среди участников первой группы оказалось на треть больше безупречных результатов.
    С увеличением уровня шума, похоже, усиливается и этот эффект. Так, одна компания была представлена 50 участниками с рейтингом уровня шума, превышающим средние показатели на 22 процента. В этой компании безупречные результаты находились в диспропорции с количеством людей, считающих уровень шума неприемлемым.
    Из безупречных сотрудников 66 процентов утверждали, что уровень шума терпеть можно, из остальных (одна или более ошибок) лишь 8 процентов поддерживали это мнение.
    В этом случае участники также отвечали на вопросы о среде до выполнения конкурсных заданий.
    Заметим, мы не проводили объективных замеров уровней шума. Мы просто спрашивали людей, находят ли они существующий уровень шума приемлемым. В результате мы не можем отличить тех, кто работал в действительно тихом месте, от тех, кто хорошо адаптировался к шумному рабочему месту. Однако когда сотрудник жалуется на шум, он прямым текстом сообщает вам, что не входит ни в одно из этих замечательных подмножеств. Он сообщает вам, что в его работе вероятны ошибки. Игнорируйте это сообщение на свой страх и риск.

    Открытие, достойное Нобелевской премии

    В некоторые дни люди более восприимчивы, чем в другие. Для нас таким поворотным днём в плане восприятия стало 3 февраля 1984 года, когда мы начали замечать удивительную связь плотности сотрудников и площади, приходящейся на человека. Похоже, с увеличением одного параметра второй уменьшается! Как и полагается старательным исследователям, мы принялись документировать это явление. Изучая 32 346 компаний по всему Свободному Миру, мы подтвердили практически идеальное обратное отношение между этими двумя показателями.

    Вообразите наше волнение в процессе сбора данных. Мы испытывали то же, что, наверное, испытывал Ом, открывая свой закон. Вот так рождаются кандидаты на получение Нобелевских премий. Запомните, что именно в этой книге вы узнали: «Плотность сотрудников (скажем, на 90 квадратных метров) обратно пропорциональна площади, выделенной каждому человеку».
    Если вы не можете понять, почему это важно, подумайте о шуме. Шум прямо пропорционален плотности, поэтому, уполовинив площадь, приходящуюся на одного человека, мы увеличим уровень шума вдвое. Даже если вам удалось убедительно доказать, что программист способен работать на площади в 2,7 квадратных метра, не будучи безнадёжно скованным своим рабочим местом, вы все-таки не сможете утверждать, что 2,7 квадратных метра — достаточная площадь. Уровень шума в клетках по 2,7 метра более чем в три раза превышает уровень шума в клетках по 9 квадратных метров. Такая разница в площадях может означать разницу между продуктом, полным дефектов, и продуктом, таковых не имеющим.

    Прятки

    Если офисная среда слишком раздражает людей, они начинают искать места, где можно спрятаться. Они бронируют конференц-залы, или отправляются в библиотеку, или идут пить кофе и не возвращаются. Нет, они вовсе не ходят на тайные свидания и не готовят политический переворот, они лишь прячутся, чтобы поработать. Это хорошая новость — вашим людям требуется удовлетворение от сделанной работы. Они на многое готовы ради этого. В кризисной ситуации они приложат все усилия, чтобы найти для работы нормальное место.
    Когда я учился в университете Брауна, мы знали, как успеть сделать все работы и пережить сессию — нужно найти тихое место, где можно комфортно работать. В университетской библиотеке были помещения для научной работы. И единственной уважительной причиной для перерыва могла стать только сирена пожарной тревоги в момент страшной усталости. Мы стали настоящими специалистами в поиске удалённых отсеков, где никто не подумал бы нас искать. Мои излюбленные отсеки находились на пятом этаже биологической библиотеки. А один мой приятель забрался даже в склеп под Библиотекой Америки — самый настоящий склеп с останками женщины, внёсшей свой вклад в историю этого здания. Там было прохладно и, как говорил мой друг, тихо. Очень тихо.
    Т. Д.
    Если вы заглянете в конференц-зал, то обнаружите троих сотрудников, работающих в полной тишине. Если добредёте до столовой после обеда, то, вероятно, увидите, как люди работают, каждый за своим столом. Некоторых из сотрудников вы не сможете найти вовсе. Люди прячутся, чтобы делать свою работу. Узнаете свою организацию? Это приговор. Экономия денег на пространстве может встать в копеечку.

    ИНТЕРМЕДИЯ

    Интермедия — это забавное отступление на страницах серьёзной в целом книги (ну, скажем, достаточно серьёзной).

    Замеры производительности и неопознанные летающие объекты

    Почему мы не можем просто измерить производительность на хороших и плохих рабочих местах и наконец ткнуть пальцем в связь между средой и эффективностью труда? Такой подход, несомненно, подошёл бы для конвейерной линии, но при замерах параметров работы более интеллектуального характера все не так очевидно. Измерение производительности работника сферы интеллектуального труда страдает из-за репутации «неточной» науки. По мнению некоторых, это немногим лучше, чем изучение неопознанных летающих объектов.
    Достаточно легко спроектировать эксперимент для исследования влияния рабочего места на производительность:
  • измерить объём работы, выполненной на новом месте;
  • измерить стоимость выполнения этой работы;
  • сравнить объём и стоимость работы на новом рабочем месте с объёмом
  • и стоимостью на прежнем.
    Спроектировать легко, а реализовать труднее: скажем, как оценить объём работы, проделанный при исследовании рынка, или при проектировании новой микросхемы, или при разработке новой системы займов? Может быть, в этой области и зарождаются стандарты (как это происходит в индустрии программного обеспечения), но они потребуют тщательного сбора данных на местах и накопления внутреннего опыта. Большинство организаций даже не пытается измерить объёмы проделанной интеллектуальной работы. Оценку стоимости эти организации выполняют также не очень эффективно.
    Может существовать статистика общего числа часов, затраченных на решение задачи в организации, но при этом никакой информации о качестве этих часов (подробнее в главе 10). И даже если бы организации смогли измерить объёмы и стоимость работы на новом месте, то с чем сравнивать эти показатели? Руководители, вероятно, станут хмурить брови, вздыхать и заключат, что вариации в производительности находятся за пределами понимания. Однако все не так уж и плохо.

    Закон Гилба

    Два года назад на конференции в Лондоне я полдня общался с Томом Гилбом (Тот Gilb), автором книги «Software Metrics» (Метрики программного обеспечения) и десятков опубликованных статей по теме измерений процесса разработки. Я обнаружил, что его легко можно вывести из себя, предположив, что тот или иной аспект «измерить невозможно». Тома оскорбляла сама мысль об этом. В тот день он оказал мне любезность, высказав фундаментальную, с его точки зрения, истину об измеримости. Его мысль сразу же показалась мне столь мудрой и вдохновляющей, что я слово в слово записал её в свой дневник под заголовком «Закон Гилба»:

    Если вам нужно представить что-либо в количественной форме, это можно измерить каким-то способом, который даст лучшие результаты, чем в случае, если не проводить измерений вовсе.

    Закон Гилба не гарантирует, что измерения будут бесплатными или даже дешёвыми, и они могут оказаться далёкими от идеала — но это все равно лучше, чем ничего[35].
    Т. Д.
    Конечно же, производительность поддаётся измерению. Если создать группу из людей, выполняющих одинаковую или похожую работу, и дать им день на создание разумной схемы самоконтроля в целях измерения, они в результате создадут нечто, подтверждающее закон Гилба. Цифры, полученные этими людьми, позволят им регулировать собственную производительность, а также в сочетании с кружками качества или каким-либо другим способом взаимного контроля предоставят возможность учиться на методах работы коллег. Средние показатели, вычисленные для этой группы, дадут руководству надёжное свидетельство воздействия на производительность таких событий, как улучшение офисной среды.
    В наиболее знакомой нам области конструирования программного обеспечения существует неограниченное число работающих механизмов измерения производительности[36]. Существует даже служба оценки производительности[37], которая может приехать и показать, где находится ваша организация в сравнении с другими участниками отрасли. Организация, не способная выполнить какую-либо оценку собственной производительности в программировании, просто недостаточно прилежно старается это сделать.

    Не позволяйте себе не знать

    Предположим, существует надёжный инструмент измерения производительности, и в данный момент он применяется к вашим сотрудникам. Допустим, измерители сообщают вам, что по производительности вы входите в первые пять процентов организаций, занимающихся той же деятельностью. Вам будет приятно. Вы станете бродить по коридорам с загадочной улыбкой на лице и тепло думать о своих сотрудниках: «Я подозревал, что они неплохо работают, но какая же потрясающая новость».
    Ой-ой! Измерители только что вернулись и сообщили, что случайно перевернули график результатов. На самом деле вы входите в последние пять процентов. Ну вот, испортили день. Вы начинаете думать: «Я мог бы с самого начала догадаться. Как можно вообще работать с такими тупыми сотрудниками?» В одном случае вы радуетесь, в другом — расстраиваетесь. Но ни в том ни в другом случае особо не удивляетесь. Реакция удивления маловероятна независимо от новости, поскольку у вас нет ни малейшего представления о действительном уровне производительности.
    Учитывая, что организации на практике довольно значительно отличаются одна от другой, вы просто не можете себе позволить игнорировать информацию о собственном текущем положении. Ваши конкуренты могут работать в десять раз эффективнее. Если вы не знаете об этом, то не можете принять меры. Зато рынок все поймёт. Он предпримет собственные шаги для выправления ситуации, и эти шаги будут не в вашу сторону.

    Измерения с закрытыми глазами

    Измерения работы могут стать полезным инструментом для улучшения методов, повышения мотивации и уровня удовлетворённости работой, но практически никогда не применяются для этих целей. Проекты по измерению часто превращаются в угрозу и становятся обузой.
    Чтобы получить от метода обещанные результаты, руководство должно проявить достаточную проницательность и спокойствие, исключив себя из этого процесса. Проще говоря, данные по отдельным сотрудникам не попадают на глаза руководителям, и это известно каждому в организации. Сведения о производительности отдельного человека должны использоваться только в интересах этого человека. Схема измерения — это упражнение в самооценке, и шефу должны быть доступны только средние показатели, прошедшие цензуру[38].
    Многим руководителям будет нелегко принять такое положение вещей. Они считают, что могут использовать данные для более эффективного выполнения своей работы (скажем, более заслуженно предлагать повышения или более аргументировано увольнять). Их компания заплатила за сбор данных, так почему эти данные недоступны? Однако сбор этих весьма деликатных сведений об отдельном человеке возможен лишь при активном и добровольном сотрудничестве со стороны этого человека. Если хоть раз конфиденциальность сведений будет нарушена, если хоть раз данные будут использованы против хотя бы одного человека, вся схема сбора данных прекратит своё существование.
    Индивидуумы склонны поступать с данными точно так же, как руководители. Они стараются совершенствовать то, что делают хуже, и специализироваться в областях, где и так уже преуспели. В отдельных случаях люди даже «увольняют» себя, чтобы разрушить собственную зависимость от недостаточных профессиональных способностей. Руководителю вовсе не нужны данные по отдельным сотрудникам, чтобы извлечь выгоду.

    10. Работа ума и работа тела

    В ходе исследования по подготовке отделения фирмы IBM в Санта-Терезе, описанного в главе 9, Мак-Кью и его ассистенты изучили распределение времени по различным режимам работы. В обычный день сотрудники распределяли своё рабочее время следующим образом:
    Таблица 10.1. Распределение времени разработчиками[39]

    Важность этой таблицы в контексте уровня шума должна быть очевидна: тридцать процентов своего времени люди чувствительны к шуму, а все остальное время они генерируют шум. Поскольку рабочее пространство заполнено людьми, работающими в одиночестве или совместно, существует конфликт режимов. Работающим в одиночестве этот конфликт мешает более всего. Пусть они выступают в меньшинстве в любой момент времени, но их нельзя игнорировать, поскольку именно в одиночном режиме люди занимаются непосредственно выполнением работы. Все остальное время уходит на вспомогательную деятельность, отдых и болтовню.

    Поток

    Во время работы в одиночестве человек в идеале находится в состоянии, которое психологи называют потоком[40]. Поток — это состояние глубокого, почти медитативного погружения в работу. В этом состоянии человек испытывает лёгкое чувство эйфории и не замечает течения времени: «Я начал работать. Когда оторвался, прошло уже три часа». Человек не прикладывает сознательных усилий, потому что работа, кажется, идёт потоком. Вы часто бывали в этом состоянии, поэтому нам не нужно его описывать.
    Не все виды работы требуют состояния потока для достижения хорошей производительности, но для любого, кто связан с проектированием, дизайном, разработкой, письмом или подобными задачами, поток — необходимость. Это задачи, требующие сильного импульса. И только в потоке подобная работа продвигается хорошо.
    К сожалению, поток нельзя «включать» по желанию. Требуется медленное погружение в предмет, не менее пятнадцати минут концентрации, прежде чем появится это состояние. В период погружения вы особенно чувствительны к шуму и остановкам. Шумная среда может затруднить или сделать невозможным вход в поток.
    Из потока вас может легко вывести направленное непосредственно на вас воздействие (скажем, ваш телефон) или назойливый шум («Внимание! Сообщение для Пола Портулаки! Пол Портулака, позвоните по внутреннему номеру…»). После каждого такого вмешательства требуется дополнительное время для возврата в поток. И в это время работа стоит на месте.

    Бесконечное отсутствие потока

    Если в среднем входящий телефонный звонок отнимает пять минут, а ваш период повторного входа в поток — пятнадцать минут, общая стоимость такого звонка, исчисляемая в потерянном времени потока (непосредственной работы), — двадцать минут. Десяток телефонных звонков израсходуют половину рабочего дня. Ещё десяток других вмешательств, и вот уже рабочий день пропал. Именно поэтому «С девяти до пяти здесь совершенно невозможно работать».
    Здесь важна не только потеря времени, но ещё и сопровождающее эту потерю раздражение. Сотрудник, который постоянно пытается войти в поток и постоянно вынужден отвлекаться, — человек недовольный. Как только он приближается к включению в работу, рабочая среда тут же возвращает его на землю. Вместо желанной предельной концентрации он постоянно находится в беспорядочной смене действий, присущей современному офису. Поставьте себя в положение участницы, заполнившей свою анкету для военных манёвров разработчиков следующим образом (табл. 10.2):
    Таблица 10.2. Фрагмент журнала с конкурса разработчиков

    Несколько дней в таком режиме, и кто угодно станет искать новую работу. Если вы руководитель, то можете быть отчасти безразличны к раздражению тех, кто не может достичь состояния потока. В конце концов, большую часть собственной работы вы делаете в режиме вмешательства — это же руководство; однако ваши сотрудники нуждаются в потоке. Все, что мешает им достичь этого состояния, снижает их производительность и удовлетворённость работой. А также повышает стоимость выполнения работы.

    Исчисление времени, основанное на потоке

    Вероятнее всего, в вашей компании в настоящий момент принята традиционная модель исчисления времени. Предполагается, что выполненная работа соразмерна числу оплаченных рабочих часов. Когда сотрудники заполняют свои журналы по этой схеме, они не делают различия между часами, затраченными на осмысленную работу, и часами простого раздражения. Поэтому они сообщают информацию о времени работы тела, но не мозга.
    Что ещё хуже, данные по отдельным задачам используются при вычислении заработной платы. Это побуждает работников стремиться к тому, чтобы общее количество зафиксированных документально часов всегда было более или менее сопоставимо с определённым заранее количеством часов в расчёте на неделю, независимо от того, сколько сверхурочных или недоработанных часов на этой неделе было. Окончательная сводка официальных выдумок может быть приемлемой для отдела финансов: она эквивалентна ответу «здесь» на перекличке. Но для любой оценки производительности или анализа затрат эти записи слишком ущербны, чтобы оказаться полезными.
    Феномен потока и погружения даёт нам более реалистический способ моделирования затрат времени на задачи разработки. Имеет значение не время присутствия, но время работы в полную силу. Час в потоке даёт реальные результаты, но десять шестиминуток, чередуемые одиннадцатью перерывами, не дают никаких результатов.
    Учёт времени в потоке не очень сложен. Вместо того чтобы заносить в журнал часы, люди заносят часы непрерывной работы. Чтобы получить честные данные, следует исключить чувство вины за слишком малое количество часов непрерывной работы. Люди должны быть уверены, что не по их собственной вине им удаётся лишь час или два в неделю поработать не отвлекаясь; скорее, это вина организации, которая не предоставляет им среду, способствующую работе в потоке. Разумеется, такие данные не должны попасть в отдел финансов. Для расчёта зарплаты все равно придётся сохранить механизм учёта часов присутствия.
    Схема учёта, фиксирующая часы в потоке вместо часов присутствия, даёт весьма серьёзную двойную выгоду. Во-первых, она фокусирует внимание ваших людей на важности времени потока. Узнав, что каждый рабочий день должен позволять им по меньшей мере два-три часа работать не отвлекаясь, они примут меры, чтобы защитить эти часы. Если они яснее осознают действие отвлечений , то смогут защищаться от случайных вмешательств со стороны коллег.
    Во-вторых, эта схема позволяет оценить, насколько разумно тратится время на рабочие задачи. Если предполагается, что завершение продукта требует трех тысяч потоко-часов, у вас есть веская причина полагать, что две трети пути пройдено, если зафиксированы затраты двух тысяч потоко-часов. Подобное заключение, сделанное на основании часов присутствия, было бы глупым и опасным.

    Фактор «С»

    Если вы тоже считаете, что качественная среда должна положительно влиять на способность сотрудников работать в потоке, то сбор информации по часам непрерывной работы может дать вам количественное представление того, насколько хороша ваша офисная среда. Если отношение продолжительности непрерывной работы к общей продолжительности рабочего дня достаточно высокое, порядка сорока процентов, значит, среда позволяет людям при необходимости работать в потоке. Намного меньший показатель свидетельствует о раздражении сотрудников и снижении эффективности их работы. Мы называем этот параметр фактором Среды, или просто фактором «С»:
    Фактор С = время непрерывной работы/время присутствия;
    В результате сбора данных по фактору «С» обнаружился интересный момент: фактор может изменяться в пределах одной организации в зависимости от подразделения. К примеру, в одной крупной правительственной организации мы встретили одновременно высокий фактор «С» (0,38) и низкий (0,10). Руководитель организации заверил нас, что физические изменения в рабочей среде невозможны, даже если она плоха, потому что свойства рабочего места определены правилами, установленными правительством для государственной службы. Несмотря на это мы обнаружили отделы, сотрудники которых работали в тесных, шумных офисах открытой планировки, и отделы, где сотрудники на тех же должностях, выполнявшие ту же работу, располагались в удобных офисах по четыре человека. Неудивительно, что в четырехместных офисах фактор «С» оказался заметно выше.
    Фактор «С» может поставить под угрозу установившееся в организации равновесие. (Возможно, вам лучше не заниматься сбором этих данных.) Если вы сообщите о факторе 0,38 для разумного рабочего пространства и факторе 0,10 для экономичного, люди могут сделать вывод, что экономия на стоимости не имеет особого смысла. Чтобы выполнить ту же работу, сотрудники в пространстве с фактором 0,10 должны присутствовать на рабочем месте в 3,8 раза дольше, чем сотрудники из пространства с фактором «С», равным 0,38. Это означает, что выполнение работы в экономичном пространстве может привести к потерям производительности, убыток от которых будет превышать экономию на пространстве. Очевидно, подобную ересь допускать нельзя. Ведь тогда вся наша замечательная «экономия» на рабочих площадях сотрудников полетит в тартарары. Сожгите скорее эту книгу, пока кто-нибудь ещё не прочёл её.

    Сад платков

    Не удивляйтесь, если при первоначальных замерах окажется, что фактор «С» стремится к нулю. Кое-кто может даже посмеяться над вашими попытками зафиксировать часы непрерывной работы: «В этом балагане не существует ничего подобного». Не отчаивайтесь. Помните, что вы не просто собираете данные, вы помогаете изменить отношение людей к проблеме. Регулярно фиксируя часы непрерывной работы, вы придаёте официальный тон идее, что люди должны хотя бы иногда работать не отвлекаясь. Тем самым вы делаете допустимыми надрывающиеся без человеческого внимания телефоны, закрытые двери (заметим со вздохом, если таковые имеются) и «прятки».
    В одном из подразделений нашего клиента наблюдалось явление почти что из мира живой природы — после нескольких недель сбора данных по фактору «С» на столах начали буквально произрастать красные платки. Никто из руководителей ничего такого не предлагал, но красные платки стали, словно по молчаливому согласию, официальным знаком «Не беспокоить». Все сотрудники быстро оценили этот знак и проявляли к нему уважение.
    Разумеется, всегда существовали отдельные эксцентричные личности, выставлявшие на своих столах знаки «Не беспокоить». Давление коллег часто не позволяет нам открыто демонстрировать, что посторонние вмешательства не приветствуются, даже если совершаются изредка. Уделение фактору «С» немного большего внимания помогает изменить корпоративную культуру и сделать подобные знаки привычными.

    О размышлениях на работе

    Когда я работал в Bell Labs, у нас были двухместные кабинеты. Просторные, тихие, с телефонами, позволявшими перенаправлять звонки. Свой офис я делил с Венделом Томисом, который впоследствии создал небольшую империю электронных игрушек. В те дни он работал над словарём ошибок ESS [41] . Схема словаря основывалась на расстояниях в многомерном пространстве, теме настолько сложной, что даже Вен-делу приходилось максимально сосредоточиваться. Однажды днём я изучал листинг программы, а Вендел смотрел перед собой, положив ноги на стол. Вошёл наш шеф. «Вендел, что ты делаешь?» — спросил он. Вендел отвечал: «Я думаю». И тогда шеф сказал: «Ты что, не можешь делать это дома?»
    Т. Д.
    Есть разница между средой Bell Labs и типичной современной офисной планировкой — в тех тихих офисах у человека по крайней мере была возможность думать на работе. В большинстве офисов, что мы видим сегодня, шума и помех достаточно, чтобы затруднить серьёзные мыслительные процессы до невозможности. Это тем более прискорбно, что ваши сотрудники каждое утро приносят с собой свои светлые головы. И они могли бы использовать их на ваше благо, причём без дополнительных затрат, если бы обстановка у них на рабочем месте была немного тише и спокойнее.

    11. Телефон

    При сборе данных о качестве рабочего времени внимание непременно привлекает одна из главных причин перебоев в работе — входящие телефонные звонки. Ничего не стоит отделаться от пятнадцати звонков в день. Ничего не стоит, но если сложить затраты на повторное погружение в работу, пятнадцать звонков могут стоить почти целого дня. В конце дня, пытаясь понять, куда делось время, вы редко когда сможете вспомнить, кто звонил и почему. Даже если некоторые звонки были важными, то не настолько, чтобы жертвовать состоянием потока. Но у кого хватит выдержки дождаться, когда телефон умолкнет? Сама мысль о том, чтобы терпеть звонки, уже вызывает напряжение.

    Путешествие в альтернативную реальность

    Теперь просто расслабьтесь и вообразите не столь сложный мир, в котором телефон ещё не изобрели. Вы отправляете записку с предложением пообедать или встретиться и в ответ тоже получаете записку. Все планирование идёт с некоторым опережением. Совершенно естественно потратить утром полчаса на то, чтобы прочитать почту и ответить на неё. В вашей жизни нет громкого звона.
    В среду утром в этой альтернативной реальности проходят собрания трастового пенсионного комитета вашей компании. Вообразите на секунду, что вы — один из представителей сотрудников компании, которому поручено наблюдать за вложением капиталов. В одну из таких сред в расписании значится презентация изобретения. Изобретатель собирается изменить мир — конечно, если вы вложите деньги в его штуковину. Его зовут А. Г. Белл.
    «Дамы и господа, это называется беллофон!» (Человек извлекает на свет здоровенный чёрный ящик с ручкой сбоку и гигантским звонком сверху.) «Это будущее. Мы поставим такой беллофон на каждый рабочий стол в Америке. И у нас дома тоже такие будут. В какой-то момент люди уже не смогут представить себе мир без этого устройства».
    Приближаясь к сути, он начинает горячо жестикулировать и перемещаться по комнате. «Беллофоны повсюду, куда ни посмотри, все до единого объединённые проводами, проложенными под улицами или по воздуху. А вот теперь самое интересное: вы можете подключить свой беллофон к беллофону другого человека, хотя вы находитесь в разных концах города или даже в разных городах. Подключиться очень просто — достаточно набрать код, и аппарат этого человека зазвонит. И звоночек не какой-нибудь там пустяковый, а такой, что сердце замирает».
    Он устанавливает в другом конце комнаты второй аппарат и подключает его к первому. Манипулируя диском на поверхности первого аппарата, он приводит второй в действие. Звучит громкое ДЗЗЗЗЗЗИНННННННННЬ! Полсекунды спустя снова раздаётся оглушающий звон, затем опять и опять.
    «Итак, что должен сделать второй, чтобы прекратить звон? Он должен подбежать к своему беллофону и снять трубку». Белл снимает трубку на звонящем аппарате и вручает её одному из участников комитета. Затем он уходит в другой конец комнаты и принимается орать в микрофон первого аппарата: «Алло! Алло! Меня слышно? Вот, смотрите, я полностью завладел его вниманием. Теперь я могу продать ему что-нибудь, или сделать так, чтобы он одолжил мне денег, или обратить его в другую религию, все что угодно!»
    Комитет шокирован. Вы поднимаете руку и спрашиваете: «А зачем повторять звонок, если он такой громкий?»
    «О, в этом и прелесть беллофона, — отвечает изобретатель. — Он не даёт вам задуматься о том, хотите ли вы отвечать на звонок. Неважно, чем вы заняты в этот момент, неважно, насколько увлечены, вы бросите все, чтобы ответить. Потому что понимаете, что если не ответить, он будет звонить и звонить. Мы продадим миллиарды таких штук и запретим продавать аппараты, которые звонят лишь единожды».
    Комитет удаляется на совещание, но решение принимает довольно быстро. Решение единогласно: выбросить этого неудачника за дверь. Его устройство столь разрушительно, что если бы по чьей-то тупости его установили, люди не смогли бы работать в офисе. Несколько лет воздействия беллофона, и мы все начнём покупать товары из Тайваня или Кореи. И наша страна, возможно, даже начнёт торговать себе в убыток.

    Байки из склепа

    Конечно, историю не изменишь. Телефон уже существует и будет существовать. От него нельзя избавиться, да это и ни к чему. Несомненно, попытка убрать телефоны с рабочих столов приведёт к революции. Но есть определённые шаги, которые позволяют минимизировать отрицательное воздействие отвлекающих звонков. Наиболее важный шаг — осознать, насколько сильно телефон участвует в планировании нашего времени.
    Часто ли вы прерываете беседу с коллегами или друзьями, чтобы ответить на звонок? Разумеется, да. Вы даже не задумываетесь о возможности на него не ответить. Но ведь это нарушение общих принципов справедливости; нельзя отвлекаться от своих дел лишь потому, что кто-то громко (ДДДДДЗЗЗЗИНННННННННННЬ!) требует вашего внимания. Вы не только делаете это сами, но и позволяете делать это с собой. И вы настолько привыкли к подобному злоупотреблению, что едва замечаете его. Лишь в самых невообразимых ситуациях становится ясно, что такое поведение неуместно.
    Лет двадцать тому назад мне пришлось стоять в очереди в отделе запчастей нью-йоркского дилера компании Morgan Motorcars Limited. У меня был сломанный Морган (единственный в своём роде), и я надеялся достать карбюраторные иглы. Владельцы английских спортка-ров — несомненно, мазохисты, но та очередь за запчастями переходила всякие границы. Продавец отвечал на один телефонный звонок за другим, а вся очередь ждала, когда он закончит. Когда я добрался до прилавка, он быстро ответил на четыре звонка, прежде чем я успел вставить хоть слово. Ну почему же, начал размышлять я, люди, которые звонят из собственных комфортабельных домов, получают преимущество перед теми, кто стоит в этой идиотской очереди? Почему этих праздно интересующихся пропускают перед теми, кто стоит с деньгами в руках, приготовившись к покупке? В состоянии полного бешенства я предложил продавцу оставить звонящий телефон в покое и обслужить сначала покупателей. Удивительно, но моё поведение взбесило его ещё больше, чем меня его. Он сообщил мне весьма раздражённо, что телефон более важен, чем люди, и дело с концом. Моё неприятие такой постановки вопроса было столь же бессмысленно, как, скажем, неприязнь к Атлантическому океану. Жизнь не могла измениться в мою пользу.
    Т. Д.
    Естественно, что телефон до некоторой степени изменил наши способы ведения дел, но это не должно закрывать нам глаза на воздействие внешних факторов. По меньшей мере, руководитель должен внимательно относиться к воздействию вмешательств на его людей, которые пытаются работать. Но часто именно руководитель сам становится злостным нарушителем. Один из участников военных манёвров разработчиков 1985 года написал в своём отчёте: «Когда мой босс уходит, он переключает свои звонки на меня». Интересно, о чем думал этот руководитель? Или что происходило в голове менеджера, написавшего в письме сотрудникам такое:
    «До моего сведения дошло, что многие из вас, будучи заняты, дают своим телефонам звонить более трех раз, в результате переключая звонки на секретарей. Из-за всех этих вмешательств секретари не могут продуктивно работать. Официальное правило нашей компании: находясь на рабочем месте, снимайте трубку до третьего звонка.»

    Модифицированная телефонная мораль

    Всякому терпению приходит конец. Путь к разумным условиям труда лежит через новое отношение к вынужденным перерывам в работе и новое отношение к телефонной связи. Люди, стремящиеся выполнить порученную им работу, должны иметь тихое место, где можно ею заняться. У них должны быть периоды полной свободы от вынужденных перерывов. Люди, желающие работать в потоке, должны иметь эффективный и приемлемый способ избавиться от телефонных звонков. «Приемлемый» означает осознание корпоративной культурой того факта, что людям иногда удобно быть недоступными для телефонных звонков. «Эффективный» означает, что не обязательно ждать, когда телефон закончит звонить, чтобы вернуться к работе.
    Существуют действенные способы избавляться от телефонных звонков и других факторов по мере необходимости. (Некоторые из этих способов связаны с затратами, а потому могут применяться лишь в организациях, долгосрочная перспектива которых простирается дальше следующего вторника.)
    Когда речь впервые зашла об электронной почте, многие из нас посчитали, что экономия бумаги — эффект просто замечательный. Но этот эффект просто мелочь в сравнении с экономией на времени повторного погружения в поток. Серьёзная разница между телефонным звонком и сообщением электронной почты в том, что телефонный звонок прерывает работу, а электронная почта — нет. Получатель реагирует на почту так, как ему это удобно. Объёмы переписки в системах электронной почты доказывают, что правило «удобства адресата» приемлемо для подавляющего большинства деловых взаимодействий. После периода привыкания сотрудники начинают использовать электронную почту вместо внутренних телефонных звонков. Это избавляет не от всех звонков, но от большинства.
    Эта технология, вероятно, пришла уже и к вам в офис. Большинство из нас сейчас пользуются приемлемыми почтовыми службами — голосовой и электронной. Фокус не в технологии, а в смене привычек. (Благородные читатели, пожалуйста, обратите внимание на этот постоянный лейтмотив.) Мы должны научиться спрашивать. Настолько ли важна новость или вопрос, чтобы прерывать работу? Могу ли я продолжать работать в ожидании ответа? Требует ли сообщение немедленной реакции? Если нет, то насколько долгой может быть задержка?
    Когда ответы на эти вопросы получены, лучший способ общения, как правило, становится очевиден. Есть, правда, одна проблема: насколько надёжен этот способ? К примеру, как долго ваше сообщение электронной почты будет ожидать ответа? Прочтут ли его или оно просто осядет в папке входящих?
    В благодарность за время непрерывной интеллектуальной работы люди должны ежедневно выделять время на подобные взаимодействия, при этом необходимо общее понимание того, что электронную почту разумно проверять не реже, скажем, трех раз в день.

    Не пробуйте повторить это сами…

    В последние несколько лет я консультирую одного руководителя из Лос-Анджелеса. Он управляет группой тестирования, работающей иногда в две или три смены. Участники группы общаются посредством электронной почты, поскольку в любой момент времени примерно треть команды может спать. Он рассказал мне о своих утренних упражнениях с почтой. Проснувшись, он включает свой лэптоп, чтобы получить новые сообщения, пока будет принимать душ. Во время завтрака он читает новые сообщения и выбирает те, что требуют немедленного ответа. По дороге на работу, а ехать ему, как типичному жителю Лос-Анджелеса, где-то восемьдесят километров, он отвечает на эти сообщения. Прибыв на работу, он подключает компьютер к сети и отправляет ответы. Фокус в том, что каждое утро он сам садится за руль своей машины.
    Т. Д.
    Изменение отношения гораздо важнее любого новшества. Люди должны понять, что иногда допустимо игнорировать телефон и что их время имеет огромное значение не только в количественном, но и в качественном аспекте.

    12. Верните дверь на место

    В практике создания разумного рабочего места существуют распространённые приметы удач и провалов. Наиболее очевидным признаком успеха является дверь. Там, где дверей достаточно, сотрудники могут регулировать уровень шума и вынужденные перерывы по ситуации. Наиболее очевидным признаком провала является система громких объявлений. Систематическое отвлечение от работы всех сотрудников, преследующее цель найти одного, есть проявление полного невежества в сфере устройства среды, способствующей продуктивной работе.
    Умело обращаясь с этими символами, вы не только привлечёте внимание к своей заинтересованности в качестве рабочей среды, но и немедленно начнёте извлекать соответствующую пользу: люди смогут работать. Избавиться от системы объявлений и поставить на место дверь — звучит как чрезмерное требование? Хватит ли у нас возможностей, чтобы воплотить в жизнь эти идеи?

    Нет, наша песенка пока не спета

    Деградация условий работы, затронувшая многих из нас в последние десять лет, во многом произошла с безмолвного согласия жертв. Мы не хотим сказать, что одна из жертв могла бы остановить процесс, заявив: «Нет, я не стану работать в шумном, тесном, открытом для посторонних глаз месте». Но все мы вместе недостаточно громко и недостаточно много кричали о разрушительных побочных эффектах экономии денег на площадях.
    В большинстве своём мы полагали, что повышение уровня шума и уменьшение рабочих площадей отрицательно влияет на производительность, но молчали, потому что не имели достаточных количественных улик, подтверждающих нашу позицию. Впрочем, мебельная полиция не предоставила вовсе никаких доказательств в поддержку своей убеждённости, что люди имеют одинаковую производительность, будучи селёдками в бочке или находясь в просторных офисах. Мебельная полиция просто заявила, что это так.
    Мы должны учиться у них отвечать теми же средствами. Так, первым шагом к разумной среде станет программа многократных утверждений. Если вы считаете, что среда работает против вас, то должны заговорить об этом. Необходимо создать форум, чтобы и другие могли присоединить свои голоса, возможно даже исследовать, как люди оценивают свои рабочие условия. (В одном подобном исследовании, проведённом в компании-клиенте, сотрудники обозначили семь отрицательных аспектов своей работы как ограничивающие производительность. Первые четыре из семи были связаны с шумом.)
    По мере того как люди начнут осознавать, что не одиноки в своих чувствах, будет расти и осведомлённость в области влияния среды. И по мере распространения этой осведомлённости станут заметны два положительных эффекта: во-первых, среда немного улучшится в результате повышенного внимания к шуму и вынужденным перерывам; во-вторых, исчезнет согласие жертвы. Теперь высокопоставленным руководителям станет сложнее предпринимать какие-либо шаги по улучшению производительности, не обратив некоторое внимание на параметры среды.
    Не ожидайте, что правящая элита попадает на спины и вытянет лапки только потому, что вы начали свою кампанию. Есть (по меньшей мере) три аргумента против, и они не замедлят проявиться:
  • Людям не нужны роскошные офисы, люди для этого слишком умны. А те, кому нужны, просто играют в престиж.
  • Вполне возможно, что проблема шума существует, но есть менее дорогие способы справиться с ней, чем возня с планировкой. Мы можем просто добавить белого шума или включить музыку, чтобы скрыть помехи.
  • Закрытые офисы представляют собой нездоровую среду. Мы хотим, чтобы люди продуктивно взаимодействовали, да они и сами этого хотят. Так что стены и двери — шаг в противоположном направлении.
    Эти три возражения мы рассмотрим в следующих трех подразделах.

    Роскошь

    Верно, что людей не очень заботит внешний вид. Каждый раз люди, участвовавшие в исследованиях, придавали небольшое значение выбору оформления, скажем, если дело касалось разноцветных панелей и креплений. Похоже, гнетущая обстановка влияла бы на производительность отрицательно, но если офис не угнетает, то обстановку можно игнорировать и продолжать работать. Если мы пытаемся создать лишь обстановку, которую человек способен игнорировать, то нет смысла тратить деньги на роскошную обстановку.
    Работников не очень заботит внешний вид офиса, и этот факт часто некорректно интерпретируется как их безразличие вообще ко всем аспектам обустройства рабочего места. Однако если спрашивать о конкретных вещах — шуме, уединённости, площади рабочего стола — мы услышим уверенный ответ: все эти вещи очень важны. Это открытие согласуется с представлением об идеальном рабочем месте — таком, которое можно игнорировать; вы не сможете игнорировать рабочее место, постоянно отвлекаясь на систему сообщений, делая вынужденные перерывы и подвергаясь прочим издевательствам.
    Нас особенно заботит, что беспокойство сотрудников относительно рабочей среды считается игрой в престиж, а ведь именно руководство склонно играть в престиж, проектируя рабочие места. Тот, кто в поте лица трудится, чтобы вовремя сдать высококачественный продукт, не интересуется видом офисной обстановки, а вот его начальство временами интересуется именно этим. Вот мы и наблюдаем парадоксальное явление: совершенно непригодное для работы пространство украшается дорогими и совершенно бесполезными шикарными коврами, чёрной с хромированными вставками мебелью, зерновыми культурами, занимающими места больше, чем сотрудники, и детально проработанными панелями. В следующий раз, участвуя в экскурсии по только что созданному офису, задумайтесь хорошенько, что здесь предлагают, — функциональность пространства или все-таки его внешний вид. Слишком часто напоказ выставляется именно последнее.
    При проектировании рабочих мест внешнему виду уделяется слишком большое внимание. Хотя гораздо важнее, есть ли возможность работать на этих местах. Офисное пространство, способствующее продуктивной работе, — не символ престижа, а необходимость. Вы заплатите за эту необходимость в твёрдой валюте сразу либо потом — потерями производительности.

    Творческое пространство

    В ответ на жалобы сотрудников по поводу шума можно попытаться вылечить симптомы или же устранить причину. Устранение причины потребует создания заграждений от шума — стен и дверей — и будет стоить денег. Лечить симптом гораздо дешевле. Установив «Мьюзек» или другой источник розового шума, вы малой кровью заглушаете шум, мешающий работе. Можно и ещё больше сэкономить — просто не обращать внимания на проблему; людям тогда придётся прибегнуть к помощи магнитофонов и наушников, чтобы защититься от шума. Избрав один из таких подходов, вы должны быть готовы понести невидимое наказание — пострадают творческие способности ваших сотрудников.
    В шестидесятые годы исследователи Корнелльского университета провели ряд тестов, в которых определялось воздействие музыки на работающего человека. Они опросили группу студентов факультета информатики и разделили их на две подгруппы. В первую вошли те, кому нравилась фоновая музыка в процессе работы или учёбы, во вторую — те, кому музыка мешала. Затем половину участников каждой из подгрупп поместили в тихую аудиторию, а вторую половину — в аудиторию, оборудованную наушниками с возможностью выбирать музыку. Участники в обеих аудиториях получили задачу по программированию на Фортране. Никого не удивило, что участники обеих аудиторий одинаково быстро и качественно справились с задачей. Как знает любой ребёнок, выполняющий под музыку домашнее задание по математике, музыка не затрагивает часть мозга, отвечающую за математические действия, её прослушиванием занят другой мозговой центр.
    Однако в Корнелльском эксперименте был ещё скрытый фактор. В постановке задачи требовалось, чтобы поток выходных данных формировался посредством ряда преобразований над числами из потока входных данных. Так, участникам предлагалось сдвинуть каждое число на две цифры влево, затем разделить его на сто, и так далее порядка десяти операций. И хотя в спецификации об этом не было сказано явно, конечным результатом всех преобразований над числом оказывалось обязательно само это число. Некоторые участники поняли это, а некоторые нет. Подавляющее большинство догадавшихся работало в тихой аудитории[42].
    Многие из повседневных задач, выполняемых профессиональными работниками, обсчитываются в центре последовательной обработки левого полушария. Музыка не особо мешает такой работе, поскольку её восприятием занимается правое холистическое полушарие мозга. Но не все задачи могут выполняться в левом полушарии. Есть ещё и моменты просветления, когда вы восклицаете «Ага!», обнаружив короткий путь, позволяющий сэкономить много месяцев или даже лет работы. Такое творческое озарение требует работы правого полушария. Если правое полушарие занято прослушиванием фортепианного концерта, возможность творческого озарения исчезает.
    Творческий штраф, налагаемый средой, отличается коварством. Поскольку творческие способности и без того проявляются нерегулярно, мы часто не замечаем, что они стали проявляться реже. Творческое мышление человека не нормировано. Подавление творческого мышления накапливается с течением времени. Организация становится менее работоспособной, люди без всякого вдохновения вымучивают результаты, а лучшие сотрудники покидают компанию.

    Жизненное пространство

    Аргументация против изолированных офисов рано или поздно доходит до «стерильности» работы в одиночестве. Однако изолированные кабинеты могут быть не только одиночными. Комнаты, вмещающие двух, трех или четырех человек гораздо более разумны, особенно если они обустроены так, как это удобно рабочей группе. Если работнику требуется проводить половину своего времени с другим человеком, то, как правило, это вполне конкретный человек. Вот два очевидных кандидата на общую комнату.
    Даже в офисах с открытой планировкой следует способствовать изменениям в решётке отсеков, разрешать коллегам превращать свои рабочие места в небольшие ансамбли. В этом случае люди проявляют активную изобретательность в переделке пространства под свои нужды: появляется рабочее пространство, места для рабочих встреч и места просто для общения. Поскольку коллеги, как правило, одновременно находятся в потоке или одновременно взаимодействуют, они меньше мешают друг другу, чем при случайном выборе соседей. Пространство получает жизненные качества, поскольку взаимодействие становится простым и естественным. Некоторая степень контроля над рабочим пространством считается дополнительным преимуществом.

    Ломка корпоративного шаблона

    Что может быть менее опасным, чем предложение разрешить людям реорганизовать открытую планировку, создать ансамбли рабочих мест вместо раздельных отсеков? Одно из серьёзных преимуществ такого рода «офисной системы» (то есть без кабинетов) состоит в том, что компания уже заплатила за её гибкость. По крайней мере, так написано в рекламном проспекте панельной системы. Так что перемещение её компонентов не должно вызывать затруднений. Идея кажется не опасной, однако мы прогнозируем, что кто-то в высших кругах организации возненавидит её.
    Проблема в том, что эта идея нарушает священный принцип единообразия. Насаждая единообразие, «владелец» территории осуществляет и демонстрирует контроль. Подобно садовнику, высаживающему семена в точности по туго натянутой верёвке, чтобы морковь росла идеальными рядами, этот руководитель чувствует для себя угрозу со стороны природного беспорядка (в данном случае речь идёт о человеческой природе).
    Неудобная правда жизни: лучшее рабочее место невозможно многократно копировать. Обстановку, способствующую работе, разные люди понимают по-разному. Если позволить людям сделать с пространством то, что им нужно, оно в результате потеряет своё единообразие. Пространство каждого человека, каждой команды будет иметь свой собственный характер. А если нет, они переделают все заново и будут переделывать, пока не добьются этого.
    Руководство, если оно хорошее, должно убедиться, что сотрудникам просторно, что им не мешают посторонние шумы, что существует достаточно способов найти уединение и создать разумные рабочие места. Единообразию в этом подходе места нет. Если люди вешают странные картинки, оставляют беспорядок на столах или передвигают мебель с целью объединения кабинетов, вам остаётся лишь ухмыльнуться и смириться с этим. Как только они добьются своего, то смогут перестать думать о среде и полностью отдадутся работе.

    13. Танцы с зонтиком

    В последней главе, посвящённой офисной среде, мы рассмотрим свойства идеального рабочего места и попытаемся пролить свет на вопросы, подобные этим:
  • Какая рабочая среда будет самой удобной для ваших сотрудников и повысит производительность их труда?
  • Какие рабочие места позволят сотрудникам раскрыть свой потенциал и получить удовлетворение от работы?
    Если вам приходится работать в типичном зашумленном и кошмарно единообразном корпоративном пространстве, такие вопросы могут показаться почти жестокими. Однако задумываться об идеальной рабочей среде имеет смысл. Когда-нибудь вы можете обнаружить, что этот вопрос в вашей власти. Даже сегодня вас могут попросить внести свои соображения в процесс улучшения рабочего пространства. Разумно позволить себе поразмышлять на эти темы, просто чтобы знать, какое из направлений верное. По нашему мнению, правильное направление приводит к рабочему месту, обладающему определёнными, проверенными временем характеристиками.
    Существует способ строительства на века [43] . Ему тысячи лет, и сегодня он такой же, каким был всегда. Великие традиционные постройки прошлого — деревни, шатры и храмы, в которых человек себя чувствует словно дома, всегда создавались людьми, неизменно очень близкими к сути этого способа. Лишь следуя этому способу, можно строить великие здания, великие города, прекрасные места, где чувствуешь себя самим собой, где чувствуешь себя живым. И, как вы увидите, каждый, кто ищет этот способ, придёт к зданиям, столь же древним по форме, как деревья, холмы и наши лица.
    The Timeless Way of Building (Строительство на века)
    Кристофер Александер, архитектор и философ, более всего известен своими наблюдениями в области процессов проектирования. Он облекает свои мысли в архитектурную форму, но некоторые из его идей повлияли не только на архитектуру. (Скажем, книга Александера «Notes on the Synthesis of Form» (Заметки о синтезе формы) считается почти священной у дизайнеров многих отраслей.) Александер и его коллеги из центра изучения структуры окружающей среды (Center for Environmental Structures) задались целью классифицировать элементы хорошего архитектурного дизайна. В результате на свет появился трехтомный труд, озаглавленный «The Timeless Way of Building» (Строительство на века). О содержании этой работы спорят до сих пор. Александер полагает, что современная архитектура по преимуществу несостоятельна, а потому современным архитекторам свойственна вполне понятная оборонительная позиция в отношении этого человека и его идей. Но когда вы держите эти книги в руках и сравниваете предложенные посылки с собственным опытом, трудно не поддержать Александера. Его философия закрытого пространства неотразима. Она помогает понять, почему вам так полюбились определённые места, а в других всегда так неуютно.

    Александер и его органический порядок

    Представьте, что ваша организация вот-вот приступит к строительству нового комплекса. Каков первый шаг? Практически наверняка — разработка генерального плана. В большинстве случаев таково первое, оно же фатальное, отклонение от вневременного способа строить. Полные жизни, восхитительные, гармоничные места никогда не появляются на свет таким образом. Генеральный план создаёт образы чего-то грандиозного и обширного, образы пролётов из стали и бетона. Он подразумевает модульный подход и копирование, превращающие комплекс в гигантское целое, состоящее из идентичных элементов. Результат — стерильное единообразие и пространство, не привлекающее никого, кроме той Личности, в честь которой возведён этот монумент.
    Монолитное корпоративное пространство в большинстве случаев можно осмыслить лишь с точки зрения его символического значения для руководителей, по велению которых оно создавалось. Таков их плевок в вечность, достижение, которое просуществует ещё очень долго. «Взгляните, — торжествуют они, — взгляните на мои работы, о, Великие, и отчайтесь!» Отчаяние, собственно говоря, — здесь единственно возможная реакция. Отсек, размноженный до самого горизонта, заставляет вас почувствовать себя пронумерованным винтиком. Будь это оруэлловская башня TransAmerica в Сан-Франциско или мавзолей AT&T на Мэдисон-авеню, результат тоскливо одинаков: удушье для личности.
    Генеральный план есть попытка навязать тоталитарный порядок. Единое, а значит, единообразное видение руководит всем. Нет двух мест, в которых одна задача решалась бы по-разному. Побочный эффект тоталитарного подхода в том, что историческая оценка здания не меняется с течением времени.
    Александер предлагает вместо генерального плана использовать мета-план. Это философия, согласно которой здание может расти эволюционным путём, постепенно выполняя потребности тех, кто его занимает. Ме-таплан состоит из трех частей:
  • философии постепенного роста;
  • набора шаблонов или общих принципов дизайна, регулирующих рост;
  • локального влияния на дизайн тех, кто занимает пространство.
    В рамках метаплана объекты эволюционируют и посредством многочисленных лёгких изменений превращаются в университетские городки и сообщества взаимосвязанных зданий. Проявляя уважение к общим принципам, они сохраняют внешнюю гармонию, но не становятся одинаковыми. Подобно старым обжитым деревням, они со временем приобретают некий шарм. Александер называет это органическим порядком (рис. 13.1).
    Этот естественный, или же органический, порядок появляется как следствие идеального равновесия между потребностями отдельных элементов среды и потребностями среды в целом. В органичной среде каждое место уникально, а различные места объединяются — все до единого — в глобальное целое, доступное восприятию всех составляющих частей.
    Идеальным примером органического порядка является Кембриджский университет. Одна из самых прекрасных его особенностей — расположение колледжей — Сент-Джонс, Тринити, Тринити Холл, Клэр, Кинге, Петерхаус, Куинс — между главной улицей города и рекой. Каждый колледж включает систему общежитий, каждый имеет свой выход на улицу и каждый смотрит на реку. У каждого есть собственный маленький мост, который пересекает реку и ведёт к лугам, у каждого есть свой эллинг и тропинки для прогулок у реки. Но повторяя общую систему, каждый из колледжей имеет свой уникальный характер. Дворы, выходы, мосты, эллинги и тропинки отличаются один от другого.
    — The Oregon Experiment (Орегонский эксперимент)[44]

    [45]

    Шаблоны

    Каждый из шаблонов вечного способа строительства является абстракцией успешного решения в планировке и интерьере. Основной том книги «A Pattern Language» (Язык шаблонов) содержит описания 253 таких шаблонов и объединяет их в стройную систему взглядов на архитектуру. Некоторые из шаблонов относятся к свету и вместительности, другие — к отделке или же к отличиям пространства для взрослых, детей и старшего поколения, или же к сообщению вокруг и внутри закрытого пространства. Каждый шаблон представлен в виде простого архитектурного афоризма и дополняется иллюстрацией и уроком. Кроме этого имеется рассказ об идейных предпосылках шаблона. В качестве примера рассмотрим рис. 13.2 и выдержку из шаблона 183 «Worspace Enclosure» (Отгораживание рабочего места).
    Люди не могут эффективно работать, если их рабочие места слишком изолированы или слишком открыты. Хорошее рабочее место сбалансировано… На рабочем месте вы чувствуете себя уютнее, если за спиной у вас стена… Перед вами не должно быть пустой стены ближе чем в 2,5 метрах. (В процессе работы вы время от времени поднимаете глаза, чтобы дать им отдохнуть, сфокусироваться на чем-то не столь близком, как стол. Если пустая стена ближе, чем в 2,5 метрах, глаза не изменят фокусировку и не смогут отдохнуть. В таком случае вы почувствуете тесноту.)… Вы не должны слышать звуки, существенно отличающиеся от тех, что производите вы сами. Рабочее место должно быть достаточно изолированным, чтобы блокировать все такие звуки. Существуют свидетельства, что человек может лучше сосредоточиться на задаче, если люди вокруг него заняты такими же задачами, а не чем-нибудь ещё… Рабочее место должно позволять обращать взгляд в разные стороны.
    A Pattern Language (Язык шаблонов) [46]

    [47]
    Для того чтобы дополнить 253 базовых шаблона, командам следует подготовить набор новых шаблонов, приспособленных к природе своих проектов. Чтобы написать следующие четыре подраздела, мы вызвались добровольцами в такую команду. Наша задача — спроектировать разумные рабочие места для людей, зарабатывающих на жизнь интеллектуальным трудом. Четыре предложенных шаблона нацелены на четыре наиболее неприятных минуса современного рабочего пространства. При создании шаблонов мы многое позаимствовали у своих клиентов, которым удалось создать удачные рабочие места.

    Первый шаблон: подгонка стандартного рабочего пространства

    Современные модульные отсеки являются шедевром компромиссов: они не дают разумной уединённости, но каким-то образом заставляют почувствовать себя в изоляции. Вы слабо защищены от шума и внешних воздействий; более того, в некоторых случаях источники этих помех словно нацелены на ваше рабочее пространство. Но вы находитесь в изоляции, потому что это маленькое и одинокое место не нужно никому кроме вас (вроде туалетной кабинки, в которую забыли поставить унитаз). На таком месте трудно работать в одиночестве и почти невозможна совместная работа группы, которая могла бы сформироваться вокруг проекта.

    Изолированные отсеки предоставляют работающим в одиночку пространство низкого качества, а команде не предоставляют вовсе никакого пространства. Альтернатива этому — изменить пространство, подогнать его под потребности рабочих групп. Каждой команде нужны чётко выделенные общие и полузакрытые зоны. Каждому человеку требуется защищённое рабочее место.
    Группе людей, назначенных или вызвавшихся работать вместе, необходимо иметь значимую роль в проектировании своего рабочего пространства. В идеальном варианте им помогает централизованный отдел планирования, задача которого состоит в поиске места для группы: «Так, вас трое, значит, нужно как минимум тридцать квадратных метров. Да, вот неплохой вариант. Теперь давайте подумаем о планировке и мебели…» "Участники команды и их консультант по планировке начинают искать оптимальные способы распределения пространства (рис. 13.3).
    Из необходимости участия сотрудников в процессе проектирования собственного пространства видно, что организация столов и рабочих принадлежностей, предоставляемых компанией, должна быть действительно модульной. Обстановка должна приносить пользу в десятках различных конфигураций, а не только в простой сетке.

    Второй шаблон: окна

    Современная офисная политика в вопросе распределения окон строится на основе прямо-таки классовых принципов. В оконном тотализаторе проигрывает большинство участников. Люди, которым в голову не пришло бы поселиться в доме без окон, вынуждены в конечном итоге проводить большую часть своего светового дня на рабочих местах без окон. Александер весьма нетерпимо относится к пространству без окон: «Для тех, кто вынужден в них находиться, помещения без обзора подобны тюрьмам».
    Нам внушают, что офисное пространство без окон — это данность. Компания, безусловно, хотела бы, чтобы у каждого из нас было окно, но это просто невозможно. Ну, конечно! Существует идеальное доказательство, что достаточное количество окон можно получить без излишних затрат. Это доказательство — отель, любая гостиница. Невозможно даже представить комнату отеля, в которой нет окна. Никто этого не потерпит. (А ведь речь идёт только о пространстве для сна.) Поэтому отели строят так, чтобы в них было много окон.
    Проблема пространства без окон — прямое следствие квадратного формата. Если здание имеет достаточно вытянутую форму, появляется возможность избавиться от недостатка окон. Разумный предел ширины здания — девять метров, как в случае здания на рис. 13.4.

    [48]
    Ограничить ширину здания девятью метрами? Это что, всерьёз? А как насчёт стоимости? А как же экономия в связи с увеличением масштаба, сопутствующая гигантским внутренним пространствам? Несколько лет назад законодательные органы Дании приняли закон, по которому каждый работник должен иметь собственное окно. Этот закон вынудил строителей создавать длинные узкие здания, планировкой напоминающие отели и жилые здания. Исследования, проведённые через некоторое время после принятия закона, показали, что затраты на квадратный метр изменились не сильно. Это не означает, что изменение пропорций не влияет на стоимость, однако увеличение стоимости, если таковое присутствовало, было слишком мало, чтобы проявиться в собранных данных[49]. Даже если размещение сотрудников в более подходящем пространстве стоит дороже, эти затраты оправданы экономией в других областях. На самом деле проблема в том, что стоимость — это очень заметный показатель (площади и их обслуживание), тогда как компенсирующие преимущества относятся к недостаточно измеряемым, а следовательно, невидимым категориям (повышение производительности и снижение текучести кадров).

    Третий шаблон: закрытое и открытое пространство

    Узкая форма здания также делает возможной более тесную интеграцию закрытого и открытого пространства. Если вам когда-либо приходилось работать в месте, обладавшем открытой составляющей, трудно представить, что когда-либо вы ограничите себя полностью закрытым пространством.
    При создании организации Atlantic Systems Guild в 1983 году мы задались целью найти на Манхэттене место для собраний, которое послужило бы и офисом для членов организации, проживающих в Нью-Йорке. Мы нашли такое место и занимаем его до сих пор — на верхнем этаже магазина мореходных принадлежностей в Гринвич Виллидж[50]. Оно включает 180 квадратных метров закрытых площадей и открытую террасу площадью 90 квадратных метров. Эта терраса весной, летом и осенью служит нам конференц-залом и местом для еды. Около половины года открытое пространство используется практически с утра до вечера. Если работу можно сделать на террасе, там она и делается.
    Прежде чем отбросить наше решение как непозволительную роскошь, задумайтесь о таком факте: мы платим на треть меньше за каждый квадратный метр, чем в среднем по Манхэттену. Наши площади гораздо дешевле потому, что не входят в монолитное здание. На таких площадях невозможно централизованно размещать людей тысячами. Вам придётся перебрать сотни вариантов, чтобы найти подходящий для крупного штата сотрудников вариант, подобный нашему. И в конечном итоге ваши люди не получат одинаковых рабочих мест. В солнечный день некоторые сотрудники будут работать на террасах, тогда как других можно будет найти в саду или во внутреннем дворе. Ужасно непрактично.

    Четвёртый шаблон: общее пространство

    Традиционный шаблон закрытого пространства характеризуется свойством постепенного увеличения уединённости по мере продвижения вглубь. Периметр — это пространство, куда могут проникать посторонние (курьеры, коммерсанты, коммивояжёры). Далее начинается пространство, зарезервированное за своими (рабочая группа или семья), и наконец, пространство, предназначенное для единственного человека. Этот шаблон применим к вашему дому — уединённость повышается по мере перемещения из прихожей в гостиную, в кухню, в спальню, в ванную комнату. Подобные свойства должно проявлять хорошее рабочее место.
    В районе входа должна быть зона, принадлежащая всей группе. Это нечто вроде домашнего очага. Далее по шкале уединённости следует пространство, принадлежащее тесно связанным группам, — здесь они могут взаимодействовать и проходить социализацию. Наконец, есть защищённое и тихое пространство для размышлений, где человек может работать в одиночестве.
    В пространстве группового взаимодействия должны быть столы и сидячие места для всех участников группы, а также доски для объявлений и схем в нужном количестве. В идеальном варианте присутствует и общая столовая:
    Без совместного приёма пищи никакая группа людей не может держаться вместе. Дайте каждой [51] место, где люди могут поесть все вместе. Сделайте общую трапезу регулярным событием, в частности организуйте общий обед, чтобы искренняя трапеза за общим столом (не из коробочек, автоматов или пакетов) стала важным, приятным и ежедневным событием… В нашей собственной рабочей группе, в Центре, мы обнаружили, что лучше всего при этом готовить обед по очереди. Обед стал событием — собранием, в которое каждый из нас вложил свою любовь и энергию.
    A Pattern Language (Язык шаблонов) [52]

    Шаблон шаблонов

    Шаблоны успешного рабочего пространства проявляются вновь и вновь и существуют потому, что находятся в фундаментальной гармонии с характером человеческого существа. Они позволяют человеку быть человеком. Они подчёркивают его существо — он становится одновременно и индивидуумом, и участником группы. Шаблоны поддерживают как его индивидуальность, так и его склонность работать в команде. Они позволяют быть самим собой.
    Общее свойство всех шаблонов, как наших, так и разработанных Александером, — ориентация на неповторимые формулы. Никакие два человека не должны работать на одинаковых местах. Никакие два кафетерия не должны быть одинаковыми, равно как никакие две библиотеки или два конференц-зала. Строение, форма и организация пространства — это вопросы, вызывающие глубокий интерес людей, занимающих это пространство. Пространство должно соответствовать выполняемой в нем работе. И на любом уровне людям требуется возможность оставить свой след на рабочем месте.

    Возвращение в реальный мир

    Итак, какое же отношение все это имеет к вам? Если вы работаете на крупную организацию, то вряд ли сможете убедить руководителей признать ошибочность их путей и разрешить всем создавать рабочие места на века. И при этом, возможно, вы не хотите работать на маленькую компанию, для которой вполне естественно наличие очаровательных и уникальных рабочих мест.
    Тем не менее, есть способ разместить своих людей в полном жизни пространстве, способствующем повышению производительности труда. Возможность эта существует потому, что пространство, построенное по генеральному плану, почти всегда заполнено до предела, так что постоянно приходится искать место для новых проектов. Если вы стоите во главе одного из таких проектов и место для проекта ещё не найдено, обратите свой взор во внешний мир. Ходатайствуйте о переводе проектной группы за пределы корпоративного монолита. Вам могут отказать, но ведь поскольку в компании для вас нет подходящего места, могут и дать согласие. Дайте своим людям задание найти и обустроить собственное рабочее пространство. Не грустите, что там может не оказаться таких же пластиковых корзин или отсеков с вельветовой обшивкой, как в головном офисе. Если вам удастся арендовать заброшенный дом какого-нибудь общества или дом с участком, из которого получится недорогое, неповторимое и прекрасное пристанище для ваших людей, — что ж, значит, ваши люди будут пристроены не так, как остальные сотрудники компании. Кому какая разница, если это устраивает ваших сотрудников?
    Нет необходимости решать проблему рабочего пространства в масштабах всей организации. Если вы сможете решить её для своих людей, то уже окажетесь впереди. А если ваша группа более производительна и проявит меньшую текучесть кадров, это лишь подтвердит ваши достоинства как руководителя.
    Вывод проекта или рабочей группы из корпоративного пространства имеет смысл практически всегда. Работа в непринуждённой обстановке происходит с большей энергией и имеет больше шансов на успех. Люди меньше подвержены шуму, вмешательствам и раздражению. Необычная природа рабочего места способствует формированию групповой личности. Если вы принадлежите к высшему менеджменту, решайте, какие проекты имеют наибольшее значение. Перемещайте лишь ключевые проекты. Суровая правда такова, что важные проекты зачастую лучше себя чувствуют вне «дома». Обратите эту правду себе во благо.

    III. ПОДХОДЯЩИЕ ЛЮДИ

    Результат любого предприятия скорее зависит от того, кто делает работу, а не от того, как она делается. Однако современная теория управления почти не обращает внимания на поиск и сохранение подходящих людей. На какие бы курсы по управлению вы ни пошли, вы мало что услышите об этом.
    Теория управления намного больше интересуется ролью начальника как главного стратега и тактика предприятия. Вас учат, что руководить — все равно что играть в военную настольную игру. В такой игре нет необходимости считаться с личностями или отдельными талантами; победа или поражение зависит от ваших решений, где и когда расставить свои безликие пешки.
    В следующих четырех главах мы попытаемся возместить ущерб от принципа «руководитель-стратег», заменив его подходом, поощряющим вас добиваться успеха при помощи следующей формулы:
  • найдите подходящих людей;
  • сделайте так, чтобы они были счастливы и не хотели уходить;
  • дайте им волю.
    Разумеется, вам придётся координировать усилия даже лучших участников команды, чтобы вклад отдельных людей объединялся в целое. Но это более или менее техническая часть руководства. Для большинства предприятий исход определяется судьбой в тот момент, когда создаётся команда и выбираются начальные направления. Имея талантливых сотрудников, руководитель может добиться результатов без особого труда.

    14. Фактор Хорнблауэра

    В серии романов Форестера о наполеоновских войнах действует офицер британского флота Гораций Хорнблауэр. В какой-то мере эти книги представляют собой чисто приключенческие истории, происходящие в контексте хорошо изученной исторической эпохи. С другой стороны, их можно читать как серьёзные книги о менеджменте. Управление фрегатом с четырехугольными парусами или линкором не так уж отличается от управления подразделением компании или проектом. Вопросы набора и подготовки персонала, распределения задач, составления расписания и тактической поддержки знакомы каждому, кто сегодня связан с руководством.
    Хорнблауэр — совершённый руководитель. Он сделал карьеру от курсанта до адмирала посредством того сочетания ума, отваги, политической подкованности и удачи, что не раз помогало людям, забравшимся на самую вершину карьерной лестницы. Каждое решение Хорнблауэра содержит ценный урок для руководителя.

    Прирождённые против обучившихся

    Красной нитью через все романы проходит печальная предубеждённость Хорнблауэра в том, что успешные люди рождаются таковыми, успешности нельзя обучиться. Многие из доставшихся ему по воле случая подчинённых ненадёжны или глупы. Он знает, что в критический момент они его подведут. (Так оно и происходит.) Он также знает, что может полагаться лишь на немногих настоящих мужчин. Умение находить надёжных людей и полагаться на них — вот два истинных таланта Хорнблауэра.
    Мы живём в эпоху равноправия, когда почти невозможно себе представить, что кого-то спишут со счётов за врождённую некомпетентность.
    Предполагается, что каждому человеку присуща определённая ценность. И руководители должны использовать своё мастерство лидера, чтобы открыть эти невидимые качества в каждом из подчинённых. Вот эта лепка из человеческого материала и считается сущностью руководства.
    Такой подход может быть более приемлемым, чем суровое мнение Хорнблауэра, и уж конечно, он сильнее льстит руководителям, но нам он кажется не очень реалистическим. Родители за много лет действительно умудряются оказывать влияние на развитие своих детей, а отдельные люди, несомненно, способны многое в себе изменить. Однако маловероятно, что руководителю удастся осмысленно изменить своих сотрудников. Люди обычно не остаются надолго на одном месте, а у руководителя просто нет подходящих рычагов воздействия, чтобы изменить их природу. Поэтому люди, проработавшие на вас какое-то время, в конце этого периода будут такими же, как в начале. Если они изначально не подходят для такой работы, то такими и остаются навсегда.
    Очевидно, поиск подходящих людей в начале проекта имеет первостепенное значение. К счастью, вы не должны полностью полагаться на случай. Вы можете сыграть значимую роль в наборе новых людей или отборе имеющихся сотрудников для новой команды. Если так, ваше мастерство в этой области в значительной степени определит успех предприятия.

    Пластиковый человек установленной формы

    Даже начинающий руководитель, впервые проводящий набор персонала в команду, знает кое-что о принципах квалифицированного найма. Скажем, что нельзя нанимать человека на основании его внешнего вида. Идеальная внешность кандидата вовсе не говорит о том, что он сможет создать продукт более качественный, чем другой кандидат, с виду невзрачный.
    Это общеизвестно, однако, что странно, большая часть ошибок при найме вызвана излишним вниманием к внешним особенностям кандидата и недостаточным вниманием к его способностям. И это происходит не из-за невежества или ограниченности человека, осуществляющего найм. Эволюция заложила в каждого из нас определённое беспокойство в отношении людей, слишком отличающихся от среднего человека. Вполне очевидно, каким образом эта тенденция служит целям эволюции. Вы можете пронаблюдать эту защитную реакцию в себе — например, в собственном восприятии фильмов ужасов. Почти человеческое «создание» гораздо страшнее, чем километровая безглазая капля, медленно пожирающая Детройт.
    Каждый индивидуум по мере взросления учится преодолевать заложенную склонность к норме при выборе друзей и развитии близких отношений. И хотя вы, возможно, выучили этот урок давным-давно из личного опыта, вам придётся выучить его заново, чтобы повысить своё мастерство в найме.
    Вероятно, вам совсем не кажется, что вы безвольно нанимаете привлекательных или просто «нормальных» людей. Так почему же тогда мы это обсуждаем? Потому что на найм влияет не только ваша личная склонность к норме, но и лежащее ниже порога восприятия давление норм корпоративных. Каждый нанятый человек становится частичкой вашей маленькой империи, а также частичкой империи вашего начальника и так далее до самого верха. Вы нанимаете от имени и по поручению целой корпоративной лестницы. Проявления норм руководителей высшего звена воздействуют на вас всякий раз, когда вы раздумываете, предложить ли человеку работу. Это почти неощутимое давление склоняет вас к усреднённым нормам, поощряет найм людей, которые выглядят, говорят, думают так же, как все остальные. В здоровой корпоративной культуре этот эффект может быть пренебрежимо мал. Однако когда культура здоровьем не отличается, сложно или невозможно нанять именно такого человека, который нужен, — человека, думающего не как все.
    Потребность в единообразии — признак неуверенности со стороны руководства. Для сильного руководителя не имеет значения, как стригутся участники команды или носят ли они галстуки. Гордость такого руководителя связана только с достижениями сотрудников.

    Униформа

    Единообразие настолько важно для ненадёжных авторитарных режимов (к примеру, для приходских школ и армий), что они вводят ещё и правила для одежды. Различная длина юбок или различные цвета рубашек — это угроза, все подобное запрещается. Ничто не должно нарушать гармонии длинных рядов практически идентичных пехотинцев. Достижения имеют смысл лишь тогда, когда их совершают внешне стандартные люди.
    И некоторые компании вводят стандарты одежды. Не столь строгие, чтобы требовать определённой униформы, но все же серьёзно ограничивающие свободу выбора. Когда это происходит впервые, вред поистине огромен. Люди не могут говорить и думать ни о чем другом. Всякая полезная работа прекращается. Наиболее ценные сотрудники начинают понимать, что их действительные достижения никто не ценит, что их вклад в общее дело не так важен, как стрижки и галстуки. В конечном итоге они уходят. Компания же плетётся дальше, пытаясь доказать, что найм подходящих людей, как выяснилось, не так уж важен.
    На страницах этой книги мы предлагали лекарства от некоторых болезней, поражающих организации. Но если заболевание принимает форму пропаганды формального стандарта внешности, пиши пропало. Лечить уже слишком поздно. Организация находится на последних стадиях разрушения коры головного мозга. Труп упадёт не сразу, поскольку очень многие его поддерживают. Но поддерживать труп — работа, не приносящая удовлетворения. Найдите себе другую.

    Кодовое слово: Профессионализм

    Когда я сослался на неуверенность руководства как причину любой стандартизации, участники одного закрытого семинара едва сдерживались. Их всех распирало от историй. Один из самых глупых случаев — реакция компании на использование микроволновки в кафетерии для приготовления попкорна на обед. Понятно, что попкорн оставляет характерный запах, и кто-то из верхних слоёв руководства его учуял. «Попкорн, — написал он, — проявление непрофессионализма. Чтобы впредь этого не было».
    Т. Д.
    Стандарт, запрещающий попкорн или рекомендующий определённую одежду, можно понять, если вы работаете в отделе поддержки клиентов или в отделе сбыта. Но в любой другой области подобные стандарты не имеют смысла. Редко когда у таких компаний вообще есть клиенты. Эти «стандарты» не имеют ничего общего с предназначенным для посторонних имиджем организации. Здесь значение придаётся внутреннему имиджу, для своих. Свои — это, как правило, не уверенные в себе руководители второго и третьего уровней. Им неловко иметь дело с поведением, отличающимся от среднего. Им необходимо распространить стерильные, гомогенизированные нравы на своих подчинённых, чтобы продемонстрировать, «кто тут главный».
    Слово непрофессиональный часто употребляется для обозначения неожиданного и угрожающего поведения. Все, что может обеспокоить слабого руководителя, непрофессионально почти по определению. Так что попкорн — это непрофессионально. Длинные волосы — непрофессионально, если растут на мужской голове, но совершенно приемлемо, если на женской. Плакаты любого вида — это непрофессионально. Удобная обувь — непрофессионально. Танцы вокруг стола, когда происходит что-то хорошее, — непрофессионально. Хихикать и смеяться — непрофессионально. (Улыбаться можно, но не слишком часто.)
    И наоборот, профессиональный — значит, предсказуемый. Вас станут считать профессионалом настолько, насколько вы выглядите, действуете и думаете, как все остальные, как все идеальные пчелы.
    Разумеется, это извращённое чувство профессионализма патологично. В более здоровых культурах людей считают профессионалами, оценивая их познания и компетенцию.

    Корпоративная энтропия

    Энтропия — это равномерность или одинаковость. Чем больше энтропия, тем меньше потенциала для применения энергии или выполнения работы. В корпорации или иной организации энтропию можно рассматривать как единообразие мнений, внешности и мыслительных процессов. Корпоративная энтропия подобна термодинамической, которая во Вселенной непрерывно увеличивается:

    ВТОРОЙ ЗАКОН ТЕРМОДИНАМИКИ МЕНЕДЖМЕНТА: Энтропия в организации постоянно увеличивается.

    Именно поэтому в более старых организациях теснее и не так весело работать, как в энергичных молодых компаниях.
    С этим явлением вряд ли можно бороться в глобальном масштабе, однако в своей собственной области вы должны ему противостоять. Наиболее успешный руководитель будоражит локальную энтропию, нанимая подходящих людей и разрешая им быть собой, пусть даже приходится отступать от корпоративных норм. Когда у вашей организации начнётся трупное окоченение, орган, находящийся под вашим контролем, будет ещё жив и здоров.

    15. Как нанять жонглёра

    Менеджер: «Как давно вы жонглируете?» Кандидат: «Ну, примерно шесть лет».
    Менеджер: «Тремя, четырьмя, пятью шарами умеете жонглировать?» Кандидат: «Да, да и да».
    Менеджер: «Работаете с горящими предметами?» Кандидат: «Конечно».
    Менеджер: «…ножами, топорами, открытыми коробками с сигарами, мягкими широкополыми шляпами?» Кандидат: «Мне все равно, чем жонглировать».
    Менеджер: «А какую-нибудь весёлую скороговорку знаете?» Кандидат: «Онабесподобна».
    Менеджер: «Что ж, мне нравится. Думаю, мы вас возьмём». Кандидат: «Аааа… Не хотите посмотреть, как я жонглирую?» Менеджер: «Хм, мне как-то это не пришло в голову».
    Нелепо брать на работу жонглёра, не увидев сперва, как он жонглирует. Это просто здравый смысл. И все-таки, когда вы принимаете решение нанять инженера, проектировщика, программиста или руководителя группы, правила здравого смысла часто отходят на второй план. Вы не просите показать проект, или программу, или что-то ещё. По сути дела это просто «собеседование».
    Вы нанимаете человека, чтобы создавать продукт, предположительно подобный тому, что он или она уже создавали в прошлом. Вам требуется изучить образцы тех продуктов, чтобы оценить качество работы кандидата. Это может показаться очевидным, но руководители проектов по разработке почти всегда упускают это из виду. На собеседовании существует некая поверхностная сдержанность в отношении примеров выполненных работ. Словно неписаное правило, разрешающее интересоваться прошлыми проектами, но не требовать у кандидата образцы работы. А ведь если спросить, большинство кандидатов будут рады что-нибудь показать.

    Портфолио

    Весной 1979 года, когда мы занимались преподавательской работой на западе Канады, позвонил преподаватель информатики одного местного университета. Он предложил как-нибудь вечерком угостить нас пивом в обмен на идеи. От таких предложений мы редко отказываемся. То, что мы узнали от него в тот вечер, стоит определённо больше, чем то, что он узнал от нас.
    Этот преподаватель честно объяснил, что ему нужно признание в своей области, а для этого необходимо, чтобы его ученики получили хорошие предложения, много хороших предложений. «Диплом Гарварда ценен сам по себе, а вот наш диплом не стоит ничего. Если выпускники этого года быстро не найдут работу, то работы не будет и у меня.» Поэтому он разработал формулу, позволяющую сделать его выпускников как можно более привлекательными на рынке рабочей силы. Разумеется, он преподавал им современные методы конструирования систем, включая структурный анализ и основанное на данных проектирование, сокрытие информации, структурное программирование, командное рецензирование и метрики. Он также предоставлял им работу над реальными проектами в местных компаниях и агентствах. Однако важнейшим в этой формуле стало портфолио. В портфолио каждый учащийся собирал примеры своей работы.
    Он объяснил учащимся, как следует представлять портфолио на интервью:
    «Я принёс образцы выполненных работ. Вот, к примеру, подпрограмма на Паскале из одного проекта, а вот фрагмент на КОБОЛЕ из другого. Как видите, здесь мы использовали цикл с условием выхода, рекомендованный Кнутом, но в остальном это чистый структурный код, в большой степени соответствующий требованиям вашей компании. А вот проект, по которому этот код был создан. В иерархиях и для анализа сцепления используется нотация Майерса. Вот эту подсистему я полностью спроектировал сам, плюс вот этот небольшой раздел, где мы применили некоторые методы Орра, потому что структуры данных очень хорошо коррелировали со структурой процессов. А вот это направленные диаграммы потоков данных, существенная часть нашей спецификации, и ещё словарь предметной области…»
    В последующие годы мы ещё часто слышали об этом малоизвестном университете и этих портфолио. Нам доводилось видеть агентов по найму аж из Северной Каролины и Флориды, регулярно совершавших набеги на далёкий канадский учебный городок в надежде заполучить его выпускников.
    Конечно, со стороны преподавателя было умно придумать такой способ придавать своим выпускникам дополнительное ускорение, но в тот вечер нас больше всего поразило, что интервьюеров всегда удивляли портфолио. Это означало, что они не имели привычки предлагать кандидатам приносить портфолио на собеседования. Но почему нет? Что может быть разумнее, чем попросить каждого кандидата принести на собеседование примеры своих работ?

    Тесты на профпригодность

    Если так важно, чтобы новый сотрудник хорошо владел различными навыками работы, почему не спроектировать тест на пригодность, чтобы измерить его квалификацию? В нашей отрасли идеей тестирования на профпригодность интересуются давно и с переменным успехом. В шестидесятые годы эта идея была весьма популярной. Сегодня же, вероятно, вы и ваша организация уже распрощались с ней. Но если нет, мы знаем одну важную причину, по которой распрощаться все же стоит: тесты измеряют не то, что нужно.
    Тесты на профпригодность почти всегда ориентированы на задачи, которые человек будет решать непосредственно после найма. Эти тесты определяют, насколько вероятно, что человек будет хорош в роли аналитика или программиста, или в том, что требуется для данной конкретной должности. Легко можно ознакомиться с тестами практически для любой технической области, и все они весьма тщательно опробованы в плане предсказания того, насколько хорошо будет работать новый человек. Ну и что? Успешный новый сотрудник может успешно выполнять эти задачи в течение нескольких лет, а затем стать лидером команды, или возглавить проект, или продвигать продукты. Этот человек в конечном итоге может потратить два года на задачи, определённые тестом, а потом двадцать — на совершенно другие.
    Известные нам тесты на профпригодность в основном ориентированы на левое полушарие мозга. Дело в том, что новые сотрудники, как правило, выполняют задачи, связанные с левым полушарием. А вот то, чем они будут заниматься в своей дальнейшей жизни, в гораздо большей степени связано с правым полушарием. Руководство в частности требует целостного мышления, эвристических суждений, а также основанной на опыте интуиции. Поэтому тест на профпригодность может выявить людей, более полезных на короткой дистанции, но в будущем вряд ли успешных. Возможно, проводя тест на профпригодность, следует нанимать тех, кто его провалит.
    Читая эти строки, вы вряд ли сделаете вывод, что авторы одобряют идею найма по результатам тестов на профпригодность. Из этого не следует, однако, что тесты никуда не годятся или что вам вообще не следует их применять. Тем не менее применять их следует, но не для найма. Типичный купленный или созданный вами тест на профпригодность может стать для ваших людей замечательным средством самооценки. Частая возможность оценивать себя — обязательное условие труда в жизнеспособной организации. (К этому мы ещё вернёмся в главе 24.)

    Организация проб

    Наш бизнес не столько технологический, сколько социологический, он больше зависит от способностей сотрудников общаться между собой, чем от их способности общаться с машинами. Поэтому в процессе найма необходимо уделять главное внимание хотя бы некоторым аспектам социологии и человеческого взаимодействия. Мы обнаружили, что лучший способ это сделать — устроить пробы для кандидатов на места.
    Идея достаточно проста. Попросите кандидата подготовить короткую, на десять или пятнадцать минут, презентацию какой-либо показательной работы, выполненной кандидатом в прошлом. Презентация может быть посвящена новой технологии и первым попыткам её применения, или же какому-то открытию из области руководства, сделанному на основании собственного опыта, или особенно интересному проекту. Предмет выбирает кандидат. Назначив дату, соберите небольшую аудиторию из тех, кто будет работать с новым сотрудником.
    Разумеется, кандидат будет нервничать, возможно, даже неохотно пойдёт на подобный эксперимент. Вам придётся объяснить, что все кандидаты нервничают на пробах, и привести свои аргументы в пользу такого прослушивания: необходимо понять, какими навыками общения обладают кандидаты, а также позволить их будущим коллегам принять участие в процессе приёма на работу.
    В конце прослушивания, когда кандидат уже ушёл, обсудите с присутствующими впечатления. Каждый может изложить свои соображения о том, насколько человек подходит для работы и впишется ли он в команду. И хотя в конечном итоге ответственность за принятие решение ложится на вас, информация, полученная от сотрудников, может оказаться бесценной. Что ещё важнее, любой нанятый таким способом человек приживётся в команде лучше, поскольку другие её участники тоже его выбирали.
    Мой первый опыт проб был связан с наймом людей на должности консультантов и инструкторов. Свою потребность испытывать потенциальных работников я объяснял просто: я хотел понять, имеет ли каждый отдельно взятый кандидат врождённую способность объяснять простое и сложное, или же его можно научить этому, или же он никогда не сможет никому ничего объяснить. Мне также хотелось получить дополнительное заключение, поэтому я пригласил своих сотрудников, находившихся в тот момент в офисе. За пять лет мы проводили такие пробы около двухсот раз.
    Мы очень быстро поняли, что прослушивание ускоряет социализацию нового сотрудника в коллективе. Успешное прослушивание стало своего рода сертификацией на роль равного. Обратное тоже оказалось верным. Если проба давала сбой, мотивация коллектива мгновенно поднималась. Все единодушно подтверждали, что набор в группу в самом деле зависит вовсе не от того, в каком настроении начальник будет читать резюме.
    Т. Д.
    Предостережение по поводу проб: убедитесь, что кандидат будет говорить на тему, уместную для организации. Можно легко попасться на удочку, выслушав речь на тему из какой-нибудь левой области, например «Уход за детьми, страдающими аутизмом» или «Воздействие кислотных дождей». Вы сделаете ошибку, положившись на неотразимую страстность в речи говорящего, страстность, которой можете больше не услышать, взяв его на работу.

    16. Счастлив работать здесь

    Эта глава начинается с неожиданной контрольной работы:
    Вопрос 1. Какая текучесть кадров наблюдалась в вашей организации в последние несколько лет?
    Вопрос 2. Сколько в среднем стоит замена уволившегося сотрудника?
    Оцените себя следующим образом: зачёт, если вы что-либо готовы ответить на оба вопроса. В противном случае незачет. Незачет получит большинство.
    Говоря по справедливости, вполне возможно, что знание подобных вещей не входит в ваши обязанности. Ладно, оценим вашу контрольную повторно. Зачёт, если хоть кто-нибудь в вашей организации может дать правильные ответы на эти два вопроса. И опять большинство получит незачет. Мы избегаем измерения текучки по той же причине, по которой заядлые курильщики избегают долго и всерьёз беседовать со своими докторами о долголетии: много хлопот, а в результате все равно плохие новости.

    Текучка: очевидные затраты

    По нашему опыту типичные показатели текучести лежат в диапазоне от восьмидесяти до тридцати трех процентов в год, что подразумевает средний срок работы сотрудника от пятнадцати до тридцати шести месяцев[53]. Предположим пока, что текучесть в вашей организации находится в середине диапазона. В среднем человек уходит, проработав немногим более двух лет. Стоимость найма нового сотрудника — от полутора до двух месячных зарплат, которые вы отдадите агенту или потратите на внутреннюю службу кадров, выполняющую ту же функцию. Сотрудник, будучи нанятым, может сразу приступить к работе над проектом, и в этом случае стоимость его рабочих часов относится в счёт стоимости проекта — и нет никаких указаний на начальные вложения. Надо заметить, что это чистой воды бухгалтерская фантастика. Все мы знаем, что новый сотрудник бесполезен в первый день или даже хуже чем бесполезен, поскольку требуется время других людей, чтобы ввести его в курс дела.
    Через пару месяцев новый человек уже делает некоторую полезную работу, а через пять месяцев он уже работает в полную силу. Таким образом, разумная оценка начальных затрат — примерно три потерянных рабочих месяца на каждого нового сотрудника. (Очевидно, начальные затраты тем выше, чем сложнее выполняемая работа.) Общая стоимость замены каждого сотрудника — от четырех с половиной до пяти его зарплат или примерно двадцать процентов стоимости его пребывания на этом месте за два года.
    Текучесть кадров варьируется совершенно непредсказуемо от одной организации к другой. Мы знаем о компаниях с десятипроцентной текучкой и о других, занимающихся тем же бизнесом, с текучкой в сто и более процентов. Если собрать руководителей конкурирующих компаний, можно ожидать, что текучка в фирме вашего соседа отличается от вашей более чем в два раза. Конечно, ни один из вас не имеет понятия, у кого она больше, и вы никогда это не узнаете, потому что как минимум один из вас, вероятно, работает в компании, где текучесть кадров не измеряют.

    Скрытая стоимость текучки

    Стоимость текучести кадров составляет около двадцати процентов всех затрат на содержание персонала. Но это лишь видимая часть стоимости. Существуют ещё и страшные невидимые затраты, которые могут быть гораздо выше.
    В компаниях с высокой текучестью кадров люди склонны к деструктивным рассуждениям ближнего прицела, поскольку знают, что не слишком долго ещё задержатся на своих местах. Так что если вы начнёте кампанию за лучшие рабочие места для своих сотрудников, не удивляйтесь, что выше по иерархии встретится человек с таким аргументом:
    «Минуточку. Речь идёт о немалых деньгах. Если мы дадим нашим инженерам столько пространства, защиту от шума и даже уединённость, то в результате станем тратить пятьдесят долларов в месяц на человека. Умножь это на количество инженеров, и ты получишь десятки тысяч долларов. Мы не можем потратить столько денег. Я ведь тоже за производительность, как и все мы, но ты видел, какой у нас ужасный третий квартал?»
    Разумеется, неопровержимо логичный ответ на это — своевременные вложения в разумную среду помогут избежать ужасных третьих кварталов в будущем. Но лучше не напрягайтесь. Вы столкнулись с ближним прицелом, который не собьёт никакая железная логика. Этот человек скоро покинет компанию. Затраты в краткосрочной перспективе весьма ощутимы, однако долгосрочные выгоды не имеют вообще никакого значения.
    В организации с высокой текучкой никому не интересны долговременные планы. Если эта организация — банк, она даст деньги в долг Угандийской Корпорации Развития, потому что двадцать два процента годовых очень неплохо смотрятся в квартальном отчёте. Разумеется, УКР через пару лет объявит дефолт, но через пару лет нас уже и след простынет, правда? Если речь идёт о фирме-разработчике, она станет оптимизировать своё существование, эксплуатируя людей, мошенничая с рабочими местами, не делая ничего, чтобы сохранить источник собственной энергии — человеческие ресурсы, своё единственное достояние. Если бы наша сельскохозяйственная отрасль работала по тем же принципам, мы съели бы все зерно сразу, а на следующий год принялись бы умирать от голода.
    Если люди работают в компании лишь год или два, единственный способ сохранить лучших людей — быстро их повышать. Это означает, что новички будут попадать на руководящие посты начального уровня. У них общего опыта может быть не более пяти лет, а опыта работы в компании — меньше двух.
    Эти цифры приводят в замешательство. Человек с трудовым стажем, скажем, в сорок лет проведёт пять из них в качестве обычного сотрудника, а ещё тридцать пять — в качестве руководителя. Получается чрезмерно высокая и узкая иерархия. Пятнадцать процентов персонала выполняют работу, а восемьдесят пять управляют. Тогда лишь десять процентов затрат приходится на работников, а девяносто на вознаграждение руководителей. Даже Марксу не могло присниться такое утяжеление верхушки капиталистической пирамиды.
    Подобная структура не только расточительно не сбалансирована, в её основании находятся слишком легковесные люди. Это отчасти справедливо для отрасли в целом, но для компаний с высокой текучестью кадров справедливость этого тезиса просто поражает. Привычно видеть, как серьёзные, зрелые компании выпускают продукты, созданные людьми, средний возраст которых не превышает тридцати лет, а средний опыт не превышает двух лет[54].
    Многие из нас начали верить, что именно в компаниях с быстрыми повышениями происходит все интересное. Это естественно, поскольку в молодости мы склонны стремиться вперёд. Но с корпоративной точки зрения именно поздние повышения являются признаком благополучия. В компаниях с низкой текучестью повышение до руководителя начального уровня возможно лишь после десяти лет работы в компании. (К примеру, такое положение долгое время существовало в некоторых из мощнейших подразделений IBM.) Люди на низшем уровне иерархии обладают средним опытом работы в пять лет. Сама же иерархия низкая и плоская.

    Почему люди уходят

    Причины могут быть столь же разнообразными, как сами люди, размышляющие о смене работы. Вот несколько причин увольнений для организации с чрезмерно высоким уровнем текучести кадров (более пятидесяти процентов):
  • Умонастроение «как-пришли-так-и-уйдём»: по коллегам не скажешь, что они относятся к работе как к чему-то постоянному.
  • Ощущение ненужности: руководство считает своих подчинённых взаимозаменяемыми частями (поскольку текучка столь высока, незаменимых нет).
  • Чувство верности здесь абсурд: кто может быть предан организации, считающей своих сотрудников запчастями?
    Коварный эффект текучки в том, что она порождает текучку. Люди уходят быстро, поэтому нет смысла тратить деньги на их обучение. Поскольку компания ничего не вкладывает в человека, ему легко с нею распрощаться. Новых сотрудников нанимают не за их превосходные качества, поскольку заменить такие качества будет слишком сложно. Ощущение же, что компания не видит в сотруднике ничего необычайного, вызывает у этого сотрудника чувство неоцененности как индивидуума. Другие, кстати, постоянно увольняются, значит, с вами что-то не так, если вы ещё на год задержитесь здесь.

    Особая патология: переезд компании

    Нет более эгоистичного шага для неуверенного руководителя, чем перевод компании в какое-нибудь отдалённое место. «Кручу-верчу» во всей красе! Разбавление жизней сотрудников таким количеством ужаса придаёт руководителю ощущение богоподобности. Обычное руководство компанией позволяет ему контролировать жизнь сотрудников на работе, но переезд — это возможность до некоторой степени распространить своё влияние на личную жизнь людей. Разумеется, руководитель показательно приуныл, рассказывая о причинах переезда. Он говорит о повышении стоимости аренды или системе налогообложения на старом месте и о преимуществах нового. Будьте уверены, настоящие причины переезда совсем иные. Настоящей причиной переезда может быть политическая сделка, или шанс построить новое величественное здание (вот оно, материальное свидетельство его важности), или же приближение компании к пригородному дому, где проживает начальник. А иногда это просто неприкрытая демонстрация силы.
    Чем более эгоцентричен руководитель, тем больше ему нравится идея о переезде компании. Послушайте, что пишет по этому поводу Роберт Таунсенд (Robert Townsend) в книге «Up the Organization» (Вверх по карьерной лестнице):
    Если вы унаследовали (или построили) офис, требующий капитального ремонта, единственное проверенное средство — перевести его за город, оставив после себя лишь деревянный каркас. Один из моих друзей четыре раза проделывал это в различных компаниях. Результаты всегда одинаковы: 1) Хорошие сотрудники уверены в своём будущем и последуют за вами. 2) Людям, будущее которых сомнительно, а также их жёнам не придётся мириться с увольнением. «Компания съехала из города», — скажут они. Они быстро получат предложения работы, как правило, от ваших конкурентов, которые решат, что удалось вторгнуться в сферу ваших интересов. 3) Новые сотрудники в Городе Мечты лучше тех, что остались за бортом, и полны энтузиазма, потому что им пришлось столкнуться только с лучшими из ваших сотрудников.
    Up the Organization [55]
    Все это, если называть вещи своими именами, полнейшая чушь. Таунсенд, похоже, полностью упустил из виду один момент: присутствие женщин на рынке рабочей силы. Сегодня переезжающий человек — это, как правило, часть семьи, в которой оба супруга работают. Вторая часть уравнения вряд ли переезжает синхронно, поэтому такой шаг со стороны компании создаёт кризис в отношениях пары, причём по весьма щекотливому вопросу. Переезд создаёт невыносимое напряжение в тандеме, когда оба пытаются сделать полноценные карьеры. Это удар ниже пояса. Современные пары не станут мириться с этим и не смогут этого простить. Переезды компаний были возможны в пятидесятые и шестидесятые годы. Сегодня это безрассудство.
    Даже в шестидесятые годы переезды организаций не имели особого смысла. Для примера вспомним решение AT&T Bell Laboratories перевести шестьсот человек, занятых в проекте ESS1, из Нью-Джерси в Иллинойс в 1966 году. Руководство озвучило много причин для переезда, но теперь кажется вероятным, что присутствовала политическая подоплёка. В пятидесятые годы сенаторы Кеннеди и Джонсон добились гигантских инвестиций в Массачусетс и Техас, а сенатору Дирксену из Иллинойса ещё предстояло кое-что получить. Какая удача для Дирксена, если шесть сотен высокооплачиваемых, безопасных для окружающей среды рабочих мест внезапно образуются в его штате. Возможно, AT&T пошла на этот шаг под действием некоторого давления и в обмен на поддержку в каком-нибудь антимонопольном деле или послабление в законах. В Bell Labs посчитали, что стоимость будет не очень высока — в несколько тысяч долларов на человека обойдётся переезд плюс какая-то лёгкая текучка…
    Через много лет после отказа компании от ESS я договорился об интервью с Реем Кетчледжем (Ray Ketchledge), который этим проектом управлял. Я тогда писал эссе, посвящённые управлению крупными проектами, и проект ESS определённо мне подходил. Я спросил, что он считает своей главной удачей и своим главным провалом в роли босса. «Забудем об удачах, — сказал он. — Провалом был тот переезд. Вы себе не представляете, во что нам это обошлось в смысле текучки». И он поделился цифрами. Количество уволившихся накануне переезда можно было подсчитать сразу. Выраженный в процентах от общего числа подлежавших переводу, этот показатель был больше, чем потери французов в окопах первой мировой войны.
    Т. Д.
    Вы причините меньший ущерб организации, если выстроите сотрудников перед дулом пулемёта, чем если организуете переезд. И речь пока только о первоначальных потерях. В случае Bell Labs был и ещё один масштабный исход, начавшийся через год после переезда. Некоторые люди честно пытались последовать за компанией. Они переехали, а когда им не понравилось новое место, переехали снова.

    Умонастроение постоянства

    За многие годы нам несколько раз выпадала честь работать с компаниями, имевшими потрясающе низкие показатели текучести кадров. Вы не удивитесь, вероятно, но низкая текучка — далеко не единственное достоинство тех компаний. И действительно, они, похоже, преуспели во многих или в большинстве человеко-ориентированных вопросов, речь о которых идёт в этой книге. Они лучшие.
    Лучшие организации — это не категория; они заметны скорее своими различиями, чем подобием. Но есть одно общее свойство — это озабоченность тем, чтобы быть лучшими. Это постоянная тема разговоров в коридорах, на рабочих совещаниях, в курилках. Обратное тоже верно: в «нелучших» организациях эту тему обсуждают редко или вовсе не обсуждают.
    Лучшие организации сознательно стремятся быть лучшими. Это общая цель, задающая общее направление, создающая общее удовлетворение и сильный объединяющий эффект. В таких местах витает настроение постоянства, каждый чувствует, что просто глупо искать другую работу — люди будут смотреть на тебя, как на полоумного. Такого же рода общность ощущений была присуща маленьким американским городкам в прошлом. Этого часто не хватает в городах и районах, где мы живём, и тем важнее иметь подобную атмосферу на рабочем месте. Некоторые амбициозные компании целенаправленно создают ощущение сообщества. К примеру, в Reader's Digest и в некоторых отделениях Hewlett-Packard для сотрудников созданы сады. В обеденный перерыв на полях появляются огородники-любители. Проводятся конкурсы на самый сладкий горох или самые длинные цукини, а по бартеру можно обменять чеснок на кукурузу.
    Можно доказать, что такие общественные сады в краткосрочной перспективе бессмысленны. Любые затраты будут отражены в балансе этого квартала. В большинстве компаний этого достаточно, чтобы зарубить идею на корню. Но в лучших организациях бывают и другие перспективы, кроме краткосрочной. Имеет значение все, что позволяет им быть лучшими. А это долгосрочная перспектива.
    Люди склонны оставаться в таких компаниях, потому что находятся в атмосфере, располагающей остаться. Компания вкладывает огромные средства в ваш персональный рост. Здесь может быть магистратура или продолжительный период обучения для новых сотрудников (до года в некоторых местах). Трудно не понять, что вас приглашают остаться, если компания только что вложила такие средства в ваше образование.
    У компаний с низкой текучестью кадров есть ещё одна общая черта — распространённость переподготовки. Здесь можно до бесконечности натыкаться на руководителей и директоров, начинавших секретарями, конторскими служащими или же курьерами. Они пришли в компанию молодыми, кое-кто прямо из школы. Когда им требовались новые умения, чтобы что-то изменить, компания позволяла им эти умения приобрести. И ни одна должность не вела в тупик.
    Опять же можно доказать, что переподготовка — не самый дешёвый способ заполнить вакансию. Всегда дешевле — в краткосрочной перспективе — уволить человека, нуждающегося в переподготовке, и нанять другого, уже обладающего нужными умениями. В большинстве организаций так и поступают. Лучшие организации так не делают. Они осознают, что переподготовка способствует созданию умонастроения постоянства, которое снижает текучесть кадров и усиливает дух сообщества.
    Они осознают, что подобный эффект более чем покрывает затраты. В компании Southern California Edison человек, отвечающий за обработку всех данных, начинал с того, что снимал показания счётчиков. В EG&G существует программа переквалификации секретарей в системных аналитиков. В бюро трудовой статистики магистры философских наук проходят по найму и становятся разработчиками программного обеспечения, причём переподготовка начинается в первый рабочий день. В Hitachi Software одной из основных обязанностей руководителя отдела исследований является обучение новых сотрудников. В Pacific Bell линейные монтёры и операторы, прошедшие переподготовку, служат основным источником, из которого набираются системщики. Эти компании отличаются от обычных. Они воспринимаются иначе. Здесь энергию и чувство причастности к общему делу можно практически потрогать руками. И тогда начинаешь жалеть компании, у которых этого нет.

    17. Самоизлечение системы

    Сотрудник врывается в отдел кадров и увольняется. На следующее утро он беседует со своим начальником, робко пытаясь объяснить, что это была просто глупая ошибка. Нет ли возможности отменить увольнение? Сотрудники, работающие с бумагами, в замешательстве и не знают, что делать с начатой транзакцией. Человек, создавший процедуры увольнения, не задумался о возможной отмене. Но достаточно легко понять, как сделать все правильно: «Так, вот эту папку мы просто выбросим в мусорное ведро и будем считать, что её и не было, затем мы аннулируем чек на выходное пособие, потом со стола Гарри утащим документы об отмене страховки, пока он их не увидел…»
    Система только что излечила себя. В исходном проекте системы было упущено нечто, что оказалось необходимым. Люди, благодаря которым система работает, починили её на ходу. И такое происходит постоянно.

    Детерминированные и недетерминированные системы

    Автоматизация системы, прежде работавшей исключительно по человеческой инициативе, делает её полностью детерминированной. Новая система способна к действию лишь в случаях, явным образом запланированных её создателями. Так что свойство самоизлечения теряется. Любой ответ, который может потребоваться, должен быть изначально заложен в систему. Если когда-либо возникнет необходимость излечить систему, это можно будет сделать лишь вне контекста её работы. Техники разберут систему и воссоздадут её, добавив один или более запланированных ответов.
    С одной стороны, возможность избавиться от неуправляемых и запутанных возможностей самоизлечения — положительное свойство автоматизации. Система сразу проектируется «правильно», и потом уже не возникает нужды что-то подправлять в процессе работы. Однако не секрет, что это может обходиться дорого. Автоматизаторы проводят много времени, придумывая ситуации настолько маловероятные, что люди, работавшие в прежней системе, вряд ли задумались бы о них до тех пор, пока не возникла бы необходимость одну из таких ситуаций разрешить. Если бизнес-правила, регулирующие новую систему, изначально предусматривают достаточную степень адхократии, ошибкой будет автоматизировать систему. Детерминизм в этом случае не является достоинством, потому что система будет постоянно нуждаться в обслуживании.
    Источник способности недетерминированных систем самоизлечиваться безболезненно и элегантно (а иногда и бесплатно) — это люди, работающие в системе и знакомые с её основополагающими целями. Когда возникает новая ситуация, они уже знают, какие действия имеют смысл. Возможно, в будущем мы сможем обучать компьютеры целям системы, а не действиям, выполняемым для достижения целей, но пока что это недоступно. Идея в том, что преобразование системы в детерминированную приводит к потере её способности к самоизлечению.
    Организация, в которой вы трудитесь или руководите, в каком-то смысле представляет собой систему. Это сплав взаимодействующих людей и процессов, существующий с какой-то целью. В наше время очень модно обсуждать, как делать такие системы более детерминированными. Что подводит нас к предмету Методологии.

    Тайный смысл Методологии

    В наших организациях более всего раздражает, что они хороши лишь настолько, насколько хороши люди, набирающие в них сотрудников. Но ведь было бы здорово выйти за обозначенные рамки и создавать хорошие организации несмотря на то, что сотрудников набирают посредственные или некомпетентные люди. Нет ничего проще — нам нужна лишь (фанфары, пожалуйста) Методология.
    Методология — это общесистемная теория того, как следует выполнять весь класс задач, требующих напряжения мысли. Она воплощается в толстые книги, подробно описывающие, какие шаги следует предпринимать в каждом конкретном случае, независимо от того, кто выполняет работу, когда и где. Авторы Методологии умны. Люди, использующие её, могут быть глупыми. Им никогда не приходится включать свой мозг. Они просто открывают Методологию на первой странице, после чего идут по Дороге из Жёлтого Кирпича, подобно маленьким довольным Жевунам, от начала работы до её успешного завершения. Методология принимает все решения, а люди не принимают решений вовсе. Организация становится полностью детерминированной.
    Подобно всякой другой системе, по мере роста детерминированности команда из людей все более теряет свойства самоизлечения. В результате может сложиться ситуация, когда все участники работают в направлениях, не имеющих для них никакого смысла, — верный признак, что дело не идёт на лад. Несколько лет назад мы проводили посмертный анализ провалившегося проекта. По нашей просьбе каждый участник проекта наговорил около часа своих соображений на плёнку, причём каждый занимался этим у себя дома. Мы заверили всех, что лишь мы двое будем иметь доступ к записям. Один из участников подарил нам такое наблюдение:
    «К марту у нас уже был двухмесячный стаж [56] . Я не мог понять, в чем тут для нас польза, но Джордж постоянно уверял меня, что она есть. Он сказал, что мы должны верить в Методологию, и в конечном итоге все получится».
    Конечно, не получилось. Именно участники проекта лучше всех знакомы с предметом. Если полученные указания кажутся им бессмысленными, то они таковыми и являются.
    Существует большая разница между Методологией и методологией. Методология с маленькой буквы — это базовый подход, используемый для выполнения работы. Он не требует толстой книги, а обитает в головах людей, выполняющих работу. Такая методология состоит из двух частей: простого плана (подходящего для данной задачи) и набора умений, необходимых для реализации плана. Едва ли можно отвергать методологию — без неё не начать работу. Но Методология — это нечто отдельное.
    Методология с большой буквы — это попытка централизации мышления. Все осмысленные решения принимаются создателями Методологии, а не сотрудниками, которым поручено работу выполнить. Люди, выступающие в поддержку Методологии, долго перечисляют её предполагаемые преимущества, включая стандартизацию, документальное единообразие, управленческий контроль, а также современные методы. Таков явный смысл Методологии. Тайный же смысл проще и грубее: участники проекта недостаточно умны, чтобы думать.

    Безумие Методологии

    Разумеется, если ваши люди недостаточно умны, чтобы подумать и выполнить работу, работа сделана не будет. Никакая Методология здесь не спасёт. Хуже того, Методологии способны наносить непоправимый ущерб предприятиям, в которых участвуют совершенно компетентные люди. Как? Они пытаются навязать всем единый шаблон, гарантирующий:
  • болото писанины;
  • ограниченное число методов;
  • отсутствие ответственности и
  • общую потерю мотивации.
    Далее о каждом из этих эффектов рассказано подробнее.
    Писанина : Методологии сами по себе огромны и становятся все больше (они вынуждены расти, вбирая в себя «возможности», необходимые для новых ситуаций). Методология часто занимает чуть ли не полметра пространства книжной полки. Что ещё хуже, она поощряет людей создавать документы, а не работать. Одержимость документированием в таких Методологиях, похоже, происходит от параноидального мышления в стиле «В последнем проекте исписали тонну бумаги, и он все равно провалился, так что в этом проекте испишем две». Последние десять лет в тех секторах нашей экономики, которые основываются на технологии, очень любят думать, что писанина, писанина и ещё больше писанины — это решение всех проблем. Похоже, настало время представить новую концепцию, противоположную до ереси:

    Объёмная документация — часть проблемы, а не часть решения.

    Методы : Основу большинства Методологий составляют стандартизированные методы. Если бы существовала тысяча различных, но одинаково хороших способов выполнить работу, возможно, имело бы смысл выбрать один в качестве стандарта. Но при нашей технологической недоразвитости в большинстве случаев не так уж много конкурирующих способов выполнить одну и ту же работу. Если существуют реальные альтернативы, люди должны узнать о них и овладеть ими. Выбор какого-то способа в качестве стандарта означает исключение другого. Если говорить коротко, получается, что знание бесценно, и потому мы будем применять его экономно.
    Ответственность : Если что-то идёт не так в предприятии, использующем Методологию, виновата Методология, а не люди. (В конце концов, ведь именно Методология принимала все решения.) Работа в такой среде практически освобождает от ответственности. Люди хотят принимать ответственность, но не станут, если не получат определённую степень свободы в управлении собственным курсом на успех.
    Мотивация : Смысл решения о применении Методологии ясен всем. Ничто не может лишить сотрудников мотивации настолько эффективно, насколько это сделает осознание ими того факта, что руководство считает их некомпетентными.

    Умышленное повиновение

    Создателям Методологий не даёт покоя мысль, что думающие люди попросту не будут обращать на Методологии внимания. Именно это происходит во многих организациях. А ещё более прискорбен противоположный вариант: люди не станут игнорировать Методологию, а будут вместо этого делать буквально то, что она приказывает, даже если знают, что это приведёт к потере времени, созданию неработающего продукта и бессмысленной документации. Именно это наш единомышленник Кен Орр (Ken Orr) называет «умышленным повиновением»[57]. Когда Методология призывает создать руководство оператора в восемнадцати частях, разработчики могут и написать его, даже если продукт столь глубоко запрятан в недра двигателя или спутника, что никакой оператор до него не доберётся. Если Методология обязывает вас заполнить форму базы данных по каждому элементу данных, разработчики могут выполнить это требование буквально, даже если в системе нет базы данных.
    В Австралии, где забастовки отнимают примерно половину рабочего времени, существует очаровательная форма протеста — «работа по правилам». Вместо того чтобы уходить с работы, сотрудники открывают толстую книгу рабочих процедур и заявляют: «Будем работать по букве инструкций, пока вы не выполните наши требования». К примеру, когда авиадиспетчеры начинают работать по правилам, они могут посадить лишь один самолёт в семь минут. У врача при таком подходе к работе вырезание аппендицита занимает неделю. Введение Методологии открывает возможность «работы по правилам» во многих других областях экономики. Люди могут строго следовать букве Методологии, и работа в этом случае практически остановится.

    Как не выплеснуть ребёнка с водой

    Преимущества, приписываемые Методологиям, в действительности являются преимуществами конвергенции методов. Реальные преимущества могут наблюдаться, если люди делают похожую работу и применяют похожие методы. Технический персонал в этом случае получает возможность быстрее осваивать новые продукты, разработчики — быстрее начинать новые проекты; кроме того, появляется возможность единообразно определять численные показатели для различных проектов, а конкретные виды ошибок обнаруживать быстрее. Конвергенция методов — вещь хорошая. Но её можно достигнуть и без помощи Методологий.
    Методологии пытаются навязать конвергенцию посредством устава. Здесь неминуем ответный удар, частично как следствие тяжести руки полицейского, а частично — склонности работника к независимости и ковбойским умонастроениям, столь распространённым среди первопроходцев новых неизведанных территорий. Вот лучшие способы достигнуть конвергенции методов:
    Обучение : Люди делают то, что умеют делать. Если дать им базовый набор методов, они станут применять эти методы.
    Инструменты : Набор автоматизирующих вспомогательных средств для моделирования, проектирования, реализации и тестирования даст большую конвергенцию методов, чем любой устав.
    Рецензирование : В организациях, где принято рецензирование результатов коллегами (группы качества, совместные обсуждения, критические рассмотрения, презентации технологий), существует естественная склонность к конвергенции.
    Лишь после такого рода осторожных шагов навстречу конвергенции можно подумать о публикации стандарта. На самом деле нельзя провозглашать что-либо стандартом, пока это ещё не стало стандартом де-факто. Это основа теории стандартизации, скажем, в DuPont. В этой компании руководство по стандартам определяет стандарт как «испытанный метод решения задач определённого рода». Далее руководство уточняет, что «испытанный» следует читать как «успешно и широко применявшийся в компании DuPont». Вот, по нашему мнению, здравый смысл, хотя он противоречит отраслевой мании искать новые подходы и скоропалительно провозглашать их стандартами, прежде чем кто-либо в организации успеет эти подходы опробовать.

    И снова иллюзия высоких технологий

    Одержимость Методологиями на рабочих местах — ещё одно проявление иллюзии высоких технологий. Оно происходит от веры в то, что лишь технология имеет значение. Даже лучшая из всех возможных Методологий, описывающая действительно подходящие методы для всех возможных задач, не даст серьёзного улучшения в плане технологии. В конце концов, даже без руководства люди не смогут принимать только неверные решения. Каким бы ни было технологическое преимущество, его можно достичь лишь ценой существенного ухудшения социологической обстановки в команде.
    Противоположный подход: каждое новое предприятие сначала выполняется как пилотный проект. И если существует определённый способ выполнения работы, негласный стандарт, именно этот способ нельзя будет использовать. И по меньшей мере одну часть проекта следует выполнить нестандартным способом. (Таково, похоже, негласное правило в некоторых отделениях Fujitsu.)
    Весной 1932 года эксперты по производительности провели ряд испытаний в Hawthorne Western Electric Company, чтобы определить влияние различных параметров среды на производительность. Они пробовали увеличивать освещённость и заметили, что производительность увеличилась. Затем они попробовали снизить освещённость и заметили, что производительность увеличилась ещё больше. Они предположили, что если отключить свет совсем, производительность выбьет потолок. Было похоже, что влияние оказывает не изменение, но сам его факт. Людям было приятно, что на них обращали внимание, их интриговала новизна. Явление получило название эффекта Готорна (Hawthorne Effect)[58] . Грубо говоря, люди работают лучше, когда пробуют что-то новое.
    Внимательное изучение литературы по улучшению производительности может убедить вас, что всякое улучшение происходит вследствие эффекта Готорна. В рекламе замечательных достоинств средства для улучшения производительности X неизменно присутствуют цифры, полученные при первом применении этого X. Редко когда можно встретить исследование, анализирующее «улучшения» десятилетней давности на предмет их теперешнего статуса. Вероятно, статуса уже никакого нет. Лишь с малой толикой цинизма мы подписываемся под воззрением, что именно эффект Готорна является причиной улучшения производительности в большинстве случаев.
    Чтобы эффект Готорна помог и вам, следует применять только нестандартные подходы. Существующие стандарты должны быть краткими и мягкими. Общий объём стандартов для ваших людей не должен превышать 10 страниц. (Это не причуды; во многих организациях, распрощавшихся с подходом «Методология — это Закон», в конечном итоге стандарты ограничиваются 10 страницами.) Будьте готовы делать исключения даже для правил на этих 10 страницах. И тогда ваша среда разработки станет сообразна взглядам знаменитого мудреца бизнеса Мао Цзе-Дуна:
    Пусть расцветают сто цветов,
    И пусть состязаются сто школ мысли.
    Мао, конечно, лукавил, а вот мы говорим всерьёз.

    IV. СОЗДАНИЕ ПРОДУКТИВНЫХ КОМАНД

    Вспомните о каком-нибудь особенно приятном переживании, связанном с работой. Что делало его настолько приятным? Упрощённый ответ — вызов. С хорошим опытом работы всегда связана определённая доля сложностей.
    А теперь остановитесь на одном приятном воспоминании того периода. Прокрутите его мысленно, как видеоплёнку. Возможно, это было собрание, или разговор в курилке, или ночное бдение, или последовавший за ним завтрак. Если вы похожи на многих из нас, такие воспоминания красочны и удивительно подробны. Вы сможете вспомнить звуки и отдельные голоса, увидеть выражения лиц, вспомнить обстановку. А теперь сделайте стоп-кадр и изучите внимательно изображение. Где здесь вызов? Мы готовы поспорить, что он в ваших воспоминаниях не фигурирует вовсе, а если и фигурирует, то лишь на самом далёком плане.
    На переднем же плане среди всех наших ценных воспоминаний о работе — командное взаимодействие. Когда группа людей сплавляется в значимое целое, полностью изменяется характер работы. Вызов в работе важен, но не сам по себе. Он важен потому, что позволяет нам сфокусироваться на чем-то всем вместе. Вызов — это инструмент, объединяющий нас. В тех рабочих группах, где люди получают наибольшее удовлетворение от работы и действуют на пределе своих возможностей, командное взаимодействие — это все. Именно благодаря взаимодействиям люди терпят все, выкладываются на полную катушку, преодолевают чудовищные трудности.
    Люди лучше работают и получают большее удовлетворение, когда команда объединяется. Часть IV посвящена понятию кристаллизованной команды и действиям, помогающим формированию таких команд.

    18. Целое больше суммы его частей

    В деловой среде мы весьма вольно обращаемся со словом команда, называя так любую группу людей, которым поручено совместно выполнить ту или иную задачу. Но многие подобные группы совсем не похожи на команды. У них нет общего определения успеха или проявленного командного духа. Чего-то не хватает. Не хватает того, что мы назвали явлением кристаллизации.

    Понятие кристаллизации команды

    Команда, прошедшая кристаллизацию, — это группа людей, столь сильно связанных, что целое становится больше суммы составляющих его частей. Производительность этой команды выше, чем производительность тех же людей, не перешедших порог кристаллизации. И, что столь же важно, удовольствие от работы также выше, чем можно было бы ожидать, учитывая природу работы. В некоторых случаях кристаллизованная команда может замечательно себя чувствовать, работая над задачей, которую другие посчитали бы откровенно скучной.
    Как только начинается кристаллизация команды, вероятность успеха очень резко возрастает. Команда может стать неумолимой силой, стремящейся к успеху. Управлять этой стихией — одно удовольствие. Вы проводите большую часть рабочего дня, убирая препятствия с их пути, расчищая тропинку, чтобы зевак случайно не затоптали: «Так, народ, минуточку внимания. Сделайте шаг назад и придержите свои шляпы». Управление в традиционном смысле этого слова им не нужно и уж точно не нужны дополнительные стимулы. Они уже обладают собственным импульсом.
    Причины такого явления не столь сложны: команды по природе своей склонны формироваться при наличии целей. (Скажем, спортивная команда. Может ли она вообще существовать без цели?) До кристаллизации команды её участники, возможно, имели различные цели. Однако в процессе кристаллизации каждый поверил в общую цель. Эта корпоративная цель обретает особую важность по причине её значимости для группы. И хотя сама по себе цель может казаться участникам команды выбранной наудачу, они стремятся к её достижению с невероятным напором.

    Управление посредством истерического оптимизма

    Некоторых руководителей беспокоит настрой предыдущего абзаца. Они считают неприятным предположение, что какой-то ловкостью нужно заставлять сотрудников принимать корпоративные цели. Зачем создавать ещё какие-то специальные отделы? В конце концов, предполагается, что профессиональные разработчики принимают цели своего нанимателя как одно из условий работы. Это и значит быть профессионалом.
    Вера в то, что сотрудники автоматически принимают цели организации, — признак наивного оптимизма руководителя. Механизмы вовлечения отдельных личностей в планы организации гораздо более сложны. Скажем, вряд ли вас удивит, что человек, известный вам своими познаниями в базах данных, более склонен считать себя отцом, предводителем бойскаутов, а также членом местного школьного комитета. На этих ролях он постоянно делает вдумчивые субъективные оценки. Но было бы удивительно, перестань он выполнять такие оценки, приходя на работу. Он не перестаёт этого делать. Находясь на рабочем месте, он пользуется любым поводом для проявления личной энергии и преданности. Цели организации постоянно критически рассматриваются сотрудниками этой организации, и большинство этих целей оценивается как ужасный бред.
    Дилемма здесь в том, что в качестве руководителя вы, вероятно, приняли корпоративную цель (завершить проект к следующему апрелю и уложиться в бюджетные $750 000), причём приняли чистосердечно. Если ваши люди не проявляют такого же энтузиазма, появляется разочарование. Их недостаточный интерес может показаться вам почти предательством. Но постойте-ка, возможно ли, что ваше собственное принятие этой корпоративной цели имеет иные корни, нежели простой профессиональный интерес? Разве нельзя сказать, что искусные действия вашего шефа и вышестоящих сил сделали так, что корпоративная цель находится на одной прямой с вашей собственной? Достижение корпоративных целей определённо добавит вам веса и ответственности: «Сегодня проект Сисбумба, а завтра весь мир!» В верхних эшелонах организации удивительные в своей изобретательности умы заботятся о том, чтобы у каждого руководителя были сильные личные стимулы принять корпоративные цели. Лишь в самом низу, где выполняется реальная работа, этой изобретательности не хватает. Здесь приходится полагаться лишь на «профессионализм», который позволит всем работать в нужном направлении. Что ж, флаг в руки.
    Если вы работаете в обществе защиты дартеров-моллюскоедов[59], или в Церкви Непорочного Зачатия, или же в любой иной организации, все сотрудники которой связаны общими убеждениями, то можете рассчитывать на их природное тяготение к целям организации. В противном случае — даже не надейтесь. Исполнительный комитет может бегать и суетиться в ожидании повышения прибылей, но та же цель для людей, находящихся внизу пирамиды, яйца выеденного не стоит. ПРИБЫЛЬ MEGALITHIC INC. УВЕЛИЧИЛАСЬ НА МИЛЛИАРД ДОЛЛАРОВ. Как скучно. РЕКОРДНЫЙ ДЛЯ КОМПАНИИ КВАРТАЛ. Раздаётся посапывание.
    Однажды мне пришлось руководить телекоммуникационным проектом в крупной кредитной компании. Эта организация давала деньги в долг бедным людям под невероятно высокие проценты, короче говоря, занималась деятельностью, объявленной вне закона в двадцати трех штатах. Увеличение и без того чудовищных прибылей компании не сильно трогало среднего работника, но руководство считало, что все обстоит иначе. Однажды в пятницу, ближе к вечеру, меня посетила делегация. В наших руках шансы на лучший второй квартал в истории компании, заявили они. И попросили поделиться этим фактом с другими участниками команды, чтобы «сфокусировать их усилия». Мне никогда ещё в жизни не приходилось работать с такой сфокусированной командой, но на следующее утро (они так загорелись, что даже в субботу утром на рабочих местах оказались все до единого) я покорно передал эти слова сотрудникам. Энергия вдруг исчезла из команды, словно ветер из парусов. Главный программист озвучил общее мнение: «Да нам плевать на их второй квартал». Полчаса спустя они все уже разошлись по домам.
    Т. Д.
    Создание системы было целью произвольной, но команда приняла эту цель. Эта цель объединила людей. С момента кристаллизации подлинным центром притяжения их энергии стала сама команда. Они участвовали в процессе ради общего успеха, ради удовольствия от достигнутой цели. Перефокусировка их внимания на интересы компании в этом проекте ничего не дала. Она лишь сделала успех незначительным и бессмысленным в их глазах.

    Пушки острова Наварон

    Цели корпораций всегда будут казаться людям выбранными случайно (как и сами корпорации), но случайность цели не означает, что её никто никогда не воспримет. Будь это верно, у нас не было бы спорта. Цели в спорте всегда абсолютно произвольны. Вселенной нет дела до того, что белый шарик перемещается между воротами команды Аргентины на одной стороне поля и воротами команды Италии на другой. Но многие люди увлекаются процессом и болеют за результаты. Их вовлеченность — функция ячеек общества, к которым они принадлежат.
    Вне команды люди могут проявлять умеренный интерес к её поражению или победе, но их интерес ничтожен в сравнении с интересом членов команды. Люди в кристаллизованных командах часто настолько вовлечены в процесс, что готовы штурмовать при необходимости остров Наварон, лишь бы только третья версия системы управления пенсионными фондами прошла приёмку. Вам приходится напоминать им, что они участвуют вовсе не в психологическом эквиваленте военных действий.
    Несмотря на полезную энергию и энтузиазм, наблюдаемые в командах после кристаллизации, руководители не особо заботятся о создании подобных команд. Отчасти причина в недостаточном понимании важности команды. Руководитель, всерьёз ориентированный на достижение цели, вероятно, обратит внимание, что цель достигается не командами, а их участниками. Практически все компоненты задачи, необходимые для получения результатов, выполняются отдельными людьми, входящими в состав команды. Причём большую часть работы выполняют люди, работающие в одиночестве.
    Действительно командная работа не так уж часто оказывается востребованной в нашей отрасли. Но команды все равно имеют большое значение, поскольку служат средством направления усилий отдельных людей.

    Назначение команды не в достижении цели, но в выстраивании целей на линии огня.

    Когда команда выполняет своё предназначение, её участники работают более эффективно, поскольку чётко видят направление.

    Признаки кристаллизации команды

    Есть несколько характерных признаков того, что произошла кристаллизация команды. Самый важный — низкая текучесть кадров в проектах и в ходе выполнения чётко сформулированных заданий. Участники команды никуда не собираются идти, пока не сделают работу. Вещи, имевшие огромное значение до кристаллизации (деньги, положение, перспективы повышений), после кристаллизации становятся не столь важными или же совсем неважными. Вряд ли кто-то уйдёт из такой команды из-за банальной возможности небольшой прибавки к зарплате. Как ни прискорбно, руководители часто не замечают столь серьёзного признака собственного успеха. Они не склонны обращать внимание на текучку, даже если она их губит; а когда текучка низкая, они не задумываются о ней вовсе.
    Кристаллизацию команды обычно сопровождает сильное чувство индивидуальности . Команды, деятельность которых широко обсуждается по всей отрасли, выбрали себе яркие названия: «Okaie Coders» (Оклахом-ские Кодеры) в General Electric или «Gang of Four» (Банда Четырех) в Du-Pont или же «Chaos Group» (Группа Хаоса) в Gas & Electric из Цинциннати. У товарищей по команде появляются общие шутки, они произносят фразы, значение которых понятно только им. Они могут создавать командное пространство. Команда может собираться на обед или отдыхать после работы в одном и том же месте.
    Участники хорошей команды испытывают ощущение элитарности. Они чувствуют, что составляют нечто уникальное, что они выше всякой заурядности. Они проявляют смелость, достойную спецназа, что может отчасти раздражать людей, не входящих в группу.
    Неизбежно появляется и чувство общего владения продуктом, созданным командой, прошедшей кристаллизацию. Участникам приятно, что все их имена написаны на продукте или какой-то его части. Каждый готов к критике со стороны коллег. Командное пространство украшено видами продукта в различных стадиях готовности.
    И последний признак кристаллизации — очевидное удовольствие от работы. В таких командах царит атмосфера процветания. Общение протекает легко, уверенно и тепло.

    Команды и клики

    Если вы неоднозначно отнеслись к тому, что прошедшие кристаллизацию команды самодостаточны и чувствуют своё лёгкое превосходство над остальным миром, вы не одиноки. Мы почти читаем ваши мысли: «Минуточку. То, что авторы называют „командой“, мы, пожалуй, назвали бы „кликой“. Командный дух — это, быть может, неплохо, но разве не следует любой ценой избегать образования группировок?»
    Разница между командой и кликой такая же, как между бризом и сквозняком. Бриз и сквозняк имеют одинаковое значение — «прохладный воздушный поток». Если вы находите прохладный поток приятным, то называете его бризом, а если раздражающим, то сквозняком. Коннотации различны, хотя денотаты одинаковы. Так же нет разницы в денотатах команды и клики, однако коннотации полностью противоположны. Слово команда люди употребляют, когда тесные химические связи кристаллизовавшейся рабочей группы им приятны, а слово клика, — когда такие связи создают опасность.
    Страх перед кликами — признак неуверенности руководства. Чем больше неуверенность, тем более устрашающей может показаться идея клики. Тому есть причины: часто руководитель не является действительным участником команды (об этом мы ещё поговорим в главе 23), так что его связь с командой слабее, чем связь с компанией в целом. Внутри группы связи сильнее, чем связь группы с компанией. Кроме того, руководителей посещает ужасная мысль, что тесно связанная команда может уйти сразу вся, отдать свою энергию и энтузиазм конкуренту. По этим причинам неуверенный руководитель боится клик. Он или она чувствует себя гораздо лучше, работая с единообразными пластиковыми людьми, идентичными, взаимозаменяемыми, не имеющими внутрикомандных химических связей.
    Кристаллизованная рабочая группа может быть дерзкой, самодостаточной, замкнутой, может вызывать раздражение, но она делает больше для достижения целей, поставленных руководством, чем любая комбинация взаимозаменяемых частей.

    19. Чёрная Команда

    Польза от кристаллизации команд очевидна, если у вас имеется приятный опыт работы в такой команде. Но если такого опыта у вас нет, эта глава позволит до некоторой степени ощутить, каково это. Далее рассказывается о команде, известность которой начала формироваться в первой половине 60-х годов. Некоторые легенды, связанные этой командой, наверняка приукрашивают действительность, но придают правдивой в остальном истории особое очарование.

    Материал для легенд

    На заре времён (скажем так) в штате Нью-Йорк существовала компания, производившая большие синие компьютеры. Компания также выпускала программное обеспечение для этих компьютеров. Клиенты компании были весьма достойными людьми, но, говоря между нами, имели обыкновение препротивно придираться к программам с ошибками. Какое-то время компания прилагала усилия к обучению клиентов, чтобы сделать их более терпимыми к ошибкам. Но из этого ничего не получилось, поэтому пришлось проглотить пилюлю и начать избавляться от ошибок.
    Простой и очевидный подход — заставить программистов удалять все ошибки перед сдачей программы. Этот подход по какой-то причине тоже работал не очень хорошо. Похоже, программисты (по крайней мере, в те времена) были в целом слишком хорошего мнения о своих программах. Как они ни старались, найти все ошибки до последней не могли, поэтому часто объявляли о готовности программ, полных изъянов.
    Тяжело было обнаружить последнюю ошибку, но некоторые тестеры справлялись лучше своих коллег. Компания сформировала группу из этих особо одарённых тестеров и предоставила ей право окончательного тестирования критических приложений перед отправкой их клиентам. Так родилась легендарная Чёрная Команда.
    Изначально в Чёрную Команду входили люди, проявившие себя в тестировании и превосходившие в этом качестве своих коллег. У них было больше мотивации. Они тестировали также и чужой код, поэтому были свободны от когнитивного диссонанса, сковывающего разработчика при тестировании собственных программ. В конечном итоге руководители, сформировавшие команду, ожидали хотя бы скромных улучшений качества продуктов, но не более того. А вот получили они гораздо больше.
    Удивительное заключалось не в том, насколько хороша была Чёрная Команда на заре своего существования, а в том, насколько она улучшилась за последующий год. Происходило что-то волшебное: в команде началось формирование индивидуальности. Эта индивидуальность находилась под влиянием оппозиционной философии тестирования, созданной участниками группы. Философия гласила, что они должны желать и ожидать недостатков в программах.
    Они вовсе даже не болели за разработчиков, но напротив находили наслаждение в том, чтобы подвергнуть программу (и программиста) испытаниям, которые были бы не просто тестом. Когда программист приносил программу на тестирование в Чёрную Команду, он чувствовал себя, как на аудиенции у Мина Беспощадного[60].

    Жалкие земляне, кто вам теперь поможет?

    Поначалу просто ходили шутки, что тесты Чёрной Команды подлые и скверные и что участникам группы очень нравится, когда код работает неправильно. Затем шутки закончились. Члены команды начали культивировать образ разрушителей. Они разрушали не только ваш код, но и весь ваш день. Они делали нечеловечески несправедливые вещи, чтобы добиться сбоя: перегружали буферы, сравнивали пустые файлы, набирали возмутительные последовательности на клавиатуре. Взрослые мужчины и женщины начинали плакать, когда видели ужасное поведение своих программ в руках сумасшедших врагов. Чем хуже вам приходилось, тем большее удовольствие получала группа тестирования.
    Чтобы усилить неприятный образ, участники команды начали носить чёрное (отсюда и название «Чёрная Команда»). Они взяли в привычку страшно фыркать, когда программа давала сбой. Некоторые отращивали длинные усы, которые крутили, подражая Саймону Легри[61].
    Они собирались, чтобы придумывать ещё более ужасные тестовые уловки. Программисты начали перешёптываться о душевнобольных из Чёрной Команды.
    Что и говорить, компания была в восхищении. Каждый дефект, найденный командой, клиентам уже не суждено было увидеть. Команда стала настоящей удачей. Удачей в качестве подразделения тестирования, но, что более важно для нашего изложения, в качестве социальной ячейки. Люди в команде получали такое удовольствие от своей работы, что коллеги вне команды, несомненно, завидовали им. Чёрная одежда и по-детски глупое поведение были частью этого удовольствия, но происходило здесь и кое-что ещё. Химические процессы внутри группы стали самодостаточными.

    Сноска

    С течением времени участники команды время от времени покидали её, чтобы заняться другими вещами. Поскольку функция команды была весьма важна для компании, уходивших людей заменяли немедленно. И так продолжалось, пока в какой-то момент не осталось ни одного из участников первого состава. Но Чёрная Команда продолжала жить. Она пережила потерю всех основателей, но полностью сохранила свою энергию и индивидуальность.

    20. Травля команд

    Здесь стоило бы поместить небольшую главу под названием «Как способствовать кристаллизации команд». Такая глава включала бы пять-шесть простых рецептов, помогающих формировать команды. Этих рецептов было бы вполне достаточно, чтобы гарантировать кристаллизацию. Планируя эту книгу, мы рассчитывали написать именно такую главу. Мы были уверены в себе. Неужели так сложно добраться до сути вопроса и дать читателю практические средства, способствующие кристаллизации? Мы задействуем все свои способности, весь наш опыт, мы одолеем проблему логикой и чистым вдохновением. Вот так это выглядело на стадии планирования…
    Между планом и реализацией нам пришлось несколько раз столкнуться с тревожной реальностью. Началось все с того, что мы просто не смогли придумать шесть рецептов для этой главы, застряв на цифре ноль. Мы были готовы немного умерить свои амбиции, но не настолько же. («Ноль способов способствовать кристаллизации команд?») Стало ясно, что в чем-то неправильна сама идея главы. Неверной оказалась мысль о том, что команды можно заставить кристаллизоваться. Это невозможно. Можно надеяться, что они кристаллизуются, можно стучать по дереву в надежде не сглазить, можно как-то стимулировать повышение вероятности кристаллизации, но невозможно найти универсальный катализатор. Процесс слишком хрупок, чтобы им управлять.
    В ходе снижения запросов нам пришлось изменить словарь. Мы перестали говорить о построении команд и заговорили об их выращивании. Сельскохозяйственный образ показался подходящим. Сельское хозяйство нельзя до конца контролировать. Вы обогащаете почву, высаживаете семена, поливаете в соответствии с новейшими теориями, а потом ждёте, затаив дыхание. Можно получить урожай, а можно и не получить. Если он взойдёт, вы сразу почувствуете себя замечательно, но на следующий год все равно придётся попотеть. Примерно так же создаются команды.
    Вернёмся в режим мозгового штурма и начнём искать «Шесть факторов, обеспечивающих возможность создания команды». Все равно было тяжело. В итоге, впав в отчаяние, мы прибегли к приёму обращения (inversion), который описан в книге Эдварда де Боно (Edward deBono) «Lateral Thinking»[62]. Если решить проблему не удаётся, деБоно предлагает прекратить поиски путей достижения поставленной цели и начать искать способы достижения диаметрально противоположной цели. В этом случае не исключено, что сознание очистится от тумана, препятствующего творческому процессу. Поэтому вместо того чтобы искать способы, способствующие формированию команд, мы принялись придумывать, как можно воспрепятствовать их формированию, сделать его невозможным. Оказалось, легко. За короткое время мы придумали множество убойных способов воспрепятствовать формированию команды и нарушить социологию проекта. Стратегию, объединяющую эти меры, мы окрестили травлей команд (teamicide). Вот наш краткий перечень методов травли:
  • оборонительная позиция руководства;
  • бюрократия;
  • физическое разделение;
  • дробление рабочего времени;
  • снижение качества продукта;
  • идиотские сроки сдачи;
  • насаждение клик.
    Некоторые из методов покажутся вам до боли знакомыми. Это они постоянно применяются в компаниях.

    Оборонительная позиция руководства

    Для вас как руководителя идея занятия оборонительных позиций в большинстве областей, связанных с риском, наверняка привлекательна. Если вам приходится работать с механизмом, подверженным сбоям, вы обзаводитесь резервным механизмом. Если клиент проявляет нерешительность, вы прилагаете усилия, чтобы жёстко зафиксировать требования к продукту. Если подрядчик «забывает» о своих обещаниях, вы публикуете протоколы после каждого совещания.
    Но есть одна область, в которой оборонительная позиция неизбежно ведёт к неприятным последствиям. Нельзя защититься от некомпетентности собственных людей. Если ваши сотрудники не подходят для выполнения работы, провал обеспечен. Разумеется, если люди плохо подходят, следует найти новых людей. Но, приняв решение действовать с набранной группой, вы совершите ошибку, если не будете доверять этим людям. Любая защитная мера, направленная на достижение успеха в обход команды, лишь усугубит положение. Вы можете достичь временного облегчения, но в долгосрочной перспективе лишите команду всяких шансов на кристаллизацию.
    Однажды я произносил Речь Консультанта Номер 9Б перед коллективом проекта, критикуя их за то, что они не смогли получить от клиента одобрения только что разработанной концепции новой системы. Люди выглядели слегка смущёнными. Наконец одна сотрудница сказала: «Мы согласны, что клиенту стоит увидеть концепцию, но шеф строго-настрого запретил показывать посторонним что-либо без его разрешения». Она объяснила, что шеф настолько занят, что у него накопилось нерассмотренных вопросов уже за несколько месяцев. У них попросту не было выбора. Они корпели над работой, словно во тьме, понимая, что большая часть результатов будет отвергнута клиентами, когда те, наконец, эти результаты увидят.
    Т. Д.
    Этот начальник не доверял собственным людям. Его беспокоило, что они могут показать представителям клиента что-то не то. Его беспокоило, что их ошибки могут плохо отразиться на нем. Лишь его собственное суждение достаточно компетентно, всех остальных следует подозревать.
    Если вы руководитель, то, конечно же, будете считать, что ваше мнение правильнее, чем мнение подчинённых. У вас больше опыта да и стандарты качества, наверное, повыше; именно так вы и стали руководителем. В любой точке проекта сотрудники, не знакомые с вашим мнением, более склонны к ошибкам. Ну и что? Позвольте им совершать ошибки. Это не означает, что вы не сможете отдавать предпочтение собственному решению (лишь время от времени) или придавать проекту определённую направленность. А вот если люди поверят, что им не разрешено совершать ошибки, они чётко осознают, что вы им не доверяете. Нет лучшего способа воспрепятствовать формированию команды.
    Большинство руководителей ставят себе «отлично» за знание того, когда людям можно доверять, а когда нет. По нашему опыту в части недоверия очень многие руководители ошибаются. Они следуют исходной посылке, что люди могут работать совершенно автономно, если работают правильно. В результате никакой автономии нет. Единственная свобода, имеющая какой-либо смысл, — это свобода поступать не так, как поступил бы руководитель. Это верно и в более широком смысле: право поступать верно (в глазах руководителя или в глазах правительства) значения не имеет; свободу даёт лишь право ошибаться.
    Самые очевидные уловки руководителя, занимающего оборонительную позицию, — это навязанные Методологии («Мои сотрудники слишком тупы, чтобы создавать системы без Методологий») и вмешательство в технические вопросы. И та и другая обречены на неудачу в долгосрочной перспективе. Кроме того, подобные уловки способствуют эффективной травле команды. Испытывая недоверие со стороны начальства, люди не слишком склонны объединяться в команду.

    Бюрократия

    В исследованиях, проведённых в 70-е и 80-е годы, Кейперс Джоунс (Capers Jones) показал стоимость разработки систем, разбив виды работы на категории. Одной из таких категорий стала бумажная работа (в главе 17 названная писаниной). То, что Джоунс называет бумажной работой, — по большей части бездумное перекладывание бумажек, поскольку время, необходимое для заполнения этих бумажек информацией, должно быть посвящено другой работе — анализу, проектированию или же планированию тестов. Иными словами, эта категория Джоунса идентична обычной бюрократии. Джоунс сделал вывод, что бумажная работа находится на втором месте по затрате времени в процессе разработки систем. Она отнимает более тридцати процентов стоимости создания продукта[63].
    Существует печальная современная тенденция превращать разработчиков в бюрократов. Возможно, это признак эпидемии оборонительного менеджмента. Но хотя тенденция проявляется в глобальных масштабах, она проявляется везде по-разному. Мы знакомы как с компаниями, где группы разработки являются воплощением бюрократических кошмаров в духе Кафки, так и с компаниями, где тяготы бумажной работы минимальны.
    Бессмысленное перекладывание бумаг — трата времени. С этим занятием следует воевать, потому что оно отрывает людей от работы. Впрочем, мы сейчас говорим о другом. Формированию команды мешает именно бюрократия. Команда должна поверить в цель, вокруг которой происходит формирование. Эта цель может быть любой, но она должна существовать. Должно существовать свидетельство веры руководства в эту цель. Недостаточно просто сказать людям, что цель очень важна, если к этому приходится добавить, что треть времени следует тратить на перекладывание бумажек. Люди, перекладывающие бумажки, не могут заработать в режиме команды спецназа. Они не способны упорно стремиться к успеху.

    Физическое разделение

    Когда мебельная полиция ратует за модульный офис, речь идёт в основном о «гибкости». Но когда доходит до необходимости что-нибудь действительно изогнуть, чтобы объединить рабочую группу, лица сразу вытягиваются. «Мы не можем нарушить гармонию и передвигать все подряд на нашем замечательном ковре только ради того, чтобы посадить этих четверых рядом. Они что, телефоном пользоваться не умеют?» В результате возможные составляющие тесно связанной команды разбрасываются по многим этажам или даже зданиям. Взаимодействие, которого требует работа, пострадает, скорее всего, не очень серьёзно, но внепланового взаимодействия не будет вовсе. Участники группы могут сильнее привязаться к не входящим в группу соседям просто потому, что чаще их видят. Итак, нет группового пространства, нет постоянной поддержки и во-одушевлённости, нет шансов на формирование групповой культуры. (Невозможно представить, чтобы участники Чёрной Команды, одетые в чёрное, сидели каждый в своём отсеке. Им постоянно приходилось бы общаться с людьми, не понимающими этой шутки. Эти люди просто считали бы их странными, и всему веселью моментально пришёл бы конец.)
    Физическое разделение людей, нуждающихся в близком взаимодействии, не имеет смысла в любом случае. Соседи становятся источником шума и раздражения. Когда все соседи входят в одну команду, то, как правило, одновременно работают в тишине, поэтому поток нарушается реже. Общность пространства также даёт возможность нерабочего общения, которое так необходимо для формирования команды.

    Дробление рабочего времени

    Один из моих клиентов — австралийская правительственная организация. Однажды в телефонном разговоре я получил данные, указывающие на то, что средний сотрудник организации занят как минимум в четырех различных проектах. Я пожаловался на это представителю организации. Печально, сказал он, но такова жизнь. Обязанности людей фрагментированы потому, что их способности и знания делают их незаменимыми во многих предприятиях. Неизбежно, сказал он. Глупости, сказал я. И предложил ему ввести в действие правило, ограничивающее участие каждого человека одним и только одним проектом единовременно. Это правило следует зафиксировать на бумаге и распространить по организации. Через год, когда я вернулся, каждый сотрудник участвовал в среднем не более чем в паре проектов.
    Т. Д.
    Дробление не только препятствует формированию команды, но и отрицательно воздействует на эффективность. (Возможно, вы уже начали постигать суть вопроса.) Люди в состоянии отслеживать лишь ограниченное число взаимодействий с другими людьми. Когда они пытаются участвовать в четырех рабочих группах, количество взаимодействий возрастает в четыре раза. Они проводят все своё время, переключая передачи.
    Ни один человек не может входить в несколько кристаллизованных команд. Тесные взаимодействия внутри такой команды исключают любые другие. Чуть больше дробления, и команда просто не кристаллизуется. Хуже всего то, что мы допускаем гораздо более сильное дробление, чем в действительности необходимо. Мы уступаем в этом сражении, даже не вступая в бой. Даже если просто заявить, что целью является такое распределение, при котором каждому достаётся лишь одна рабочая задача, это может привести к существенному снижению дробления, что даст командам реальные возможности для формирования.

    Снижение качества продукта

    Заголовок этот несерьёзен, потому что никто обычно не говорит о снижении качества. Говорят обычно о снижении стоимости. Однако результаты на практике одни и те же. Типичные шаги, направленные на ускорение сдачи продукта, обычно приводят к снижению качества. Часто конечные пользователи продукта дают своё благословение на этот компромисс (менее качественно, но зато раньше и дешевле). Но такие уступки могут быть весьма болезненными для разработчиков. Их самооценку и удовольствие от работы подрывает необходимость создавать продукт, качество которого слишком низкое для их способностей.
    Ранней жертвой снижения качества становится то чувство отождествления с командой, которого группе уже удалось достичь. Коллеги, создающие низкопробный продукт, не хотят даже в глаза друг другу смотреть. Им не светит общее чувство достигнутого. Они знают, что по окончании этой работы наступит лишь общее чувство облегчения. В конце проекта каждый приложит все усилия, чтобы отделиться от других участников группы и найти себе лучшее занятие.

    Идиотские сроки сдачи

    В главе 3 мы говорили, что сжатые сроки сдачи могут иногда снижать мотивацию работников. Определённо существуют случаи, когда сжатые, но не запредельно, сроки могут быть для команды приятным вызовом. Но что никогда не будет полезным, так это идиотские сроки сдачи. Когда руководитель сообщает, что «без всяких компромиссов продукт должен быть готов к…», сотрудники с трудом сдерживаются, чтобы не закатывать глаза. Они это уже проходили, они в курсе вопроса.
    Возможно, беспредельно сжимаемые сроки когда-то были эффективными. Возможно, когда-то существовали работники столь наивные, что верили в то, что слышали. Когда шеф говорил, что «работу действительно надо сделать обязательно к январю», они, быть может, сразу принимали это обстоятельство к сведению и энергично брались за дело. Может быть. Но теперь из этого уже точно ничего не получится. Люди в вашей команде сразу поймут, что их пытаются надуть. Если вы скажете, что продукт без разговоров должен быть готов к случайно выбранной дате, они спросят: «Почему? Вселенная перестанет существовать, если мы опоздаем? Или компания закроется? А может быть, нашу страну затопит? Или вся западная цивилизация исчезнет?»
    В типичной болтовне об идиотских сроках сдачи руководитель объявляет, что работа должна быть сделана к такой-то дате. К этой дате её сделать невозможно, и всем это известно. Опоздание неизбежно (и на том можно распрощаться с идеей об абсолютно жёстких сроках сдачи). Работа ведь была переопределена таким образом, что успех становится невозможным. Работники чётко понимают, что их руководитель — просто робот, поражённый болезнью Паркинсона, не уважающий и не ценящий их. Шеф считает, что они и пальцем не шевельнут без принуждения. В этом проекте не стоит ожидать кристаллизации команды.

    Насаждение клик

    Участник одного из наших семинаров сделал такое наблюдение: «Наше руководство лишь тогда проявляет интерес к командам, когда предпринимает шаги, направленные на их разделение». В компании может существовать явное правило, что командам не разрешено в полном составе переходить от одного проекта к другому. Или что для завершающихся проектов необходим плавный и постепенный перевод людей в новые проекты. Это гарантирует разделение команд. Многие организации не принимают специальных мер для развала команд, но ничего не делают, чтобы сохранить уже образованные команды.
    Удовольствие от командной работы и энергия, генерируемая в командных взаимодействиях, — это символы веры нашего общества. Как же коммерческие организации пришли к такой апатии и даже антипатии в отношении команд? Одной из причин, как мы показывали в главе 19, является неуверенность. Другой — очевидно низкое осознание ценности команд в высших эшелонах руководства. Явление команды, которое мы описываем, существует лишь на нижнем уровне иерархии. Несмотря на болтовню о «командах руководителей», такого явления в природе не существует — на руководящем уровне никогда не происходит кристаллизация. Когда руководителя принимают в команду, это происходит лишь потому, что он играет двойную роль: с одной стороны руководителя, а с другой — участника группы. Он становится коллегой на неполный рабочий день для людей, которыми управляет. По мере подъёма по иерархической структуре организации понятие кристаллизованной команды все больше и больше уходит в небытие.

    И опять на ту же грустную тему

    Большинство организаций не стремятся к разрушению команд сознательно. Просто они так себя ведут.

    21. Ужин со спагетти

    Представьте себя техником, которого только что перевели в новый проект. Вы знаете руководителя и других участников по именам, но это, пожалуй, все. Вы выходите на работу в новом проекте в следующий понедельник. До этого, в среду, звонит ваш будущий босс. Она устраивает вечеринку для участников нового проекта. Есть ли вероятность, что в четверг вечером вы сможете придти к ней домой на ужин с остальными? Делать вам нечего, и вы не прочь познакомиться с группой, поэтому вы соглашаетесь.
    Когда вы появляетесь на вечеринке, вся группа уже рассредоточилась по гостиной, потягивая пиво и обмениваясь боевыми историями. Вы присоединяетесь к ним и тоже что-то рассказываете. Представитель клиента, также приглашённый на вечеринку, говорит о руководителе своего отдела. Все продолжают пить пиво. Вы вспоминаете о еде. Никакого запаха готовки и никаких признаков жизни на кухне. Наконец ваш будущий босс признается, что не успела приготовить ужин, и предлагает всем прогуляться до ближайшего супермаркета за ингредиентами пищи. «Думаю, мы вполне способны все вместе приготовить ужин из спагетти».

    Начинают проявляться командные эффекты

    Вы отправляетесь в путь. В супермаркете вы всей группой неторопливо продвигаетесь по рядам. Никто не берет на себя роль лидера. Ваш босс, похоже, думает о чем угодно, но не об ужине. Она болтает, смеётся и рассказывает байку про налоговую службу. Несмотря на отсутствие руководства, какие-то вещи в тележку попадают. Один парень уже решил вопрос с салатом. Идёт разговор о необходимости соуса из моллюсков, и, «если никто не против», двое из ваших новых коллег начинают обсуждение некоторых деталей готовки. Вы принимаете решение сделать свой фирменный хлеб с чесноком. Кто-то ещё снимает с полки бутылку кьянти. Наконец все согласны, что тележка достаточно полна для ужина.
    Вернувшись на ранчо, вы разгружаете сумки с бакалейными товарами, а босс находит ещё банку пива и принимается рассказывать о новом программном средстве. Постепенно действие перемещается на кухню, где начинаются первые приготовления. Босс не даёт указаний, но вызывается добровольно порезать лук, когда в этом возникает необходимость. Вы начинаете заниматься чесноком и прогреваете на сковородке оливковое масло. Рядом булькает соус и кипит спагетти. В конечном итоге образуется ужин. Вы наедаетесь до отвала, а затем все вместе убираете со стола и моете посуду.

    Что здесь происходит?

    Проект ещё даже не начат, но только что случился ваш первый успех, успех группы. Успех порождает успех, а продуктивная гармония — ещё более продуктивную гармонию. Ваши шансы кристаллизации в осмысленную команду повысились с этим самым первым командным опытом.
    С этой точки зрения ужин со спагетти может показаться проявлением изобретательности со стороны руководителя. Но, скорее всего, это была не уловка, и вам так не показалось бы при посещении ужина. Если бы вы прямо спросили руководителя, что она затевала в тот вечер, она, вероятно, совершенно искренне ответила бы: «Ужин». Прирождённый руководитель на уровне подсознания ощущает, что именно будет полезно для команды. Это ощущение может руководить проектными решениями. Весь проектный опыт состоит из достижения маленьких успехов совместными усилиями. Чтобы увидеть в этом воздействие руководителя, придётся как следует присмотреться, потому что кажется, что все происходит само собой.
    Много раз от разных руководителей мы слышали варианты истории ужина со спагетти. Общая идея такова, что хорошие руководители стараются как можно чаще предоставлять команде возможности для совместного успеха. Это могут быть маленькие пилотные подпроекты, или демонстрации, или же симуляции, все, что помогает создать в команде привычку добиваться успехов вместе. Лучший успех — тот, в котором нет очевидного участия руководства, а команда работает как содружество равных. Лучший начальник — тот, кто может повторять это раз за разом, не давая участникам команды догадаться, что ими «руководят». Таких руководителей их собственные коллеги считают просто удачливыми. У них все получается словно само собой. У них есть команды, рвущиеся в бой, проекты, быстро набирающие ход, и до самого конца все вокруг такого руководителя работают с энтузиазмом. Эти руководители никогда не напрягаются. Выглядит все настолько просто, что никто не верит, что они вообще руководят.

    22. Открытое кимоно

    Выращивание кристаллизованных команд — до некоторой степени дело случая. Никто не умеет делать это последовательно. Никто не может заставить кристаллизацию произойти, особенно в тот момент, когда она наиболее необходима. Иногда ингредиенты выбраны неправильно. А иногда в группу набирают людей, не расположенных играть в команде — они одиночки, и таковыми останутся навсегда.
    Роб Томсет (Rob Thomsett) в своей книге «People and Project Management» (Управление людьми и проектами) анализирует определённые патологии, препятствующие формированию команды[64]. Это захватывающее чтение. Некоторые из этих патологий, впрочем, излечимы. Практически единственное средство — удалить из проекта определённых его участников, поскольку они плохо влияют на шансы кристаллизации команды. Само по себе это звучит неплохо, но в каждом конкретном случае вы, вероятно, обнаружите, что способ просто дурацкий. Тот человек, без которого вы примете решение обходиться в дальнейшем, вероятно, окажется звездой во многих других отношениях. Многие проекты работают (и достигают успеха) без кристаллизации команд.
    С этой оговоркой мы представим неоспоримый факт: некоторые руководители умеют помогать кристаллизации команд. Они чаще преуспевают в этой задаче, чем терпят неудачи. В данной главе мы изучим одно свойство этих руководителей.

    Сообщите о здоровье

    Вероятно, вам приходилось слышать, как люди по телефону сообщают о своём невыходе на работу из-за болезни. Возможно, вы и сами когда-то так делали. Но приходило ли вам в голову позвонить и сообщить, что вы здоровы? Примерно так. Вы позвоните шефу и скажете: «Послушайте, я был болен все то время, когда работал здесь, но сегодня я здоров и больше не появлюсь на работе».
    Even Cowgirls Get the Blues[65] (Даже девушки-ковбои иногда грустят)
    Когда говорят, что только «больной» может работать на ту или иную организацию, то имеют в виду не физическое недомогание. Подразумевается, что работа в таком месте потребует отказа от определённых правил, позволяющих защитить свою психику. Наиболее важное из таких правил связано с заботой о себе и своих интересах. Ситуация, требующая отказа от этого правила, «нездорова» сама по себе.
    Человек, сообщающий по телефону, что он здоров, готов к работе, возвышающей его собственные интересы. Назначение на такую работу является подтверждением компетентности в определённых областях, предоставляет в этих областях самостоятельность и ответственность. Руководители здоровых сотрудников стараются уважать автономию, единожды предоставив её. Они понимают, что неудача работника будет иметь плохие последствия для руководителя, но это лишь правила игры. Они готовы время от времени преодолевать препятствия, прямой результат неудачи одного из сотрудников. Когда такое происходит, они подозревают, что сами никогда не сделали бы такой ошибки, если бы выполняли работу, а не занимались руководством. Ну и что? Вы сделали все возможное, чтобы найти подходящего человека на определённую должность, и теперь нет смысла менять решение задним числом.
    Такое отношение открытого кимоно прямо противоположно оборонительному руководству. Вы не пытаетесь защититься от людей, которых поставили в доверенное положение. И в таком доверенном положении находятся все ваши сотрудники. А если вы не можете доверить человеку какую-то автономную деятельность, он для вас бесполезен.
    Одним из моих первых начальников был Джерри Винер, руководивший командой в General Electric в рамках проекта по внедрению компьютеров. Позднее он создал небольшую компанию в сфере высоких технологий. Когда я поступил на работу, компания готовилась заключить контракт такого масштаба, который превосходил все прежние достижения. Все сотрудники собрались вместе, и наш корпоративный адвокат вручил Джерри контракт, предлагая прочитать и поставить подпись на последней странице. «Я не читаю контракты», — сказал Джерри и начал ставить подпись. «О, одну минуту, — ответил адвокат. — Позвольте мне просмотреть его ещё раз».
    Т. Д.
    Урок не в том, что следует подписывать контракты, не читая (их стоит читать, но если вы платите юрисконсульту за чтение таких документов в ваших интересах, это правило можно нарушать). Если вы связались с плохим юрисконсультом, то в любом случае окажетесь в очень неприятной ситуации. Руководители, наиболее успешно справляющиеся с работой, скорее всего, не слишком подготовлены к оценке контрактов на эту работу. Чтение контрактов в таком случае будет простым чванством. Джерри затратил много усилий, чтобы нанять лучшего юрисконсульта, какого только смог найти. Несомненно, он уже знал, на каком уровне этот человек работает. Так что в момент подписания контракта был не тот случай, когда надо обороняться, а случай дать всем ясно понять, что шеф полагается на компетенцию тех, кто его окружает.
    Осознание того, что шеф поставил часть своей репутации в зависимость от действий подчинённого, опьяняет и немного пугает. Оно проявляет лучшие качества в каждом. У команды появляется осмысленная идея, вокруг которой можно сформироваться. Они не просто делают работу. Они обеспечивают вознаграждение за возложенное доверие. Именно такой вид руководства — с позиций открытого кимоно — даёт команде лучшие шансы на формирование.

    Освобождающие уловки

    Наиболее распространённое у руководителей средство защиты от подчинённых — непосредственное наблюдение. Они слоняются по кабинетам в поисках бездельничающих сотрудников или некомпетентных решений. Это паркинсоновы патрульные, постоянно ищущие к кому бы придраться. Разумеется, никто (ни руководитель, ни подчинённый) не думает об этом в таких терминах, поскольку это в большой степени часть корпоративной культуры. Однако мысль о том, чтобы обходиться без патрулирования, беспокоит многих руководителей.
    Не так давно я по долгу службы принял участие в проекте по созданию клиентской информационной системы для калифорнийской компании. После написания спецификации мы были готовы начать внутреннее проектирование. Шеф созвал нас и вручил каждому карту, на которой была указана дорога к офису в далёком Лонг-Биче. Он объяснил, что там есть свободный конференц-зал, где мы можем работать, не отвлекаясь. Он же останется и будет отражать все телефонные звонки, кроме самых важных. Мы получили указание «возвращаться, когда все будет готово». Через две с лишним недели мы вернулись с великолепным проектом. За все это время он ни разу не позвонил и ни разу не появился лично.
    Т. Д.
    Если под вашим управлением работают достойные сотрудники, то вы вряд ли найдёте лучший способ увеличить их шансы на успех, чем просто не мешать им работать. Любая задача, которую можно выполнить в автономном режиме, — отличная возможность не мешаться. В таких случаях настоящее руководство и не требуется. Отошлите людей. Найдите удалённый офис, снимите конференц-зал, позаимствуйте чью-нибудь дачу или найдите отель. Воспользуйтесь сезонными скидками лыжных или прибрежных курортов. Отправьте сотрудников на конференцию и пусть задержатся на несколько дней, чтобы у них была возможность мирно поработать вместе. (Мы встречались по меньшей мере по одному разу с каждым из этих приёмов.)
    Такие дерзкие действия будут стоить вам нескольких очков в глазах собственного руководства и коллег. Откуда ты знаешь, будут спрашивать они, что вот сейчас твои люди не бездельничают? Как ты можешь быть уверен, что они не уходят на обед в одиннадцать утра и не пьянствуют во второй половине рабочего дня? Ответ прост: это будет ясно по продукту, с которым они вернутся. Люди узнаются по делам. Если они вернутся с тщательно продуманным полноценным результатом, они работали. Если нет, не работали. Визуальное наблюдение просто смешно для сотрудников проекта по разработке. Визуальное наблюдение — это для заключённых.
    Работа же вне офиса помогает довольно серьёзно. Во-первых, она избавляет самый ценный ваш ресурс от вмешательств и раздражений, съедающих столь заметную часть рабочего времени. Возможно, когда-нибудь вы успешно создадите производительную офисную среду, рабочие места, где есть возможность что-то сделать с девяти до пяти. Но это в перспективе. А пока же используйте любой повод, чтобы дать людям возможность работать вне офиса. Это не только сделает их более производительными: свобода и периоды полной автономии увеличат их шансы на кристаллизацию в мощную команду.

    Правила существуют, и мы их нарушаем

    Инженерные профессии известны одним способом разработки, невозможным для всех остальных профессий, — тайными проектами. Тайный проект спрятан в таком месте, где можно спокойно его завершить, а высшее руководство никогда не узнает, что происходит. Так случается, когда люди на низших уровнях настолько сильно верят в необходимость продукта, что отказываются принять решение руководства о закрытии проекта. PDP-11, один из самых успешных продуктов DEC (Digital Equipment Corporation), появился на рынке именно так. О таких проектах ходят легенды. Что удивительно, тайные проекты — лишь иное определение неподчинения. Руководство говорит «нет», но проект все равно продолжается.
    Один из наших клиентов пытался прервать создание продукта из-за отсутствия рынка. Но трезвые головы одержали верх, и продукт был создан. Он имел огромный успех. Руководитель, попытавшийся прервать проект (он стал теперь президентом компании) заказал для команды медаль с гравировкой: «Первый ежегодный приз за неповиновение». Он вручил медаль и в своей речи пожелал всем, кто хочет добиться этой награды, повторить этот успех. Безрезультатное неповиновение недостойно никаких призов.
    Люди на всех уровнях знают, когда разумное неповиновение допустимо. Люди ищут руководителей в открытых кимоно. Они полны решимости не подвести своих руководителей, даже если те пытаются испортить то или иное решение. Руководители на оборонительных позициях предоставлены сами себе.

    Цыплята с губами

    В середине семидесятых Ларри Константин консультировал некоторые компании на предмет построения здоровой корпоративной социальной среды. Один из его советов: разрешать людям на самых низких уровнях участвовать в выборе команды. На практике компания объявляла новые проекты на централизованной доске объявлений. Люди самостоятельно формировали команды-кандидаты на разработку проектов, а затем подавали заявки. Если вы жаждете работать с определёнными сотрудниками, то просто складываете свои резюме и устраиваете совместную презентацию своего видения проекта. Оценка производится на основе того, насколько хорошо вы подходите для задачи, насколько хорошо дополняете способности друг друга и насколько назначение вашей группы на этот проект может помешать другим проектам компании. Компания выбирает для каждой задачи наиболее подходящую команду.
    Эта схема давала людям две необычных степени свободы: выбирать проекты, в которых они будут участвовать, и выбирать людей, с которыми они будут работать. Что удивительно, первый из этих факторов имел совсем небольшое значение. Руководство изначально опасалось, что лишь интересные проекты привлекут внимание, но практика их переубедила. Даже на совершенно приземлённые проекты поступали заявки. Зато, похоже, большое значение имела свобода выбирать тех, с кем придётся работать в проекте.
    Идея проб и прослушиваний, представленная в главе 15, обладает похожими свойствами. Участники проекта, присутствующие на прослушивании, — это не просто аудитория; они участвуют в принятии решения о приёме на работу. Помимо технической экспертизы они представляют ещё и командное видение того, насколько хорошо приживётся кандидат: «Думаю, мы сможем работать с этим парнем» или «Похоже, он толковый, но в этой группе будет мешать».
    Несколько лет назад мы входили в состав достаточно тесной рабочей группы, участники которой начали приобретать общие черты характера. В частности у нас появилось схожее чувство юмора. Мы даже разработали общую теорию юмора. По этой теории некоторые вещи от природы смешны. Цыплята, к примеру, смешны, а лошади нет. Губы уморительны, локти и колени тоже, а вот плечи — просто плечи. Однажды мы присутствовали на прослушивании нового участника группы. После того как он все рассказал и ушёл, один из наших коллег высказался так: «Полагаю, к знаниям придраться нельзя. Но как вы думаете, он когда-нибудь сможет понять, что цыплята с губами — это смешно?» Кандидат не получил это место.

    Кто здесь главный?

    Лучшие из начальников умеют рисковать. Они рискуют вместе со своими людьми. Конечно, хороший руководитель все равно руководит, даёт указания и имеет собственное мнение. Он делает это постоянно. Идея в том, что они делают это, лишь давая волю естественному авторитету. Между превосходным ремесленником и подмастерьем существует связь естественного авторитетного характера — учитель знает, как делать работу, а ученик — нет. Подчинение такому авторитету не роняет ничьего достоинства, не исключает инициативу, не делает невозможным установление связей с коллегами. Неуверенность, требующая повиновения, есть полная противоположность естественному авторитету. Она гласит: «Я существо другой касты, я руководитель. Я принадлежу к классу мыслящих. Мои подчинённые наняты лишь для того, чтобы выполнять мои решения».
    В лучших из организаций естественный авторитет работает во всех направлениях. Известно, что руководитель опытнее в некоторых вопросах — скажем, в определении общих направлений, в переговорах, в найме. Ему доверяют все эти вещи. Известно, что каждый сотрудник имеет свою профессиональную область, и ему доверяют как естественному авторитету в этой области. В такой атмосфере открытого кимоно команда имеет оптимальные шансы на кристаллизацию.

    23. Химия формирования команд

    Некоторые организации известны своей последовательной удачливостью в создании хорошо сработавшихся команд. Конечно же, здесь нет удачи, речь идёт лишь о химии. В таких организациях психологический климат представляет собой оптимальную смесь компетенции, доверия, взаимного уважения и приятной социальной среды, и эта смесь становится отличной почвой для выращивания кристаллизованных команд. И не только на формирование команд благотворно воздействуют перечисленные факторы. Подобные организации просто процветают. У них все получается.
    Мы не будем иллюстрировать это примером из собственного опыта — оставим это в качестве задания читателям. Вам приходилось бывать в организации, которая просто светится здоровьем? Люди веселы, хорошо проводят время и получают удовольствие от взаимодействия с коллегами. Никто не занимает оборонительную позицию, и нет ощущения, что отдельные люди пытаются достичь успеха, несмотря на активное сопротивление окружающих. Здесь продукты — результаты совместной деятельности. Каждый гордится их качеством. (Хотя бы проблеск таких симптомов должен наблюдаться в вашей компании. В противном случае, возможно, вам пора объявить себя здоровым и забрать своё резюме.)
    Чем занимаются руководители в этих процветающих компаниях? При поверхностном взгляде может показаться, что они вообще не сильно утруждаются. Они не кажутся занятыми. Они очень скупо раздают указания. И совершенно определённо они не делают работу самостоятельно, какова бы ни была их связь с этой работой.
    В организациях с наилучшей химической средой руководители посвящают себя созданию и сохранению такой химии. Отделы и подразделения светятся здоровьем потому, что их руководители этого добиваются. Методам таких руководителей присуща глобальная целостность, а потому составляющие нелегко разделить и обозначить (для нас важнее, как эти составляющие собираются в единое целое, чем то, какие именно это составляющие). Однако попробовать все равно стоит.
    Ниже представлен, признаем, упрощённый перечень элементов стратегии создания здоровой химии для процветающей организации:
  • Возводить качество в ранг культа.
  • Создавать многочисленные промежуточные финиши, приносящие удовлетворение.
  • Внушать чувство элитарности.
  • Допускать и поощрять неоднородность.
  • Сохранять и защищать успешные команды.
  • Раздавать стратегические, но не тактические указания.
    Есть и другие элементы. Мы перечислили лишь те, что особенно влияют на формирование команды. В последующих разделах мы изложим свои соображения по каждому из пунктов.

    Культ качества

    Утверждение, что продукт, не доведённый до идеала, «достаточно хорош», — это похоронный звон для кристаллизующейся команды. Невозможно найти импульс для объединения ваших людей в общем удовлетворении от сдачи продукта среднего качества. Противоположный подход — «лишь идеал для нас достаточно приемлем» — даёт команде настоящий шанс. Этот культ качества является сильнейшим катализатором для формирования команды.
    Он связывает команду воедино, отделяя её участников от всего остального мира. Вспомним, что остальному миру на качество вообще наплевать. Да, все голосуют за качество, но если оно стоит лишнюю копейку, вы начинаете быстро познавать настоящее отношение к качеству со стороны тех, кто платит.
    Наш друг Лу Мацукелли (Lou Mazzucchelli), президент Cadre Technologies, собрался купить бумагорезательную машину. Он пригласил представителя фирмы, чтобы посмотреть на её работу. Аппарат оказался ужасным. Гигантских размеров и очень шумный (он грохотал даже тогда, когда не был занят уничтожением бумаг). Наш друг поинтересовался машиной производства Германии, о которой слышал. Коммивояжёр высокомерно заявил, что тот аппарат стоит в полтора раза дороже и у него нет ни одной дополнительной возможности. «За эти лишние деньги, — добавил он, — вы получите только лучшее качество».
    Ваш рынок, ваши покупатели, ваши клиенты и руководители высшего звена никогда не встанут стеной за высокое качество. Выдающееся качество в контексте экономических расчётов ближнего прицела мало кому интересно. Когда участники команды живут культом качества, они всегда сдают продукт более высокого качества, чем требует рынок. Они могут делать это, лишь будучи защищёнными от экономики ближнего прицела. И в долгосрочной перспективе это всегда оказывается выгодно. Людей пьянит качество, и они соревнуются сами с собой, чтобы сохранить его.
    Кен Орр называет культ качества «песчинкой в устрице». Это фокус образования команды.
    Я признался ей в любви, когда женился на ней[66]
    Некоторым это может показаться новостью, но человеческим существам время от времени требуется подтверждение, что они выбрали верное направление. Командам человеческих существ такое подтверждение тоже требуется. Обретение уверенности происходит из явления, которое психологи называют замыканием. Замыкание — это удовлетворение, получаемое в момент объединения частей целого воедино.
    Организациям тоже необходимы замыкания. Замыкание для организации — это успешное завершение запланированных работ плюс, возможно, периодические подтверждения правильности направления в ходе проекта (скажем, в моменты достижения промежуточных результатов или сдачи существенных фрагментов работы). Количество таких подтверждений для корпораций есть функция того, какова ставка в денежном выражении. Зачастую единственного замыкания в конце четырехлетнего проекта вполне достаточно для нужд организации.
    Сложность здесь в том, что организации гораздо меньше нуждаются в замыканиях, чем работающие в организациях люди. Перспектива четырех лет работы без единого удовлетворительного замыкания заставляет каждого участника группы думать: «Я, может, умру раньше, чем этот проект закончится». Частые замыкания особенно важны в момент объединения команды. Участники команды должны приобрести привычку совместно достигать успеха и полюбить это состояние. Это часть механизма накопления движущей силы для команды.
    Руководитель, использующий химические процессы в создании команд, прилагает усилия, чтобы разделить работу на части и убедиться, что каждая из частей даёт ощутимый эффект собственной завершённости. Такой руководитель может ухитриться сдать продукт после двадцати версий, хотя для его собственного начальства и конечных пользователей хватило бы двух. Может даже оказаться необходимым скрыть некоторые из промежуточных версий от клиента, поскольку они создаются лишь с целью получения внутреннего подтверждения и удовлетворения. Каждая новая версия представляет собой возможность замыкания. Участники команды разогреваются по мере приближения к этому моменту и в районе финиша бегут уже в темпе спринта. Успех пьянит их. Успех наполняет их новой энергией для следующей дистанции. Успех делает их ближе друг к другу.

    Элитная команда

    В начале 70-х вице-президент одной из компаний, которые мы консультировали, разослал всем сотрудникам своего подразделения письмо на тему командировочных расходов. Не исключено, что вы и сами получали подобные письма. Но это письмо отличалось от других. Содержание его было примерно таково: «До моего сведения дошло, что некоторые из вас, путешествуя за счёт компании, выбирали эконом-класс. Наша организация не относится к эконом-классу. Это первоклассная организация. В дальнейшем, путешествуя по делам компании, вы будете летать первым классом». Разумеется, это письмо стоило компании денег. Расходы были весьма ощутимы, и компенсировать их могло лишь усиление ощущения элитарности. По крайней мере одна организация посчитала, что это хорошая сделка. Такого не может случиться в настоящей корпорации, скажете вы. Но это случилось — в компании Xerox.
    Тот, кто считает попкорн проявлением «непрофессионализма», считает элитарность команды попросту разрушительным фактором. Распространено мнение, что если команда каким-то образом выделяется, это значит, что руководитель просто не выполняет свою работу. Приверженность группы корпоративному стандарту или единообразию является почти символом степени контроля со стороны руководителя. Однако с точки зрения людей, которыми руководят, этот символ убийственен. Чем более удобна подобная ситуация для руководителя, тем больше жизненной энергии теряет команда.
    Людям необходимо ощущение уникальности, чтобы жить в мире с собой, и если они не живут в мире с собой, то процесс кристаллизации не может начаться. Когда руководство душит уникальность, то может удушить все её проявления. Люди просто начинают выражать свою уникальность в областях, неподвластных контролю. Скажем, сотрудники, обладающие извращённой гордостью за то, что ими трудно руководить, или за то, что их трудно мотивировать, или за то, что они не могут работать с другими, возможно, реагируют таким образом на слишком большую степень контроля. Почти наверняка они предпочли бы самовыражаться менее сложным способом, не приносящим вреда эффективности группы.
    Чем плоха команда, которая уникально производительна, или же уникальна в своём стремлении к качеству, или уникальна в своих возможностях сдачи продукта в сжатые сроки? Ничем, скажете вы, но даже такие номинально приемлемые формы уникальности выводят из равновесия многих руководителей. Они жалуются, что команды неуправляемы и нахальны. На деле же элитарность команды угрожает совсем не управляемости, но власти руководства. Команда может упорно продвигаться к успеху, а руководитель в это время обеспокоен, что его сочтут тряпкой.
    Вы пошли бы на то, чтобы сделать своих людей более производительными, более ориентированными на достижение цели, но при этом менее управляемыми? Ответ на такой вопрос проводит черту между великими руководителями и обычными, средними. Средний руководитель слишком неуверен, чтобы распрощаться с атрибутикой руководства. Великий руководитель знает, что людей в любом случае нельзя контролировать разумными способами и сущность успешного руководства в том, чтобы задать нужное направление для участников проекта, а потом разогреть команду до такого состояния, чтобы ничто не могло помешать успеху, даже руководитель.
    Кристаллизация команды делает людей более производительными и ориентированными на достижение целей. А вам действительно приходится ослабить контроль или же иллюзию контроля, когда происходит кристаллизация. Команда так или иначе начинает чувствовать себя элитарной, и все её участники разделяют это ощущение. Уникальная черта команды не должна быть фундаментальной. Скажем, существовало одно всепобеждающее объединение футбольных защитников с единственной уникальной характеристикой — все участники этой команды были «безымянными». Этого оказалось достаточно. Они гордились этим фактом и объединились вокруг него. Независимо от конкретики, любая характеристика элитарности формирует основу командной личности — существенный ингредиент для кристаллизации команды.
    Здесь важно лишь то, что команды должны быть уникальными в некоторых аспектах, но не во всех. Есть множество примеров команд, следовавших всем стандартам организации, регулирующим внешний вид. Участники военных команд и большинства спортивных команд одеваются одинаково. Но если им разрешают почувствовать свою уникальность в каком-то ином смысле, они готовы подчиняться.
    Руководители, ощущающие угрозу в элитарности команд, часто говорят о губительном эффекте такой элитарности на людей, не входящих в команду. Если участники одной небольшой рабочей группы начнут считать себя Победителями, получается, что все остальные автоматически попадают в категорию Неудачников? Действительно, крайне удачливые команды могут выглядеть устрашающе для всех прочих сотрудников. Но это не столько воздействие команд, сколько воздействие их успеха. Если это единственная из ваших проблем, вам пора написать собственную книгу.

    Не распыляйте силы

    Если команда не кристаллизуется, не ломайте её. По крайней мере, дайте людям возможность вместе поучаствовать ещё в одном проекте. Они могут выбрать для себя иные проекты, но выбор должен быть. Когда команда в полном составе переходит от одного проекта к другому, то начинает новый проект с невероятным энтузиазмом.

    Сетевая модель поведения команды

    Возможно, это оскорбит ваши чувства руководителя, но руководитель обычно не входит в команду, которой управляет. Команды создаются из людей равных, которые и функционируют как равные. Руководитель чаще всего находится за пределами команды, время от времени подчёркивая направления развития и убирая с дороги административные и процедурные препятствия. По определению руководитель не является равным и не может поэтому стать частью группы равных.
    Эта мысль печалит руководителей, гордящихся своим лидерством. Разве руководитель не есть источник лидерства, разве не планирует действия, не вдохновляет команду на успех посредством тщательного отбора игроков и сверхточного чувства времени? Звучит неплохо, но если команде требуется такое лидерство, это означает, что она не очень хорошо функционирует как команда. В лучших командах лидерство переходит от одного человека к другому в зависимости от области специализации. Никто не становится лидером навсегда, потому что такой человек мгновенно перестаёт быть равным, что обязательно нарушает взаимодействие в команде.
    Команда — это сеть, а не иерархия. Несмотря на уважение к понятию лидерства (культовое слово в нашей области), лидерству здесь просто нет места.

    Сложный выбор — меню китайской кухни

    Рассказывая о командах, мы часто использовали простые аналогии между отраслевыми и спортивными командами. Само слово «команда» ассоциируется с образом здоровых молодых ребят, в поте лица гоняющих футбольный или хоккейный снаряд или же друг друга. Трудно думать о командах, не упоминая спорт, но спортивная аналогия привносит нежелательные сравнения.
    Типичная команда, которую вы видите по телевизору на выходных, состоит из людей, имеющих много общего. Так, участники баскетбольной команды все высокие, молодые, сильные, одного пола. Они похожи, ведь природа их занятия требует этого. В командах проектов по разработке нет столь жёсткого требования к похожести. Но раз сама концепция команды находится под влиянием примеров из спорта, мы часто ожидаем похожести в своих командах — возможно, даже бессознательно.
    Некоторая разнородность может стать огромным подспорьем для кристаллизации команды. Добавьте одного разработчика, имеющего физические недостатки, в только что сформированную рабочую группу, и шансы кристаллизации немедленно возрастут. Такой же эффект может дать сотрудничающий студент или бывший секретарь, для которого это первый проект после переподготовки. Любой элемент разнородности имеет символическое значение для участников команды. Это чёткий сигнал того, что допустимо не быть клоном, допустимо не вписываться в корпоративный шаблон универсального пластикового человека.
    Самый грустный пример чрезмерно гомогенизированной рабочей группы — это команда, состоящая только из мужчин. Женщины — очевидная жертва спортивных аналогий. Мужской истеблишмент, систематически исключающий их из командного спорта, теперь пытается оправдать это преступление, намекая, что женщины, скорее всего, плохо играют в команде. Разумеется, женщины в командах функционируют ничуть не хуже мужчин. Любой мужчина, работавший в смешанных командах, с трудом может себе представить работу в исключительно мужской среде. То был печальный удел наших отцов.

    Компиляция

    Не всегда этого удаётся добиться, но когда команда объединяется, затраты того стоят. Работать весело, люди полны энергии. Они проходят сроки сдачи и промежуточные финиши в поисках новых задач. Они нравятся сами себе. Они чувствуют преданность команде и среде, в которой возможно существование такой команды.

    V. УДОВОЛЬСТВИЕ ОТ РАБОТЫ? ЗДЕСЬ?

    Где-то в глубинах нашей родовой памяти затаилась мысль, что работа должна быть в тягость. Если вам нравится делать что-либо, это уже не работа. Если вам это очень нравится, то это, должно быть, греховное занятие. Вам не следует этим заниматься слишком много, а может быть, и вообще. А уж платить за это вам точно не следует. Вам, наверное, следует найти что-то другое, что больше похоже на работу. Тогда вы будете уставать, скучать и вообще будете несчастны — как все остальные.
    Если вы руководитель, эта реликтовая память требует, чтобы ваши люди никогда не получали удовольствия на работе. Любое свидетельство веселья или удовольствия на рабочем месте — верный признак, что некий руководитель не выполняет свои прямые обязанности. Работа не извлекается из работников с максимальной эффективностью, ведь в противном случае они не проводили бы время так хорошо.
    Конечно, никто и никогда прямо не говорит, что работа не должна приносить удовольствие, но идея витает повсюду, выжженная в нашем культурном подсознании. Она проявляется в виноватой застенчивости, когда нас застают восторженно хихикающими над текущей задачей. Она выходит на поверхность в нашем неохотном приятии униформы, политики «нет попкорну» и серьёзного вида вообще, по которому так называемых профессионалов и отличают от тех, кому работа доставляет удовольствие.
    Эта часть посвящена противоположной посылке: работа должна приносить удовольствие.

    24. Хаос и порядок

    Есть нечто в человеческой природе, что делает нас непримиримыми врагами хаоса. Встречая хаос, мы закатываем рукава и приступаем к работе, чтобы заменить хаос порядком. Порядок, созданный человеком, повсюду: в домах, в садах, в причёсках и аккуратных сетках улиц. Однако из этого не следует, что мы были бы счастливы в отсутствие всякого хаоса. Наоборот, нам было бы скучно до слез. Хаос, ещё существующий в современном обществе, — это ценный товар. Мы должны аккуратно экономить его, не давая жадинам больше положенной им доли.
    Жадины, как правило, — это мы, руководители. Мы часто видим хаос в своей области. И предполагаем, что наша задача — избавиться от хаоса, причём полностью. Руководитель в открытом кимоно имеет другую точку зрения. Он готов оставить небольшие фрагменты хаоса другим людям. В последнем случае задача руководителя разделить хаос поровну. И тогда подчинённым удаётся получить удовольствие, приводя хаос в порядок.

    Наша главная проблема — прогресс

    Количество беспорядка постоянно уменьшается. Это особенно очевидно в новых технологических областях. Люди, которых в эти области много лет назад привлекла новизна, отсутствие порядка, испытывают ностальгическую привязанность к временам, когда вещи были не до такой степени механизированы. Каждое великое открытие последних двадцати лет сокращало безумие нашей работы. Разумеется, открытия эти прекрасны — кому захочется возвращаться в прошлое — но все же…
    Все мы готовы улучшать методы и делать разработку более упорядоченным предприятием. Это прогресс. Да, часть безумного веселья в процессе теряется, но удовольствие одного человека может быть агонией другого (тот проект, показавшийся вам столь весёлым, вероятно, стал причиной язвы у вашего начальника). В любом случае движение к более упорядоченным, управляемым методам остановить невозможно. Вдумчивый руководитель и не хочет препятствовать этой тенденции, но может при этом ощущать потребность в замене потерянного беспорядка, который генерировал так много энергии. Это подводит нас к политике конструктивного привнесения дозированного беспорядка.
    Выразив идею столь смело, мы можем достаточно легко собрать перечень способов реализации подобной политики:
  • пилотные проекты;
  • военные игры;
  • мозговые штурмы;
  • провокационные курсы;
  • обучение, путешествия, конференции, торжества, отдых.
    Этот список мы ограничили методами привнесения беспорядка, успешное применение которых наблюдали в реальной жизни. Ваш собственный список может быть не столь кратким. Небольшой мозговой штурм по предмету (о мозговых штурмах чуть ниже) позволит найти фантастические и замечательные возможности.

    Пилотные проекты

    Пилотный проект — это такой, в котором вы откладываете в сторону толстый том стандартов и пробуете новый, неизученный метод. Новый метод вам не знаком, поэтому поначалу можно ожидать низкой производительности. Такова цена изменений. Обратная сторона медали — повышение производительности в результате применения нового метода. Кроме того, добавляется ещё эффект Готорна — прирост энергии и интерес, наполняющий людей, когда они изучают что-то новое и непривычное.
    Могут ли эти два плюса перевесить минус кривой обучения? Было бы безрассудством предполагать, что могут всегда. Большое значение имеет природа вносимых изменений, а также продолжительность проекта, способности его участников, степень веры людей в изучаемый метод.
    По нашему опыту пилотные проекты тяготеют к средней производительности, превышающей средние показатели. Это означает, что затраты на проект будут, вероятно, меньше, если вы решите сделать проект пилотным, то есть решите использовать какой-то новый метод.
    Означает ли это, что все проекты должны быть пилотными? Ваша организация окажется в хорошей компании, если примет подобный подход за правило; здесь и Fujitsu, и части Southern Company Services, и некоторые подразделения IBM. В любом случае смысла больше в том, чтобы все проекты были пилотными, чем в том, чтобы таких проектов вообще не было.
    Существует два возражения против любой расширенной программы пилотных проектов:
  • Что делать, если закончатся новые идеи?
  • Не усложнится ли ещё более сопутствующая деятельность (поддержка продукта, обучение клиентов и т. д.), если мы начнём поставлять не устойчивую продукцию?
    Первое возражение имеет смысл лишь в теории. Большинству организаций после десятилетних испытаний новых подходов редко (если вообще) приходится волноваться из-за того, что новые подходы закончатся. Если начать исследовать все хорошие идеи, на которые мы не обращали внимание в шестидесятых, затем перейти к семидесятым и восьмидесятым, то к моменту, когда исследование завершится, пройдёт ещё десятилетие и появятся многочисленные новые идеи.
    Что касается проблемы неустойчивых продуктов, то почему бы не признать, что такая проблема существует даже в случае следования жёстким стандартам? Существующая стандартизация привела к документальной стабильности продуктов, но никак не к осмысленной функциональной стабильности . Иначе говоря, стандартизация в основном затронула бумажную работу, связанную с продуктами, но не сами продукты. Если же бумажный вариант проекта немного отличается от стандартного, то серьёзных неудобств это не вызовет.
    Одно предостережение по поводу пилотных проектов: не экспериментируйте более чем с одним технологическим аспектом в пределах проекта. Несмотря на все разговоры о важности стандартов, просто удивительно, насколько часто руководители забывают обо всяких стандартах в редких пилотных проектах. Они часто испытывают новые аппаратные средства, новые программы, новые процедуры контроля качества, матричное руководство, а ещё новые методы создания прототипов — и все в одном проекте.
    Разумный подход к пилотному проекту — разрешить изменить лишь одну составляющую процесса. В здоровой среде участники проекта поймут, что экспериментировать с одним новым методом в каждом проекте — это нормально, но в целом следует всегда придерживаться стандарта.

    Военные игры[67]

    За четыре года существования наших военных манёвров разработчиков мы узнали, что иногда жёсткое состязание, в котором нет проигравших, может стать замечательным источником созидательного беспорядка. Наши игры ориентированы на сообщество разработчиков программного обеспечения, но идею можно применять практически в любой области. Независимо от рода вашей деятельности, возможность испробовать себя в решении специализированных задач и сравнить свои результаты со статистикой производительности коллег может быть весьма интересной. (Конечно же, такой опыт приятен лишь при наличии гарантий конфиденциальности, описанных в главе 8. Вы должны быть уверены, что результаты состязаний не будут использованы против вас.)
    Военные манёвры помогают вам оценить свои плюсы и минусы по относительной шкале, помогают организации выявить свои плюсы и минусы в глобальном масштабе. По этим причинам две из наших клиентских компаний разработали программу по ежегодному проведению военных манёвров, чтобы позволить своим сотрудникам измерять рост собственной квалификации с течением времени. Раз в год сотрудники подвергают себя конфиденциальным испытаниям (в чем-то это похоже на медосмотр).
    С целью стимуляции творческого беспорядка наиболее эффективная из разновидностей военных игр предлагает участникам объединяться в команды. Ниже приведена одна из формул таких манёвров, которую мы применяли до некоторой степени успешно (и с огромным интересом):
    1. Подберите маленький проект по разработке или чётко поставленную задачу; это будет ваш подопытный кролик. Лучший выбор — реальная для вашей организации задача, требующая от одного до двух человеко-месяцев работы. Выбирайте проблему, обладающую новизной, не простую, но при этом широко задействующую рабочие навыки ваших сотрудников.
    2. Подготовьте проект обычным образом — опубликуйте техническое задание.
    3. Объявите о проведении двадцатичетырехчасового состязания в ближайшие выходные. Постарайтесь объяснить всем, что вы не экономите за счёт выходных своих сотрудников. Объясните, что состязание проводится на выходных, чтобы команды могли свободно чувствовать себя на рабочих местах, а не из соображений экономии на человеческих ресурсах. Предложите участникам объединиться в команды по четыре человека и участвовать в состязании на совершенно добровольной основе.
    4. Распространите техническое задание заранее, наряду с правилами и целями состязания.
    5. В день состязания только его участники должны присутствовать в офисе. Позаботьтесь, чтобы у них было все необходимое: еда, компьютеры, кушетки, копировальные аппараты, конференц-залы — все что угодно.
    6. Все команды должны выполнять одну и ту же работу, причём в отведённое для состязания время.
    7. Подготовьте добровольцев, которые будут следить за соблюдением правил, предотвращать фатальные осложнения и устраивать большой шум по поводу каждого промежуточного финиша.
    8. Ищите возможности сделать каждого победителем в определённом смысле — по общему времени работы, по надёжности продукта, по оригинальности решений. Создавайте много шума вокруг каждого достижения.
    9. Установите победивший продукт или же несколько продуктов-победителей одновременно. Внимательно следите за временем стабильной работы продукта, количеством изъянов, уровнем дружественности продукта к пользователю, стоимостью изменений и любыми другими параметрами, определяющими успех проекта. Сообщайте значимые данные командам.
    Когда вы все это успешно осуществите, люди сообщат вам, что это был самый восхитительный и интересный опыт за все время их работы; а это как раз и было вашей целью. Стремитесь к её достижению, даже если поначалу не все получается, как задумано.
    Приведём некоторые соображения по поводу опытов вроде проектных состязаний. Во-первых, подобные мероприятия стоят денег. Не надейтесь, что ваши сотрудники, словно под гипнозом, за выходные создадут нечто, что в противном случае пришлось бы оплачивать по полной ставке. Проектное состязание обойдётся вам в несколько раз дороже, чем проведение того же проекта в рабочее время. Во-вторых, не пожалейте времени на подготовку чёткой постановки задачи, на обучение своих ассистентов к этому мероприятию, на создание многочисленных промежуточных финишей. В-третьих, приложите усилия, чтобы соразмерить масштаб проекта с выделенным на его выполнение временем (мало кто получит удовольствие, если все команды окажутся побеждёнными или если состязание закончится через час после начала). Наконец, изыщите возможность щедро потратиться на кормление участников (в одном из состязаний мы заказали пикник-ланч из одного нью-йоркского ресторана, устроили обед с доставкой, а потом, в два часа ночи, затащили всех в китайский квартал перекусить.)
    Продолжение проекта ночью каким-то образом лишь добавляет всем удовольствия. Людям нравится повод утомляться вместе, отгонять сон и позволять коллегам видеть себя лохматыми, небритыми, помятыми и раздражительными, без грима и притворства. И это сильнее привязывает участников проекта друг к другу.
    «В ходе мероприятия я заметил, как [68] прикорнула на коврике в приёмной. Я знал её много лет и всегда считал немного чопорной. Но с этого момента я стал относиться к ней иначе. Я стал иначе относиться ко всем. Мы прошли через это вместе».
    (Из обсуждения состязания)

    Мозговой штурм

    Мозговой штурм[69] — это структурированный сеанс взаимодействий, ориентированный в целом на возникновение творческих озарений. До шести человек собираются вместе, чтобы сосредоточиться на определённой проблеме. Правила проведения сеанса и уловки ведущего способствуют получению приятного и неорганизованного опыта, который часто приносит действительно ценные плоды.
    Правил немного. Поскольку вы пытаетесь привнести хаос в мыслительный процесс, правилам нет особого места. В роли ведущего вы пытаетесь внушить всем, что первоочередную важность имеет количество идей, а не их качество, и сделать так, чтобы общение протекало свободно или даже выглядело глупым. Иногда очевидно глупая идея, которой не было бы места в более формальной обстановке, может получить приз. В процессе мозгового штурма оценка качества идей не проводится. Этап оценки наступит позже. Препятствуйте критическим замечаниям вроде «Это дурацкая идея», поскольку дурацкие идеи часто наводят других людей на умные мысли.
    Как ведущий попробуйте следующие уловки для оживления мысленных процессов участников, когда поток идей начинает иссякать:
  • Мышление по аналогии (как эта или похожая проблема решается в природе?)
  • Обращение (как мы можем добиться противоположной цели?)
  • Погружение (как вы можете спроецировать эту проблему на себя?)

    Обучение, путешествия, конференции, торжества, отдых

    Каждый с удовольствием использует шанс вырваться из офиса, хотя, наверное, это не очень весёлый комментарий по поводу гнёта корпоративных рабочих мест. Наибольшее удовольствие работники получают, когда эта возможность сочетает путешествие с коллегами и неповторимый опыт. Это может быть совместное посещение семинара, особенно стимулирующего развитие, или участие в Международной конференции, посвящённой Чему Угодно. Ещё лучше, если речь идёт о путешествии в романтическое место. Вы можете отправить двух сотрудников из Бостона на конференцию в Лондон примерно за те же деньги, в которые обойдётся конференция в Сент-Луисе или Чула-Виста.
    Особый потенциал в процессе формирования команды закладывает борьба за дорожные расходы, которая позволяет вытащить участников команды из офиса — всех вместе. Если у клиента есть удалённая площадка, отправьте всю команду на разведку этой территории за счёт фирмы. Если на подходе сдача продукта, требующая интенсивной работы мысли, отправьте их в конференц-центр или в отель. Дайте им возможность путешествовать вместе, питаться вместе и вживаться в роли в новой команде.
    Школы Outward Bound[70] делают процветающий бизнес на том, что отправляют корпоративные группы в дикие места и проверяют их стойкость. Группам приходится пробираться через пороги и стремнины Бирмы, бороться за выживание в водах залива Пенобскот[71] или взбираться на гору Катадин[72]. Сегодня вы сражаетесь с IDMS[73], а завтра висите, вцепившись ногтями, и ждёте, когда коллега завернёт трос. Опыт, конечно, недешёвый. Если сложить стоимость обучения, стоимость путешествия и потерянные дни, получается до нескольких тысяч долларов на человека. В большинстве компаний о таких расходах даже мечтать не приходится. А как же другие компании, вкладывающие средства в Outward Bound и другие подобные мероприятия? Уж не упускают ли они что-то, что очевидно всем другим разумным существам в мире? Или же они стремятся раскрыть все самое лучшее в своих людях?
    Несколько тысяч долларов за подобный опыт для команды — слишком сурово для вашего неупорядоченного проектного бюджета? А сорок долларов вы сможете осилить? Один из лучших известных нам руководителей-новаторов имеет склонность заказывать для своих людей неожиданные ланчи. Однажды он вышел на улицу и нанял продавца хот-догов в комплекте с тележкой, квашеной капустой, жёлтой горчицей и сине-оранжевым зонтиком. Продавец поднялся на тридцатый этаж и подал ланч команде. Ланч, конечно, кошмарный с точки зрения диетолога, но совершенно идеальный с социологической точки зрения. Присутствующие пришли в приподнятое настроение, принялись подшучивать по поводу своей работы, своих руководителей и друг над другом. Уровень шума рос соразмерно их энтузиазму. Ланч обошёлся в сорок долларов, и его обсуждают до сих пор. Разумеется, руководитель оформил все это как бизнес-ланч, но это был никакой не ланч, а целое торжество.
    Здравый смысл и порядок — несомненно, желанные составляющие рабочего дня. Но ещё остаётся время для приключений, глупостей и небольших доз созидательного беспорядка.

    25. Свободные электроны

    Во времена наших родителей работа обычно жёстко регулировалась корпоративным контекстом. Человек работал на компанию, отмечая часы работы или высиживая целые дни в офисе. Каждую неделю получал чек, такой же, как на предыдущей. К вышестоящим относился с уважением и почтением: «Разумеется, сэр. Будет сделано без сучка, без задоринки, сэр». Не труд, которому посвящена вся жизнь, а скорее, обычная работа. Но с тех пор многое изменилось:
    Один из моих соседей по комнате в колледже недавно организовал посиделки выпускников нашего класса. Из двадцати пришедших лишь один имел «работу» в привычном смысле этого слова. Остальные работали либо на себя, либо по контрактам, либо вне штата, либо в ином нетрадиционном режиме.
    Т. Д.

    Феномен надомного промысла

    Сегодня далеко не новость, что многие наши коллеги работают в надомном предпринимательстве. Они заключают контракты на дни и недели, занимаясь программированием, проектированием или иногда руководством. Существуют даже специальные агентства, помогающие независимым профессионалам и организациям, которые нуждаются в их талантах, отыскать друг друга.
    С независимыми подрядчиками работают некоторые из наиболее солидных компаний и организаций. Разумеется, они во многих случаях предпочли бы нанять постоянных сотрудников, а не иметь дело с контрактниками. Но что они могут поделать? На рынке профессиональных услуг правила устанавливают продавцы. Этим компаниям приходится иметь дело с десятками небольших фирм вроде «Уильям Алонсо и Партнёры» (никаких партнёров на самом деле нет, есть один Билл) или «Fat City Smarts Company» (Толстые городские умники). Некоторые из этих ребят явно со странностями: они работают, когда захотят и, наверное, после каждого проекта два или три месяца катаются на лыжах. Бррррр! Как это непрофессионально.
    Если вы промышленный магнат, феномен надомного промысла может оказаться не просто мелким раздражителем. Частные предприниматели не только склонны к нахальству, они подают ужасный пример вашим сотрудникам. У них больше свободы, больше выходных, более широкий выбор проектов. Они получают больше удовольствия. Зачастую они и зарабатывают лучше.
    Гуру, научные сотрудники, интрапренеры[74]
    Под влиянием возрастающего давления организации вынуждены предлагать своим лучшим людям привлекательные альтернативы, чтобы не потерять их из-за возможности надомного промысла. Одной из таких альтернатив является должность с размытыми обязанностями, дающая индивидууму сильные позиции в выборе характера работы. В должностной инструкции может быть написано «исследует новые методы XXI века», или «создаёт новые интересные обучающие модели», или «проектирует идеальный комплекс для разработчиков».
    В крайних случаях возможен и карт-бланш: если корпорация настолько удачлива, что на неё работает не нуждающийся в мотивации преуспевающий профессионал, достаточно сказать: «Определи свою задачу сам». Наш коллега Стив Мак-Менамин называет таких сотрудников «свободными электронами», так как они вольны самостоятельно выбирать свою орбиту.
    Тенденция к созданию большего количества должностей для свободных электронов — не просто ответ на угрозу со стороны надомного промысла. Научных сотрудников, гуру, интрапренеров и частных консультантов в процветающих современных компаниях так много лишь потому, что они приносят этим компаниям пользу. Вклад людей на этих должностях соизмерим с вкладом их собственных нанимателей. Их мотивация в том, чтобы созданные для них должности приносили компаниям пользу.
    Куда идти и что делать, я во многом определяю самостоятельно. Руководство осознало, что компании нужен человек, наблюдающий за всеми направлениями, в которых мы сейчас не работаем, отсюда и мои льготы. Моя задача — импорт, я нахожусь в постоянном поиске технологий, которые могут облегчить нам выполнение работ. Такая должность делает меня более преданным компании, но менее преданным моему прежнему занятию — информатике; ведь от хорошей идеи никто не откажется, независимо от её источника. Свой успех я определяю исходя из пользы для компании. Как будто компания — моя собственная. Во многих людях скрыт талант интрапренера. Надо лишь опознать таких людей и открыть в них эти возможности.
    Майкл Л . Машет (Michael L. Mushet),
    руководитель группы технологических исследований,
    Southern California Edison
    За годы работы в этой компании я побывал на различных должностях, но лишь одна из них существовала до моего появления. С самого начала я имел возможность участвовать в определении своей должности. В организации всегда существует человек, до определённой степени склонный давать зелёный свет разумной деятельности в новых областях. И лучшие результаты достижимы в случае, когда руководство полагается на человека, а не на идею. Этот человек затем определяет идею и продаёт её. У каждого должна быть как определённая ответственность за самые разнообразные цели, так и свобода добиваться достижения этих целей.
    Ричард Брайтон ( Richard Branton ), руководитель,
    Data Administration Information Services
    Southern Company Services, Inc.
    Такой подход эффективен, если люди не нуждаются во внешней мотивации или до определённой степени позволяют действительности диктовать направления. Меня постоянно притягивает реальность, потому что того требуют интересы компании. Многочисленные чисто исследовательские проекты являются тупиковыми. Важно не терять концентрации на прикладной пользе технологий, потому что приложения всегда можно обратить на пользу организации. Сама же идея свободы полномочий может привести к печальным последствиям, как это случилось в Xerox. Некоторые из лучших сотрудников вдруг поняли, что компания не собирается использовать хорошие идеи, генерируемые в PARC, и потому ушли.
    Билл Бонэм (Bill Bonham),
    Sage Fellow,
    MicroSage Computer Systems, Inc.

    Никакой родительской опеки

    В советском обществе, особенно среди членов компартии, существовала всепроникающая система консультирования по жизненным вопросам. Практически каждому деятелю партии назначался советник — человек, с которым следовало встречаться еженедельно. Он помогал принимать важные решения, сглаживать проблемы в браке и карьере, а также держать в форме политические взгляды. Такой консультант служил заменой родителям .
    Западному человеку все это кажется ужасно назойливым. Мы считаем, что человека следует оставить в покое, чтобы он мог решать подобные вопросы или, по крайней мере, чтобы он был волен искать советов, когда и у кого ему будет угодно. Но на рабочем месте большая часть этого тонкого индивидуализма испаряется. Здесь мы считаем за мудрость, что практически каждому нужна твёрдая рука, рука начальства. Большинству нужны твёрдые указания, они приветствуют чёткую постановку задачи, исходящую от начальника, конкретное перечисление целей, достижение которых означает успех. Большинство нуждается и в чётком определении своих обязанностей, но руководство теми, кто в таком определении не нуждается, — совсем иное дело.
    Лучшего руководителя отличает способность выделить те натуры, что сочетают в нужной пропорции перспективу и зрелость, и освободить этих людей. Такой руководитель знает, что не способен действительно указывать направления этим прирождённым свободным электронам. Они развились до состояния, когда их собственное движение принесёт организации гораздо больше пользы, чем любое движение по указке сверху. Настало время уйти с их пути.

    26. Хольгер Датчанин

    В этой книге мы собрали рассказы о различных неверных путях, на которые ступают компании и проекты. Если мы сами на правильном пути, то по меньшей мере в нескольких очерках вы могли наблюдать отражение ситуации в вашей собственной компании. Каждая глава, даже самая мрачная, содержала рецепты и советы, описывала, что можно сделать, чтобы начать разумное реконструирование проекта, подразделения или же организации в целом. Конечно же, этих предписаний недостаточно, но они помогут начать. Они подстрекают вас противостоять мебельной полиции, сражаться с корпоративной энтропией, препятствовать травле команд, вкладывать больше качества в продукты (даже если на это нет времени), аннулировать закон Паркинсона, ослаблять формальные Методологии, увеличивать фактор С, открывать своё кимоно и делать десятки других вещей.
    Не надо быть ясновидцем, чтобы понять, что хорошие результаты может дать максимум одна из этих мер. Если вы попытаетесь убить сразу нескольких зайцев, то лишь распылите свои усилия. Суматохи от таких действий будет больше, чем созидания, и ваши коллеги и вышестоящие руководители спишут вас со счётов как беспомощного нытика. Одно изменение — уже хорошо. Даже единственное существенное изменение в социологии вашей организации станет грандиозным достижением.

    Почему я?

    Такое вот единственное достижение — трудная задача для одного человека. Если вы пересмотрели своё желание броситься в бой, это естественно. В конце концов, кто вы такой, чтобы противостоять могущественной группе, насаждающей повсюду новую Методологию или регулирующей планирование новых офисов? Хватит ли у вас сил?
    Несколько лет назад известность приобрёл тореадор по имени Эль Кордо-бес. За личной и профессиональной жизнью этого обаятельного парня пристально следила мировая пресса. В одном интервью репортёр поинтересовался, какие упражнения Эль Кордобес регулярно делает, чтобы быть в форме перед жарким боем с быком.
    — Упражнения?
    — Да. Ну, знаете, бег трусцой или поднятие тяжестей для сохранения
    физической формы.
    — Дружище, ты не понимаешь. Я не борюсь с быком.
    Ключ к успешному проведению изменений, за которые мы выступаем, в том, чтобы не пытаться бороться с быком. Для этого вы определённо недостаточно сильны.
    Действуя в одиночку, вряд ли можно добиться каких-то существенных перемен. И нет необходимости действовать в одиночку. Если что-либо выходит за допустимые рамки (скажем, шум на рабочем месте), очень легко пробудить в людях осознание ситуации. И дальше проблемой озабочены не только вы. А все сразу.

    Спящий гигант

    К северу от датского города Копенгагена стоит замок Кронборг. За несколько крон вы можете посетить замок и увидеть силуэт Хольгера Датчанина, легендарного спящего гиганта Дании. Он спит спокойно, когда в стране мир, но если Дания окажется в опасности, Хольгер проснётся и гнев его будет страшен. Целые классы датских школьников ходят на цыпочках мимо возлежащей пятиметровой фигуры. Его щит и меч лежат рядом, его доспехи приготовлены к бою. Дети говорят шёпотом — никто особо не жаждет увидеть исполина в действии, но они рады, потому что он на их стороне.
    Такой спящий гигант может существовать и в вашей организации, готовый проснуться, если она в опасности. А она в опасности, если слишком велика энтропия и слишком мало здравого смысла. Этот гигант — ваши коллеги и подчинённые, рациональные мужчины и женщины, терпение которых готово лопнуть. Независимо от уровня своего организационного мышления, они узнают Глупость в лицо. А некоторые вещи, наносящие больше всего вреда среде и социологии рабочего места, откровенно глупы.

    Как пробудить Хольгера

    Гиганта разбудить не так уж сложно[75]. Если глупость достаточно груба, катализатор может быть весьма мягким. Это может быть просто тихий голос, который произнесёт «Это неприемлемо». Люди знают, что это правда. И когда это сказано вслух, они больше не могут это игнорировать. Звучит весьма идеалистично, но если вы все-таки пробудите спящего гиганта в своей компании, то будете не первым:
  • Целый отдел крупной правительственной организации набил телефонные трубки салфетками. Теперь громких звонков нет — лишь мягкое урчание (или же это тихий голос Хольгера Датчанина?)
  • В одной калифорнийской компьютерной компании произошла серия партизанских атак на систему объявлений в офисах разработчиков. Провода постоянно кто-то перерезал. Поскольку программисты сидели в бывшей монтажной, потолки у них были пятиметровые. Кто может достать так высоко? Возможно, Хольгер Датчанин.
  • Руководитель крупного проекта в Миннеаполисе отказался переводить своих людей в новые помещения. («Новые» в данном случае означало просто более шумные и менее просторные.) Администраторов его отказ просто ошеломил, им и в голову не приходило, что подобное возможно. Работники ведь должны выполнять то, что им говорят. У этого руководителя теория была иная: работники должны работать. Он собрал достаточно сведений о новой среде, чтобы понять, что его люди не смогут этого делать на новом рабочем месте. Так что верным действием руководителя в этот момент был отказ. Будь он один в этом противостоянии, его бы легко одолели. Но он был не один. На его стороне выступал Хольгер Датчанин.
  • Одна австралийская компания больше не занимается формированием команд, теперь её сотрудники могут формировать команды самостоятельно. В этой компании вы просто объединяетесь с парой коллег и начинаете выступать в роли боевой единицы. Такое никогда бы не стало возможным без некоторого давления со стороны Хольгера Датчанина.
    Если вы грустно улыбались, читая предшествующие главы нашей книги, сейчас настал момент прекратить улыбаться и начать корректировку действием. Социология имеет большее значение, чем технология или даже деньги. Работа должна приносить продуктивное удовлетворение. Если работа не приносит радости, ничто другое уже не стоит внимания. Тщательно выбирайте область действий, собирайте факты и высказывайтесь. Вы сможете изменить мир — с небольшой помощью Хольгера Датчанина.

    VI. НАСЛЕДИЕ PEOPLEWARE

    Работая над вторым изданием, мы решили добавить новые главы в конец книги, не пытаясь полностью её переработать. И если при этом пострадала последовательность шестой части — в ней понемногу обо всем — то историческую перспективу первого издания удалось сохранить. Первые пять частей мы писали, будучи моложавыми, средних лет консультантами, которые большую часть своего времени работали с разными проектами. Шестая часть написана двумя сварливыми и убелёнными сединой стариками, которые теперь тратят ощутимо больше времени, консультируя уже целые организации. В первых пяти частях речь шла в основном о структуре проектов по разработке и средах, способствующих процветанию проектов; шестая часть посвящена структуре целых организаций, занимающихся разработкой.

    27. Снова о травле команд

    Описание семи видов травли команд, представленное в главе 20, казалось нам по тем временам вполне исчерпывающим. Но мы упустили два важных вида травли. Подобно изначальным семи, эти два широко практикуются в нашей отрасли. Один из них стал столь вездесущим, что вокруг него появилась целая индустрия…

    Проклятые плакаты

    В следующий раз, путешествуя самолётом, возьмите авиажурнал или бортовой каталог товаров и полистайте рекламу на разворотах. В какой-то момент вы наткнётесь на богатый выбор вдохновляющих постеров и сообщений, помещённых в рамку и предназначенных для корпоративных стен (кое-кто очень любит предназначенное для них место занимать созданными продуктами). Заставьте себя прочитать все эти плакаты внимательно, прокручивая в голове их тексты и поглощая слащавую прозу. Если вы в конце концов не разозлитесь, то, возможно, слишком долго проработали под совершенно отвратительным руководством.
    Травля команд в большинстве случаев наносит урон, эффективно унижая работу или людей, её выполняющих. Катализатором для команд служит общее осознание важности работы и того, что её стоит выполнять хорошо. Слово «хорошо» в предыдущем предложении — самое главное: команда вменяет себе в обязанность установить и поддерживать стандарт качества, которым можно гордиться. Все участники команды понимают, что качество важно для организации, но для себя команда устанавливает ещё более высокий стандарт, подчёркивающий индивидуальность команды. Без этого выделения группа остаётся просто группой, никогда не становясь настоящей командой.
    Теперь представьте, что в эту сложную смесь добавляется постер в рамке, сообщающий людям, что «Качество — задача номер один». Ух ты. Надо же, мы никогда бы не догадались. Как можно, сэр, мы ведь предполагали (пока не появился этот замечательный постер), что Качество — задача номер двадцать девять или, может быть, сто семнадцать, а может быть, и ещё ниже расположенная на шкале корпоративных ценностей, где-то между ковырянием в носу и сортировкой мусора. Но теперь-то мы знаем. Спасибо.
    Эти так называемые мотивирующие аксессуары (включая кружки для кофе со слоганами, плакаты в рамках, булавки, брелоки, награды) символизируют победу формы над смыслом. Они, казалось бы, превозносят важность Качества, Лидерства, Творчества, Командной работы, Преданности и целого ряда иных организационных достоинств. Но они делают это в настолько упрощённой форме, что в итоге смысл посланий совершенно видоизменяется: здешнее руководство полагает, что эти достоинства можно улучшить при помощи плакатов, а не посредством тяжёлого труда и талантливого управления. Каждому очень быстро становится ясно, что наличие плаката есть отчётливый признак отсутствия усердного труда и талантов.
    Оскорблением является уже то, что подобные вопросы становятся предметом мотивационных плакатов. А реализация идеи ещё подливает масла в огонь. Вот пример плаката, распространяемого одной компанией: нечёткое изображение потеющих гребцов, трудящихся в абсолютном унисоне ранним туманным утром. Под изображением надпись, содержащая в частности такие слова:

    К-О-М-А-Н-Д-Н-А-Я Р-А-Б-О-Т-А

    …Позволяет Простым Людям Достигать

    Непростых Результатов

    Вы и ваши коллеги — те самые «простые люди», о которых идёт речь. Простые люди. (Не принимайте слишком близко к сердцу.) По крайней мере, они последовательны в своём отношении: постер той же компании, посвящённый Лидерству, сообщает нам, что «лидер задаёт темп всей стае». Стае. Да, это тоже вы.
    Мотивирующие аксессуары настолько лживы, что у большинства людей от них мурашки по коже. В разумных организациях они наносят вред. И не наносят вреда только там, где их игнорируют, как, скажем, в компаниях, вред которым нанесён уже очень и очень давно, и люди, работающие в них, перестали замечать дальнейшее ухудшение ситуации.

    Сверхурочные: непредвиденный побочный эффект

    Возможно, вы заметили определённую неприязнь к сверхурочным в предыдущих главах книги. По нашему опыту положительные эффекты от сверхурочных слишком преувеличены, а на отрицательные почти никогда не обращают внимания. Отрицательное же влияние может быть серьёзным: ошибки, выгорание на работе, повышение текучки, компенсирующие недоработки. В этом разделе мы изучим ещё один отрицательный эффект сверхурочных: их вклад в травлю рабочих групп, вполне жизнеспособных во всех прочих отношениях.
    Представьте себе проект с командой, прошедшей качественную кристаллизацию. Вы и ваши коллеги делаете хорошую работу с откровенно удивительной скоростью, удивительной даже для начальства. Все вы понимаете, что это положительный эффект командной кристаллизации, что команда в целом более производительна, чем отдельные её участники по сумме результатов. Но этого все равно недостаточно. Сильные мира сего пообещали, что продукт будет готов в июне, но вам ни за что не успеть при этой скорости работы.
    Похоже, придётся добавить немного сверхурочных, да? Вы переводите команду в экстремальный режим, добавляете к рабочей неделе несколько часов (а скорость работы оставляете прежней), возможно, захватывая несколько суббот. Проблема здесь только одна: один из участников команды (назовём его Аллен) не обладает той гибкостью, что доступна всем остальным. Он вдовец, а значит, является главным опекуном своего маленького сына. Аллен должен каждый день в 17:15 забирать сына из детского сада. Как можно догадаться, его субботы и воскресенья — единственные дни, когда он может нормально пообщаться с сыном, и они неприкосновенны. Что ж, ладно, думаете вы, мы прикроем Аллена. Мы же понимаем.
    Вы все, и правда, понимаете… поначалу. Через несколько месяцев некоторые начинают проявлять напряжённость. Ваших суббот уже нет, как нет и большей части воскресений. Вы работаете минимум шестьдесят часов в неделю на протяжении слишком долгого времени, ваши супруги и дети ворчат. Нестираное бельё накапливается, за счета некому платить, ваши планы на отпуск пошли коту под хвост. Аллен при этом работает сорок часов в неделю. Наконец кто-то произносит вслух то, о чем думают все в команде: «Как же меня достало работать за Аллена».
    Что произошло? Команда, определённо купавшаяся в положительных эффектах кристаллизации, развалилась на части из-за политики сверхурочных, которую не удалось применить единообразно ко всем участникам проекта. Однако участники хороших команд разнятся в любом отношении, и уж конечно, не единообразны в своих возможностях «заимствования» времени из личной жизни. Практически в любой команде из четырех, пяти или шести человек обязательно найдутся люди, от которых нельзя ожидать, что они без всяких вопросов смогут работать сверхурочно столько же, сколько другие. От подобных доводов можно отмахнуться, если речь идёт лишь о нескольких вечерах и, быть может, одном из выходных дней. Но если сверхурочные растягиваются на месяцы и становятся невыносимыми даже для самых волевых участников команды, интеграция команды обязательно будет нарушена. Мало-помалу люди, не разделяющие общее напряжение, окажутся отчуждёнными от остальных. И магия команды закончится.
    В любом случае длительные сверхурочные есть метод сокращения производительности. Лишние часы работы почти всегда более чем компенсируются негативными побочными эффектами. Это верно, даже если не учитывать разрушение команды. Но если принять во внимание, что различные способности людей к сверхурочной работе разрушают команды, истина о сверхурочных становится очевидной.
    Большинство руководителей по меньшей мере подозревают, что сверхурочные не помогают, что проекты с большим числом сверхурочных часов свидетельствуют против квалификации и талантов руководителей этих проектов. Так почему же руководители разрешают или даже поощряют сверхурочный труд? Джерри Вейнберг (Jerry Weinberg) представил нечто вроде ответа: он предполагает, что мы работаем сверхурочно не для того, чтобы успеть сделать работу, но для того, чтобы оградить себя от обвинений, когда работа не будет сделана в установленные сроки[76].

    28. Конкуренция

    Конкуренция в пределах команды или рабочей группы — вопрос непростой, и руководители не имеют единого мнения на этот счёт. Вы наверняка слышали фразу, что компании существуют, чтобы конкурировать, из чего можно заключить, что некоторая конкуренция в пределах компании — разумный способ поддержать конкурентоспособность этой компании. Другие руководители подозревают неладное, если участникам команды кажется, что их пытаются стравить друг с другом. Определённо, в своих крайних проявлениях конкуренция препятствует кристаллизации. Если, к примеру, участникам команды сообщить, что на следующий год свои места сохранят только лучшие из них, можете быть уверены, что они не смогут успешно работать вместе.

    Рассмотрим аналогию

    Подобно руководителям, родителям иногда приходится сталкиваться с вопросом внутренней конкуренции. Они обнаруживают, что их дети соревнуются друг с другом. Иногда они пытаются убедить себя, что способность к конкуренции пригодится детям в суровых испытаниях взрослой жизни, так что, пожалуй, оттачивание подобных качеств в пределах семьи вполне допустимо.
    Но конкуренция между детьми одних родителей не очень желательна. К примеру, нам известно, что сильная конкуренция в детстве приводит в дальнейшем к дистанцированию, тогда как дети, в детстве ладившие, имеют больше шансов на тёплую дружбу в зрелой жизни. Вероятно, вы вспомните хотя бы один пример, когда дети из одной семьи «не общаются», повзрослев, или же такую крайность, как многодетную семью, в которой ни одна пара детей сходного возраста в зрелой жизни не сохранила никаких отношений.
    Сегодня уже вполне понятны способы, которыми родители поощряют конкуренцию между своими детьми или препятствуют ей. Конкуренции способствует недостаточное эмоциональное внимание к детям со стороны родителей, когда тем не хватает времени, уважения, внимания или любви на всех.
    И напротив, когда в юности и зрелости дети одной семьи во всем поддерживают друг друга, проявляют заботу друг о друге, получают определённое удовольствие от этой дружбы, можно догадаться, что их родители избрали правильный путь.
    Возможно ли, что внутренняя конкуренция в рабочих командах происходит от недостатка у руководителя времени, внимания, уважения и расположения к своим людям? Такое объяснение может показаться слишком простым, но мы считаем, что в нем заложено зерно важной истины.

    Нужно ли это? О важности обучения

    Каков в долгосрочной перспективе эффект чрезмерной конкуренции между людьми, вынужденными работать вместе? Одной из первых жертв становится простой и эффективный процесс обучения коллегами друг друга, процесс, столь часто происходящий в процветающих командах.
    Будучи руководителем, вы, возможно, убедили себя, что должны быть главным тренером команды или команд, находящихся в подчинении. Определённо, эта модель широко применялась в прошлом, когда в отраслях высоких технологий начальники являлись одновременно признанными специалистами в технологиях, которыми овладевали подчинённые. Но сегодня в типичной команде интеллектуальных работников существуют разнообразные направления специализации, и лишь некоторыми из этих направлений владеет начальник. Такой начальник обучает далеко не всех участников команды. А как же остальные? Мы все больше убеждаемся, что участники команды в большинстве случаев сами способны обучать друг друга.
    Наблюдая сплочённую команду в действии, можно увидеть выполняемый постоянно ритуал передачи знаний между коллегами. Участники команды разбиваются на пары. Один человек в паре выступает в роли ученика, другой — в роли учителя. Они меняются ролями время от времени: скажем, А натаскивает В по теме TCP/IP, а затем В рассказывает А о реализациях очередей сообщений. Когда процесс идёт легко, участники даже не замечают этого. Они могут даже не считать это обучением, для них это просто работа.
    Обучение, как его ни называй, — важный фактор успешного взаимодействия участников команды. Оно обеспечивает координацию, а также личный профессиональный рост для всех участников. Оно ещё и доставляет удовольствие. Мы вспоминаем такое обучение, почти как религиозный опыт. Мы чувствуем себя в долгу перед теми, кто учил нас, и с радостью расплачиваемся, обучая других.
    Ритуал обучения просто невозможен, если люди не чувствуют себя в безопасности. В атмосфере достаточно сильной конкуренции просто безумие позволить кому-то увидеть, что вас обучают. Ведь это будет очевидным свидетельством, что в определённой области у вас меньше знаний, чем у обучающего. Точно таким же безумием является и обучение другого человека, поскольку он в конечном итоге может воспользоваться вашей помощью, чтобы вас же и обойти.

    Снова и снова о травле команд

    Затруднение внутрикомандного обучения есть прямое следствие внутренней конкуренции. Поскольку обучение жизненно необходимо для процветания команды, все, что делает руководитель для повышения конкуренции в команде, можно считать травлей. Вот некоторые действия начальства, оказывающие чаще всего отравляющее воздействие на команду:
  • ежегодный пересмотр зарплаты или заслуг;
  • целеориентированное управление (management by objectives, MBO);
  • восхваление определённых сотрудников за выдающиеся достижения;
  • награды, призы и бонусы, связанные с производительностью;
  • измерения производительности практически в любой форме.
    Минутку, но разве это не те самые вещи, которые так много времени или даже большую его часть отнимают у руководителей? Как ни прискорбно, да. И все же эти действия с большой вероятностью оказывают отравляющее воздействие.
    У. Эдварде Деминг (W. Edwards Deming) в своей книге «Out of the Crisis» (Выход из кризиса) в 1982 году сформулировал столь популярные сегодня Четырнадцать идей. Среди оных под номером 12В скрыто одно соображение:
    Уничтожьте барьеры, лишающие руководителей и инженеров их права гордиться своим мастерством. Это означает [77] предание забвению рейтингов достижений и целеориентированного управления[78].
    С этим испытывают затруднения даже люди, считающие себя последователями Деминга. Черт возьми, что же нам делать вместо этого?
    Деминг говорит, что МВО и подобные стратегии — просто отговорки для руководителей. Используя примитивные посторонние стимуляторы для поднятия производительности, руководители избавляют себя от более сложных проблем, связанных с инвестициями, прямой личной мотивацией, вдумчивым формированием команд, удержанием персонала, непрерывным анализом и пересмотром рабочих процедур.
    Мы не делаем столь глобальных выводов и утверждаем следующее: любое действие, дифференцирующее награждение участников команды, вероятно, будет способствовать конкуренции. Руководителям следует предпринимать шаги для ослабления этого эффекта или противодействия ему.

    Перепутанные метафоры

    Мы прерываем трансляцию…

    ПУГАЮЩИМ ПРИЗНАНИЕМ АВТОРОВ

    На страницах этой книги мы упоминали и обсуждали спортивные команды в качестве метафоры, обозначающей хорошо скоординированную рабочую группу. И теперь мы вынуждены подчеркнуть своё растущее разочарование в этой метафоре.
    Сегодня нас больше всего беспокоит, что спортивные команды подразумевают конкуренцию. Футбольные, баскетбольные, бейсбольные команды состязаются в пределах своих лиг, но также пропагандируют достаточно сильную внутреннюю конкуренцию. Скажем, игроки «запасные» не должны испытывать ни малейшего желания конкурировать с основным составом. Да, конечно, они болеют за основной состав, но вряд ли они от чистого сердца желают ему выглядеть звёздной командой.
    В средней школе я был самым низкорослым членом нашей сборной баскетбольной команды. Я до сих пор помню парня, который должен был сфолить, чтобы меня выпустили на площадку. Его звали Даг Тиммер-ман. Он был чертовски одарённый игрок и почти никогда не фолил. Я любил его как брата, и все же…
    Т. Д.
    Мы все видели, как спортивные команды побеждают, несмотря на ошибки одного из участников. Мы также видели, как отдельные игроки замечательно себя чувствуют, в то время как их команда безнадёжно проигрывает. Таким образом, успех или поражение отдельного человека никак не связаны с успехом или неудачей группы в целом. Таков изъян ситуации, лишь обостряющий любую зарождающуюся тенденцию к конкуренции.
    Контрастирующий пример — хор или музыкальная группа, создающие практически идеальную связь между успехом или неудачей одного человека и успехом или неудачей всей группы. (Никто и никогда не поблагодарит вас за хорошее пение, если хор в целом пел отвратно.)
    Так что мы должны запоздало сообщить, что музыкальный ансамбль — более подходящая метафора для слаженной рабочей группы. Конечно, мы не единственные, кто использует слово «команда» для описания подобной группы. Здесь имеет значение не название — «команда», «ансамбль» или «гармоничная рабочая группа», — но осознание всеми участниками того факта, что успех отдельного человека неизменно связан с успехом коллектива в целом.

    29. Программы модернизации процессов

    Те замечательные ребята, что в восьмидесятых познакомили нас с Методологией с большой буквы М, без дела не сидели. Их последнее новшество — Движение За Улучшение Процессов, более современное, более всеобъемлющее, оно лучше, в нем больше лоска, оно ещё более амбициозно… но по сути это все то же старьё. Ваша локальная Программа Модернизации Процессов — все та же Методология, но переродившаяся. На этот раз подход «универсального размера» достиг апогея: один размер теперь подходит не только всем в вашей компании, он ещё и всем во всем мире. Способности вашей организации измеряются в контексте жёсткой модели. Чем точнее вы соответствуете модели, тем выше ваш балл. Чем выше, тем лучше. Самый высокий балл — лучше всего. Если бы все организации получали самые высокие баллы, они все были бы лучшими, и (так уж получается) выполняли бы свою работу абсолютно одинаково — лучшим способом. Лучший — он и в Африке лучший, тут нет разницы между веб-приложениями для Yahoo и подпрограммами учёта пенсий в Aetna. По крайней мере, в теории…

    Краткий исторический экскурс

    На случай, если последние пятнадцать лет вы прожили на другой планете, мы представляем новейшую хронологию усовершенствования процессов:
    1984: Министерство обороны США (U.S. Department of Defense, DoD) создаёт Институт программной инженерии (Software Engineering Institute, SEI) при Университете Карнеги-Меллон. На институт возлагается миссия «создания стандартов совершенства в разработке программного обеспечения».
    1987: SEI публикует первую пятиуровневую схему оценки «зрелости программного обеспечения».
    1988: Опубликована важнейшая работа Уоттса Хамфри (Watts Humphrey) «Characterizing the Software Process: A Maturity Framework» (Описание процесса разработки программного обеспечения: общая схема зрелости) в журнале IEEE Software за март 1988 года. Проведены и опубликованы первые оценки. Первые свидетельства о существовании СММ (Capability Maturity ModelSM — модели зрелости потенциала).
    1989: Создание групп разработки стандартов и первых организаций методологической поддержки. Публикация книги Хамфри «Managing the Software Process» (Управление процессом создания ПО).
    1990-е: Распространение СММ в Минобороны США и за пределами ведомства. Создание целевых уровней СММ во многих, если не во всех, крупных организациях, участвующих в разработке ПО.
    Ядром СММ является упорядоченное множество ключевых областей процесса (Key Process Areas, KPAs), каждую из которых характеризует определённый отраслевой опыт, связанный с уровнем СММ. Исходя из качества опыта в ключевых областях, шкала делится на пять уровней организационной «зрелости». Переход на уровень определяется не только количеством накопленного опыта, но также порядком накопления этого опыта (скажем, заслугой не является накопление опыта Уровня 4, если организация ещё не достигла Уровня 3).

    Парадокс модернизации процессов

    Стандарты — это хорошо. Слава Богу, у нас есть стандарты, ибо без них мы не могли бы вставить кассету Kodak в фотоаппарат Minolta, штепсель кофеварки не подходил бы к розетке на стене, сигнал, передаваемый местной радиостанцией, не был бы принят вашим приёмником, ваш новый телефонный аппарат не подошёл бы для работы с вашей телефонной компанией, компакт-диски не помещались бы в проигрыватель, факсы невозможно было бы разобрать, размеры одежды и обуви стали бы бессмысленными, новые покрышки не подходили бы к старым автомобилям, а сеть Интернет оставалась бы доступной лишь людям, которые её изобрели.
    Такие стандарты полезны, но следует отметить, что великий триумф стандартов в современном мире — это практически всегда успех стандартных интерфейсов. Стандарт на резьбу, на пальчиковую батарейку или кассету с плёнкой содержит много сведений о конечном продукте — о том, как он взаимодействует с другими частями, но ни слова о процессе создания этого продукта. Батарейка имеет тип АА, если отвечает стандарту соответствующего интерфейса (по форме, размеру, отказоустойчивости, электрическим характеристикам и т. д.), независимо от того, создана ли она под водой, роботами или обученными обезьянами. Из успеха стандартов на интерфейсы можно лишь с некоторой натяжкой делать вывод, что процессы тоже следует стандартизировать.
    И все же огромной привлекательностью обладает поиск идеального процесса. Работы Хамфри, Полка (Palk) и других представителей SEI вдумчивы, профессиональны, амбициозны и искренни:
    Когда мы с Тимом составляли сборник «Software State-of-the-Art: Selected Papers» (Современное программное обеспечение: избранные статьи), Dorset House, 1990, перед нами стояла задача отобрать наиболее значимые работы восьмидесятых. Работа Уоттса Хамфри «Characterizing the Software Process» была среди первых . В тот год в статье для «American Programmer» я задался целью выбрать лучшую из работ, вошедших в сборник. Без тени сомнения из тридцати одной статьи я выбрал статью Хамфри. Воздействие его работы в последующие годы, по моему мнению, подтвердило правильность такого выбора.
    Т. Д.
    Поиск идеальной практики или практики, подходящей на роль таковой, — предприятие полезное. Однако программы, предписывающие использование такой практики, — это нечто совершенно иное.
    Парадокс СММ в том, что модернизация процесса — дело хорошее, а вот программы модернизации плохи очень часто, если не всегда. Модернизацией процессов всегда занимаются люди компетентные: они гордятся достигнутым прогрессом, источником которого может быть лишь совершенствование в предметной области. Такого рода низкоуровневое улучшение процесса есть простейшая гигиена для любого интеллектуального труда, но формальная модернизация процесса переносит ответственность с отдельного человека на организацию. Индивидуум может стремиться к достижению, практике, пропаганде качественных навыков, а организация способна лишь наделять их законным статусом. Именно в придании статуса законности кроется опасность.
    Чтобы понять проблему такого подхода к модернизации процессов, необходимо отвлечься от проектов, успешно работающих одновременно с повышением уровня процесса, и обратить внимание на проекты, которые испытывают сложности.

    Это же выгодно

    Побеждают организации, которые создают продукты, имеющие наибольшую ценность для клиентов. Если организация создаёт продукты, вызывающие лишь зевоту, она проигрывает, даже если создание продуктов очень и очень эффективно. Если проект выполняется со сбоями, но при этом создаётся продукт, имеющий высокую привлекательность, то этот проект следует предпочесть проекту, эффективно создающему ерунду. Процесс ничего не стоит, если применяется в проектах, не достойных существования.
    Однажды я читал лекцию о конфликте выгоды и процесса в местном профессиональном обществе. После лекции руководитель отделения по разработке ПО рассказал мне о проекте, завершившемся ранее в том году. В ходе проекта разработчики добавили несколько новых транзакций в онлайновую систему заказов. При установке обновлённой системы они включили счётчики посещений, чтобы узнать, как часто используются новые возможности. Через полгода они сняли показатели счётчиков. Этот руководитель знал, во что обошлось компании создание программного комплекса, и потому смог сопоставить значения счётчика и стоимость и получить стоимость отдельной транзакции за эти шесть месяцев. Стоимость транзакции составила 53 000 долларов! Прибыль от каждого посещения измерялась, вероятно, копейками. Великая ирония в том, что речь идёт о СММ-организации второго уровня, которой через несколько месяцев предстояла оценка на предмет перехода на Уровень 3. Эх, будь они организацией Уровня 3 до начала этого проекта, смогли бы, наверное, сбавить стоимость до 45 000 долларов за транзакцию.
    Т. Д.
    Когда модернизация процесса становится самоцелью («Даёшь Уровень 3 к концу года!»), пугающие проекты откладываются на потом. К сожалению, именно эти пугающие проекты — вероятно, те самые, которые достойны осуществления.
    Все проекты, приносящие реальную выгоду, связаны и с реальными рисками. Именно проект, обладающий новизной, новаторскими или изобретательскими нотками, имеет шансы заполучить внимание и финансы покупателя. Возможно даже, что ваш самый знаменитый своим провалом проект — тот, что на год задержался, в три с половиной раза превысил оценочную стоимость, с трудом проходит системные испытания и все ещё требует присутствия инженеров с дефибрилляторами, чтобы дышать, — по-прежнему остаётся лучшим из проектов вашей организации за многие-многие годы.
    Один из сильнейших аргументов в пользу СММ — повышение качества и производительности с одновременным снижением рисков (табл. 29.1):
    Таблица 29.1. Модель СММ от SEI

    Эта таблица предполагает, что ту же работу можно на более высоких уровнях выполнять с меньшим риском. Но есть и другая интерпретация, которая нам кажется более корректной: организации в меньшей степени подвергают себя рискам в «зрелости». Организация, которой предстоит продемонстрировать увеличение уровня СММ, навряд ли станет искать настоящих испытаний.
    И раз уж об этом зашла речь, профессионализм в любом случае не является лекарством от рисков…

    Новый мировой рекорд во всех категориях

    Предположим, вы работаете в компании средних размеров, которая производит бизнес-приложения для массового рынка. Руководство корпорации полагает, что СММ придумали не в Питсбурге, что это слово Божие. Поэтому они пригласили представителей SEI, чтобы оценить уровень зрелости компании. Оценка завершена, и вас всех собрали в конференц-зале. Главный эксперт SEI вступает на подиум, чтобы объявить результаты исследования. В зале наступает тишина…
    «Дамы и господа, у нас есть удивительная новость. Мы завершили оценку и определили ваш уровень по пятиуровневой шкале СММ. Выяснилось, что ваша организация обладает… Уровнем 6! Да-да, Уровнем 6. Мы даже не знали, что такой уровень существует, до того как посетили вашу организацию. Это удивительный день для всех нас. Мы чувствуем себя так, словно открыли новый элемент периодической системы. Вы лучшая из известных человечеству организаций по созданию программного обеспечения. Спасибо, всего хорошего».
    Как, хорошая новость? Ну и что теперь с ней делать? Чем сильнее вера в осмысленность оценки, тем более вы склонны приниматься за более сложные задачи. Поднимать планку. Вы можете привлечь своих людей к работе над приложениями, которые более мелкие организации создать не способны. Если вы лучшая из известных человечеству организаций по созданию программного обеспечения, нет смысла давать людям работу, которую способен выполнить средней глупости человек. Лучше пусть конкуренты завидуют вашей способности решать самые сложные задачи. И если время от времени вы терпите поражение, что с того? Когда-то ведь будет и успех, и тогда это точно будет продукт, достойный организации Уровня 6. Если требуется делать рутинную работу, её исполнение можно и заказать. Существует множество просто компетентных организаций, способных делать простую работу.
    Поднятие планки означает увеличение рисков. Чем больше ваш опыт, тем большим рискам вы подвергаетесь. Глупо поступать иначе.
    Чем больше вы совершенствуете свои рабочие методы, тем сложнее будет работа. Это происходит по двум причинам: во-первых, совершенствуя методы, мы, как правило, перекладываем приземлённые задачи на машины (скажем, сегодня SQL-выражения могут генерироваться программами, а раньше этим занимались люди) или вовсе выносим за пределы проекта (так, изобретение электронных таблиц переложило огромный объём работы с разработчиков на деловых людей). Оставшиеся задачи имеют более высокую интеллектуальную насыщенность; они требуют более серьёзного опыта и умений. Настоящий прогресс в модернизации процесса приводит к увеличению потребности в более квалифицированных кадрах.
    Вторая причина: модернизированные методы позволяют вам приступать к решению более сложных задач. И вы берётесь за них… если не вмешается Тёмная сторона…

    Модернизация процессов: ведёт ли она к Тёмной стороне?[79]

    «Люк,[80] прислушайся к своему сердцу. Ты знаешь, сколь великие финансовые выгоды будут твоими, если ты перейдёшь на Уровень 4. (И помни, лишь Императору дозволено быть на Уровне 5.) Сметай преграды на своём пути, Люк. Перейди на Тёмную сторону… Вот план: мы будем давать ход лишь проектам, которые в точности повторяют прошлые. Мы будем работать только в хорошо знакомых областях. Мы создадим процесс, замечательно подходящий для этих идеальных ситуаций. Мы задокументируем все, что движется. Пангалактиче-ская Процесс-Полиция будет совершенно очарована нашей цельной реализацией идеально управляемого процесса разработки программ. Ты получишь обетованный гигантский бонус за модернизацию процесса разработки, и тогда нужно будет действовать быстро. Обналичь этот чек прежде, чем твоя организация отправится к праотцам». [81]
    Организации всего мира вынуждены карабкаться по лестнице СММ. В крайних случаях они изо всех сил стремятся заполучить Уровень+1 к завтрашнему дню, а не то… Это и есть Тёмная Сторона, ибо она соблазняет безопасным поведением и отсутствием риска и, следовательно, низкоприбыльными проектами.

    Великое противоречие модернизации процессов

    Вам нужна такая квалификация, какую только способна выдержать организация. И нужна она, чтобы приниматься за проекты с повышающимся риском. Ключевые области процесса, обозначенные SEI, будут полезны в накоплении опыта, поскольку определяют набор умений, стремиться к которому должен любой хороший руководитель проектов по разработке ПО. Сосредоточьтесь на умениях, необходимых для ключевых областей процесса (Key Process Areas, KPAs), но делайте все возможное, чтобы предотвратить официальный подсчёт баллов.
    Если ваша организация уже находится на Уровне 2 или более высоком, запомните следующее:

    Достойные проекты — это те, что перемещают вас ВНИЗ на целый уровень.

    Возможно, лишь эти проекты вы можете себе позволить.

    30. Как сделать перемены возможными

    Люди ненавидят перемены…
    дело в том, что люди ненавидят перемены…
    Я хочу убедиться, что вы меня поняли.
    Люди действительно ненавидят перемены.
    Очень сильно ненавидят.
    Стив Мак — Менамин ( Steve McMenamin )
    The Atlantic Systems Guild, Лондон (1996)
    Эти слова Стив произнёс перед аудиторией ИТ-руководителей, которых его мнение более чем обеспокоило. Поначалу им было удобно ему возражать: «Послушайте, мы ведь создаём системы, которые изменяют привычные людям способы работать и играть. Мы очень стараемся гарантировать, что эти изменения будут к лучшему. Мы объясняем, чем лучше новый способ, иногда даже используем для этого точную логику. С чего бы рациональный человек стал противиться переменам к лучшему?» Стив парировал: «Вы не понимаете. Прощу прощения, но люди действительно искренне ненавидят изменения. В этом-то и проблема: они отвергают любые перемены. Это потому, что они ненавидят перемены». И он привёл очень убедительные примеры. Мало-помалу смысл дошёл до аудитории, так что пришлось приглашать консультантов по кризисным вопросам.
    Мы должны поговорить об изменениях, потому что в них наш бизнес. Мы не просто строители систем, мы движущая сила перемен. Каждый раз, выпуская новую систему, мы принуждаем людей изменять привычные способы работы, иногда даже полностью изменяем смысл их работы. Мы требуем, чтобы они подчинялись переменам, и, кстати, наши организации точно так же требуют, чтобы подчинялись переменам мы. Новые технологии и давление сроков разработки принуждают нас изменять способы создания продуктов.

    А теперь послушаем другого знаменитого системного консультанта

    И следует учесть, нет занятия более сложного, более сомнительного в перспективе, более опасного, чем быть во главе новых порядков. Врагами тебе становятся все те, кому на руку прежние порядки, а робкими защитниками — все те, кто может получить выгоду от новых.
    Никколо Макиавелли «Государь» (1513) [82]
    Мы склонны считать, что Макиавелли был циником, но едва ли можно сомневаться, что он воображал себя реалистом. Он не хотел представить человечество в невыгодном свете, но лишь высказать голую правду, какой он её видел. Книгу «Государь» он написал в качестве учебника для юного Лоренцо Медичи, который вступал в права правления городом-государством Флоренция. (Семья Медичи построила закрытую воздушную дорожку над Арно, соединившую родовой замок с правительственным зданием, чтобы подстраховаться на случай покушения. Будете во Флоренции, обязательно взгляните на эту дорожку, она ещё сохранилась.) Целью книги было познакомить молодого наследного принца с реальностью, приятной и не очень.
    «Врагами тебе становятся все те, кому на руку прежние порядки, а робкими защитниками — все те, кто может получить выгоду от новых.» Обратите внимание, что уравнение изменений не сбалансировано. Вы рискуете нажить врагов из числа тех, кто овладел старыми способами — ведь вы вынуждаете их снова занять неудобное положение новичков — и получаете лишь малую поддержку от тех, кому перемены выгодны. Почему так? Почему проявляют малодушие те, кто получит больше всего пользы от перемен? Потому что люди ненавидят перемены. Когда мы ступаем на путь перемен, нет гарантий, что все получится. А неопределённость гораздо сильнее, чем потенциальные выгоды.
    В 1991-1993 годах я был председателем национальной конференции по методам разработки ПО, которая проводится во Флориде каждую весну. В первый год я произнёс вступительные слова и раздал участникам анкету с самыми разными вопросами по методам и инструментам, которые они применяют при разработке программного обеспечения. Среди них был и такой: «Какой метод или инструмент был принят к использованию в вашей организации, но не получил распространения?» Я собрал ответы, чтобы ближе к окончанию конференции сообщить участникам о результатах. Я принялся составлять перечень провалившихся методов и инструментов, но остановился, когда заметил один очень простой и ясный факт: проваливалось все, хотя бы по разу. Настоящая ирония была в том, что, зачитывая результаты, я поинтересовался, использует ли кто-либо перечисленные инструменты и методы на регулярной основе. И получил положительный ответ по каждой позиции. Все работает, и все терпит неудачу. В чем здесь дело?
    Т. Д.

    Классная идея, босс. Займусь немедленно.

    Пытаясь исследовать перемены, вы порой выслушиваете весьма разнообразные мнения. Джерри Джонсон (Jerry Johnson) из Института бизнеса Меннингера, предположил, что это разнообразие следует определённому шаблону, который он назвал «Спектром сопротивляемости переменам»:[83]

    Рис. 30.1. Спектр сопротивляемости переменам
    В этом спектре есть место для каждого человека, и определяется оно тем, как человек реагирует на перемены.
    Взгляните на этот спектр и спросите себя, кто из этих людей — ваши потенциальные враги, а кто — возможные союзники? Очевидно, активно противодействующие опасны, они будут искать способы вернуться к прежнему состоянию любой ценой. Вы можете заключить, что слепо преданные — хорошие ребята, а остальные просто нытики, и что слепо преданные станут союзниками, а остальных можно записать во враги.
    Джерри указывает, что подобный взгляд неверен. Так, мы должны осознавать опасность, которую представляют слепо преданные. Они, вероятно, достаточно безобидны и готовы следовать за любой модной идеей. Ими правит мода момента: «Надо перестать использовать этот бухгалтерский пакет, мы и сами не хуже можем сделать системку на базе интранет-сети с применением Java Без Кофеина. Стоп. Не надо без кофеина. Я только что видел на сайте Computing This Nanosecond рекламу Double-Java latte с пенистыми апплетами». Их поддержка улетучится столь же быстро, как появилась, потому что иначе они не смогут последовать за новой модой.
    Джонсон утверждает, что верующие, но способные оспорить — единственные разумные союзники любых перемен. Две крайности — слепо преданные и активно противодействующие — настоящие враги. Успех перемен будет зависеть от того, как вы сумеете справиться с верующими, способными подвергать перемены сомнению. Кстати сказать, не рассчитывайте на козыри логики: сохраняющие нейтралитет союзники типа бабушка-надвое-сказала никогда не поддадутся только на рациональное обсуждение того, почему новые способы лучше имеющихся. Вот фраза, которую можно повторять про себя, намереваясь предложить людям перемены:

    МАНТРА: Основная реакция на перемены не логическая, но эмоциональная.

    Как разработчики систем мы изолировали себя в мире спокойных, ровных, рациональных размышлений. Код или компилируется, или нет. Компилятор не испытывает за нас радости, как и не способен разозлиться. Возможно, поэтому мы склонны считать логику своим главным оружием разрешения диспутов.
    Вы можете представить себя за терпеливым объяснением собственному ребёнку: «Я знаю, что ты хочешь велосипед, но сейчас ведь не твой день рождения и не Рождество, а именно эти даты календаря позволяют тебе разумно ожидать подарка. Если ты накопил нужную сумму из денег на карманные расходы, то можешь купить велосипед сам.» И вас может раздражать не-очень-логичный-ответ вроде: «Но я хочу велосипед! Прямо сейчас хочу.»
    Когда мы логически аргументируем перемены, одним из подходов является перечисление преимуществ нового мира, избавляющих от недостатков старого. Но задумайтесь: кто способствовал образованию существующей ситуации? Кто хозяева способов, которые мы сейчас используем в работе? Могут ли эти люди принять за оскорбление попытки урезать текущий режим работы? Ещё как могут. Уильям Бриджес (William Bridges) в книге «Managing Transitions» (Управление развитием) советует никогда не принижать значение прежнего пути[84]. Вместо этого следует воспевать прежние достижения, чтобы способствовать переменам. К примеру:
    «Ребята, система CGS проработала четырнадцать лет. По нашим оценкам она идеально справилась более чем с миллионом взлётов и посадок. Аппаратная платформа технически устарела, а кроме того, появилась новая технология удалённого сканирования, преимуществами которой мы можем воспользоваться. Сейчас у нас есть шанс перепланировать и заново выстроить всю систему. Нам нужны вы и ваш опыт, накопленный за годы успешного использования CGS, чтобы этот проект удался».
    В целом, может быть, полезно напомнить людям, что любые улучшения подразумевают перемены:
    Неспособный изменяться никогда не станет лучше.
    Том Демарко (1997)

    Другая модель изменений

    Вот так большинство из нас думает об изменениях (рис. 30.2):

    Идея в таком (наивном) представлении — простое видение «лучшего способа» делать что-либо — напрямую меняет старое на новое. «Мы устойчиво работали в старом режиме, но тут на Харви нашло вдохновение, и мы переключились на новый, несомненно, более совершённый во всех отношениях способ вести дела». Если говорить честно, не может быть, чтобы все было так просто. И все совсем не так просто.
    Сопоставьте эту наивную модель изменений с подходом к изменениям, предложенным специалистом по семейной терапии, ныне покойной Вирджинией Сатир[85] (рис. 30.3).
    Изменение включает как минимум перечисленные стадии. Осмысленные изменения невозможны без двух промежуточных этапов.
    В модели Сатир изменение происходит в момент появления внешнего элемента — катализатора изменений. Без катализатора невозможно осознание необходимости изменений. Внешним элементом может быть внешняя сила или же осознание изменений вашего мира.

    Внешняя сила: Уоттс Хамфри появляется у вас в офисе и объявляет, что ваше производство находится на Уровне 0. Хмммм.
    или
    Мир меняется: Квартальные продажи вашего флагманского продукта впервые в истории упали. Ооой.
    Пытаясь инициировать изменения, вы столкнётесь прежде всего с Хаосом. Вы это уже проходили — убеждённость в том, что новый инструмент, новый метод, новый подход гораздо хуже, чем прежний. Люди говорят вещи вроде «Если бы только сбросить этот новый балласт, тогда мы, наверное, сможем догнать расписание…» Вы попадаете в провал на кривой обучения, и в этот момент оценка изменений как главного источника проблем может оказаться правильной. Все становится хуже, чем раньше. Отчасти по этой причине реакция на изменения столь эмоциональна. Необходимость оставить подходы и методы, которыми вы давно овладели, и снова стать новичком раздражает и приводит в замешательство. Вряд ли кому-то нравится это ощущение, будто барахтаешься: вы просто знаете, что прежние способы лучше. К сожалению, без перехода через Хаос никак не обойтись и «срезать» не получится.
    Преобразующая идея — спасительная соломинка, позволяющая людям в Хаосе надеяться на скорое избавление от страданий. Структурированная сумятица — зачастую лучшее лекарство: «Думаю, мы начинаем вживаться в программирование на C++, но как бы нам каждый день часа в четыре встречаться по поводу определения классов?»
    Фаза практики и интеграции находится на подъёме кривой обучения. Вы ещё не совсем освоились, поскольку не имеете достаточного опыта работы с новыми вещами, но соглашаетесь, что эти вещи начинают приносить пользу или по крайней мере дают подобную перспективу.
    Новый статус-кво достигается, когда то, что раньше считалось изменением, становится рутиной. Интересное свойство человеческих эмоций: чем больнее переход через Хаос, тем выше субъективная оценка нового статус-кво — конечно, если его удаётся достичь.
    Модель Сатир очень важна, потому что показывает, что Хаос есть неотъемлемая составляющая изменений. Используя более наивную двухступенчатую модель, мы не ожидаем хаоса. И когда он наступает, мы ошибочно принимаем его за новый статус кво. И раз новый статус кво кажется столь хаотичным, мы думаем: «Ой-ой, кажется, ошибочка вышла, давайте-ка вернёмся к прежнему варианту». Призыв к возврату обязательно будет услышан чётко и ясно посреди любых амбициозных перемен.
    Если же вы ожидаете хаоса, ваши шансы успешно его пережить значительно повышаются.

    Безопасность прежде всего

    Изменения не могут даже начаться, если люди не чувствуют себя в безопасности. А они чувствуют себя в безопасности, если знают, что не будут унижены или понижены в должности за то, что предложили перемены или попытались перемены пройти. Временная утрата мастерства достаточно сильно стесняет большинство из нас; стоит только в Хаосе появиться очагу паники, и все рванут под защиту прежнего статус-кво.
    Наша врождённая боязнь Хаоса помогает объяснить, почему изучать что-либо, будучи ребёнком, настолько проще, чем изучать то же, будучи взрослым.
    Наблюдая за взрослыми и детьми, впервые отправившимися покататься на лыжах, мы находимся под отчётливым впечатлением, что взрослые боятся не столько получить травму, сколько выставить себя дураками. Дети практически никогда о подобном не думают. Они скорее предпочтут упасть в снег, покататься в снегу, побросаться снегом, поесть его. (Нормальная реакция взрослого человека на снег: убрать лопатой, чтобы не упасть.) На склонах взрослые предпочитают не падать в пределах видимости своих подопечных. Предполагаемое унижение достаточно сильно, чтобы они вообще из гостиницы не выходили. Но дайте здоровому ребёнку урок или два с инструктором, и начинается «Смотрите, я Пикабо Стрит!»[86]
    Тим и Том, начинающие бихевиористы (1998)
    Сколько раз вы слышали, что какой-то новый метод будет применён потому, что это единственная возможность успеть к жёсткому сроку, и если к сроку не успеть, неприятностей не оберёшься? Первый этап перемен сразу же ставит под вопрос исход предприятия. Детскую склонность бросаться в потенциально опасные предприятия душит страх осмеяния.
    Как ни парадоксально, изменения могут быть успешными лишь в том случае, если неудача (хотя бы до некоторой степени) также допустима.

    31. Человеческий капитал

    Где-то неподалёку от вас прямо сейчас наверняка работает обогреватель или кондиционер. Атмосфера помещения изменяется для вашего комфорта при помощи электричества и, возможно, какого-то топлива. Энергия стоит денег. Вы (или ваша компания) ежемесячно оплачиваете счёт, в котором эти расходы проходят в графе коммунальных услуг. Предположим, что за март месяц вам насчитали сто долларов, что счёт оплачивает компания и что у компании за истёкший месяц иных финансовых транзакций не было: никаких доходов, никаких зарплат, вообще ничего. Только один счёт за коммунальные услуги. В конце месяца баланс организации выглядит как-то так (рис. 31.1):

    Здесь обозначены потери за месяц, поскольку расходы превысили поступления.
    В следующем месяце дела идут примерно так же. Снова нет доходов и зарплат. Однако на улице потеплело, и целый апрель вы открываете окна, не включая обогреватель. Так что за коммунальные услуги платить не нужно. Но один чек вы все же выписываете: вы купили наладонный компьютер и регистрируете покупку как «компьютерное оборудование», поскольку это самая подходящая из категорий расходов, предложенных вашим бухгалтерским приложением. В конце этого месяца баланс выглядит следующим образом (рис. 31.2):

    В прошлом месяце единственный чек на сто долларов в сочетании с отсутствием доходов дал отрицательный баланс. В этом месяце единственный чек на сто долларов в сочетании с отсутствием дохода даёт безубыточность. Откуда такая разница? Разницу можно объяснить лишь разными категориями расходов. В марте траты на коммунальные услуги попали в категорию расходов, в апреле траты на компьютерное оборудование получили совершенно иную интерпретацию. Ваш бухгалтерский пакет понял, что компьютерное оборудование — разновидность активов, вроде денег на другом банковском счёту. И потому посчитал чек переводом с одного банковского счета на другой. Этот перевод не оказал влияния на баланс.
    Расход — это деньги, которые исчезают в результате использования. В конце марта месяца нет ни денег, ни тепла (нет того, за что платятся деньги). С другой стороны, вложение — это использование средств для приобретения других средств. Ценный ресурс не был израсходован, мы лишь преобразовали его в иную форму. Когда вы считаете траты вложением, а не расходами, это называется капитализацией средств.

    Что касается людей

    Теперь поговорим о деньгах, которые компания тратит на людей. В бухгалтерии принято считать, что зарплаты — это расходы, но не вложение средств. Иногда это имеет смысл, но не всегда. Когда сотрудник создаёт продукт, который затем продаётся, не имеет значения, тратитесь вы на труд работника или производите вложение средств в его труд. В конечном итоге деньги, выплаченные работнику, вычитаются из цены продукта, что позволяет вычислить прибыль. Вряд ли вы станете приписывать его труд к затратам, точно так же, как не станете относить к ним обогрев завода. В конце месяца уже не будет ни труда, ни тепла.
    А теперь предположим, что вы отправили этого работника на семинар на неделю. Его зарплата и деньги за семинар потрачены на нечто, что не «исчезло» в конце месяца. То, что он узнал, останется в его голове на многие месяцы. Если вы с умом потратили деньги на обучение, то это вложение, и не исключено, что очень хорошее. Однако по принятой в бухгалтерии практике и это вложение попадёт в категорию расходов.

    Кому какое дело?

    Имеет значение не столько то, как счетоводы будут отчитываться о подобных вещах перед налоговой инспекцией или акционерами, сколько представление руководителей о реальных вложениях компании в сотрудников. Этот человеческий капитал может быть существенным, и ошибочное представление о подобных вложениях как о невосполнимых расходах может приводить руководителей к действиям, разрушающим ценные вложения организаций.
    Разумеется, подобные действия — основной элемент несовершенного руководства. Компании порой переживают времена, когда руководители среднего и высшего звена состязаются друг с другом в изощрённости способов повысить производительность в краткосрочной перспективе (квартальные прибыли), принося в жертву долгосрочную. Это обычно называют «балансовым сознанием», но мы предпочитаем другое название: «поедание посевных семян».
    Оценка вложений в человеческий капитал[87]
    Сколько ваша компания вложила в вас и ваших коллег? Простой способ оценить порядок сумм — представить, что случится, если уйдёт один из вас. Допустим, для примера, что Луиза, специалист по базам данных, объявляет о своём увольнении в конце этого месяца. До этого момента вы ощущали разумную уверенность в том, что ваша команда из пяти человек сможет сдать новую версию системы отслеживания продаж к следующему лету. Текущие задачи решались достаточно гладко, а сплочённая команда работала очень эффективно. До тех пор, пока Луиза не озвучила свою неожиданную новость. Кто знает, что теперь будет? Просто катастрофа. Вы звоните в отдел кадров и делитесь плохой новостью: «Луиза уходит тридцать первого числа» и спрашиваете с надеждой в голосе: «Можете найти мне другую Луизу?»
    К сожалению, отдел кадров не может быстро найти специалиста, обладающего нужными познаниями в данной области. «Может быть, подойдёт Ральф?» — предлагает собеседник. О Ральфе вы никогда не слышали раньше, как и все остальные участники команды, но, похоже, что иных вариантов не предвидится, и вы соглашаетесь. Дело сделано. Луиза уходит тридцать первого, а первого числа выходит Ральф.
    В каком-то смысле проект не испытал никаких потрясений. Тридцать первого числа в команде было пять человек, первого числа их снова пять. Если Ральф получает такую же зарплату, как Луиза, то компания продолжает с готовностью покупать ваши человеко-часы по той же цене, что и в прошлом месяце. И команда в этом месяце получит ровно пять человеко-месяцев, как если бы Луиза не уходила. Если в прошлом месяце опоздания для проекта не предвиделось, то и в этом все должно быть по расписанию. На что же вам теперь жаловаться?
    Что ж, посмотрим, как Ральф проводит первые дни в компании. Когда Луиза ушла, остался определённый объём работы, предназначавшийся для неё. Как много из этой работы успеет сделать Ральф за первый день? Ответ, понятное дело, — нисколько. Ничего он не сделает. Он весь день заполняет формы для страховок, учится заказывать обед, получать доступ к ресурсам, настраивает свою рабочую станцию и подключает компьютер к сети. Его общая производительность равна нулю. Да она может быть даже меньше нуля. Если он использует время других людей, — а вы знаете, что он это сделает, потому что ему нужны ответы на простые вопросы, — его вклад в производительность команды в этот день будет отрицательным.
    Ладно, все-таки первый день, а что во второй? Второй день немного лучше. Он полностью включился в работу, читает заметки, оставленные Луизой. Если бы Луиза осталась, ей не пришлось бы читать никакие заметки, потому что она все знала наизусть. (Ей не пришлось бы и писать эти заметки, не соберись она уходить.) Производительность Ральфа все ещё гораздо ниже, чем была бы производительность Луизы. Он по-прежнему может оказывать отрицательное влияние, поскольку ему, весьма вероятно, понадобится помощь других участников команды. Он будет тратить время, которое они в ином случае могли бы посвятить своим задачам.
    В конце концов, ваш новый сотрудник набрал полный ход и работает теперь примерно с той же скоростью, что и Луиза. Распределение производительности специалиста по базам данных по времени выглядит примерно так (рис. 31.3):
    Когда Луиза ушла, производительность получила удар. Она стала отрицательной на некоторое время, пока другие суетились в попытках компенсировать утрату хорошо прижившегося участника команды. Затем мало-помалу производительность снова поднялась до прежнего уровня.

    Заштрихованная площадь на графике представляет потери в работе (работу, которая не была сделана), связанные с уходом Луизы. Если взглянуть иначе, это вложения компании в Ральфа, в то, чтобы он достиг уровня Луизы с учётом прошлых вложений компании в её опыт и способности.
    Мы можем получить цифру в долларах, исходя из заштрихованной площади и того, какую зарплату получал Ральф, пока догонял Луизу. Если Ральф наберёт полный ход за шесть месяцев и при этом будет наращивать скорость линейно, то вложения примерно равны половине общего времени, то есть стоимости трех человеко-месяцев. Таким образом, цифра будет равна зарплате Ральфа плюс стоимость задержки проекта на три месяца.

    Какова длина взлётной полосы для опытного работника?

    Шесть месяцев на то, чтобы подняться от отрицательного вклада до уровня своего предшественника? Для нового разработчика приложений этот прогноз может оказаться разумным, но, вероятно, будет в корне неверен для человека, вступающего в команду с чуть более сложными рабочими задачами. Когда мы заставляем своих клиентов конкретизировать время разгона для новых сотрудников, большинству из них приходится допускать длину взлётной полосы, превышающую шесть месяцев. По оценке одного нашего клиента, создателя анализаторов сетевых протоколов и пакетов, разгон нового сотрудника занимает более двух лет. И эта фирма нанимает лишь людей, которые уверенно владеют базовыми технологиями, так что два года занимает изучение предметной области и врастание в команду. Общая сумма вложений для каждого нового сотрудника, таким образом, составляет чуть больше 150 000 долларов.
    Предположим теперь, что наступило очередное сокращение, и компания должна задуматься, не уволить ли такого человека. Конечно, постоянных расходов на зарплату и иных накладных расходов в таком случае не будет, но 150 000 долларов инвестиций компания потеряет. Если компания примет во внимание этот факт, она, возможно, поймёт, что не может позволить себе потерять столь ценный ресурс.

    Под дудку Уолл-стрит

    За годы увольнений, сокращений, понижений, уменьшений, определения нужных размеров и ужиманий Уолл-стрит только и делала, что аплодировала каждому такому действию, словно отступление и есть цель бизнеса. Обратите внимание, что это не настоящая цель:

    Цель манёвров — рост, а не сокращение.

    Компании, проводящие сокращения, открыто признают, что их высшее руководство потерпело неудачу.
    Но Уолл-стрит все равно аплодирует. Почему? Отчасти потому, что сокращения положительно отражаются на балансе. Если уволить несколько тысяч человек, каждый заработанный ими цент идёт в плюс баланса — или, по крайней мере, всем кажется, что это так. При этом удобно забывать о вложениях в этих людей — настоящих, тяжело заработанных долларах, которые теперь выбрасываются из окна, словно ничего не стоят.
    Вероятно, нет надежды, что Уолл-стрит изменит свои взгляды и перестанет считать вложения в людей расходами. Но в долгосрочной перспективе компании, придерживающиеся такой политики, обязательно пострадают. Обратное также верно: компании, разумно распоряжающиеся своими вложениями, в долгосрочной перспективе добьются процветания. Предприятия интеллектуальной сферы должны осознать, что именно вложения в человеческий капитал важнее всего. Хорошие компании давно это поняли.

    32. Обучение организаций

    Некоторые организации способны учиться, а некоторые нет. Одни могут усвоить урок в теории, но не могут измениться, чтобы воспользоваться преимуществами новых познаний. Другие могут учиться, но скорость их обучения компенсируется скоростью потери приобретённых знаний. Все мы понимаем, что жизненно важно быть среди способных к обучению, а не среди неспособных, потому что невозможно долго процветать без обучения, важнейшего механизма эволюции.

    Опыт и обучение

    Первое, что следует осознать, говоря об обучении организаций, — что это не простое накопление опыта. Для примера, к тридцатым годам французская армия имела сотни лет опыта охраны восточных границ, но все-таки предложила Линию Мажино как способ сдерживать немцев. Это решение и события мая 1940 года показали миру, что французы не выучили главный урок о динамическом балансе между защищённостью и мобильностью.
    Аналогично организации, имеющие отношение к высоким технологиям, могут накапливать опыт с потрясающей скоростью, но нет гарантий, что их познания будут соответствовать моменту.
    Один из моих клиентов очень давно участвует в разработке программного обеспечения, опыт его компании превышает тридцать лет. Большую часть времени тысяча или более разработчиков компании непрерывно были заняты. Так что компания может без преувеличения похвастать, что имеет более тридцати тысяч человеко-лет опыта разработки программного— обеспечения. Лично на меня это произвело впечатление: представьте, что все выученные уроки можно использовать в любом новом проекте. И я спросил у представителей компании:
    «Когда вы назначаете нового руководителя на новый проект, какие мудрые слова шепчете ему или ей на ухо?» Они немного подумали и практически хором ответили: «Удачи».
    Т. Д.
    Опыт превращается в знания, если организация меняется ради фиксации уроков, приобретённых с опытом. Это изменение имеет два вида, и виды эти достаточно различаются, чтобы обсуждать их раздельно:
  • Организация прививает своим людям новые умения и подходы
    или
  • Организация перестраивается и начинает работать в другом стиле
    В первом случае изменение является прямым следствием дополнительных вложений в человеческий капитал (более подробно об этом сказано в главе 31). Если переобученные люди уходят, вложения теряются, как и полученные знания. Во втором случае изменения изначально происходят в головах тех, кто должен эти изменения внедрять. В конечном итоге эти знания становятся общими для целой организации, но до того существуют только в головах участников изменений. В данном случае потеря ключевых людей в переходный период может угрожать обучению.
    В любом случае организации, решившейся на преобразование, приходится столкнуться со следующим неизбежным риском:

    Обучение ограничено способностью организации сохранять своих людей.

    При высокой текучести кадров обучение не даёт результатов или вовсе не происходит. В таких организациях попытки изменить навыки работников или внедрить новые процедуры оказываются бесполезными упражнениями. Более того, они могут оказывать вредное воздействие, повышая текучесть кадров.

    Пример перестройки

    Некоторые из наиболее захватывающих историй обучения организаций содержат информацию о перестройке иерархии поставщиков. Это требует уверенного руководства и желания выйти за границы организации. Вот пример, основанный на предложении Николаса Негропонте:[88]
    Компания вроде Amazon.com неразрывно связана с корпоративным партнёром, выбранным для доставки продуктов конечному потребителю. В нынешнем варианте компания, допустим, работает со службой FedEx, которая забирает книги со склада, скажем, в Сиэтле, перевозит их в Мемфис (центр деятельности FedEx), а затем в аэропорты, наиболее близкие к покупателям. Теперь предположим, что Amazon переводит свой склад на поле, расположенное рядом со взлётной полосой FedEx в Мемфисе. Продажу каждой книги по-прежнему будут обрабатывать в штаб-квартире Amazon, но список позиций и информация о доставке будет передаваться цифровым способом в Мемфис, где теперь собираются заказы. Преимущества для Amazon: уменьшается вдвое расстояние доставки для каждого заказа. Можно предположить, что теперь имеет смысл начать переговоры с FedEx, чтобы сократить цены на доставку и уменьшить стоимость передачи продуктов покупателям.
    Организации, способные на такие изменения, могут делать это снова и снова. Вас может заинтересовать, откуда у них такая гибкость.

    Главный вопрос про обучение организаций

    Главный вопрос про обучение организаций — не как оно происходит, но где. Когда организация изменяется до степени, предложенной в примере с компанией Amazon.com, должен существовать маленький, но бойкий центр обучения, который порождает, проектирует, направляет изменения. (Такого рода амбициозные перемены не могут быть изобретены комитетом или организацией в целом.) Очаг ранней активности — обучения — должен быть отмечен на карте организации. Где?
    Заманчиво сказать, что это место на вершине. Но по нашему опыту вершины организаций не так сильно сосредоточены на каждодневной работе. Президенты крупных и средних компаний, скажем, могут тратить большую часть своего времени на поглощение других компаний (или на противодействие возможному поглощению их собственных).
    В идее, что центр обучения может располагаться внизу иерархии, есть приятные отзвуки всеобщего равенства. Но не рассчитывайте, что это случится в реальном мире. Люди внизу, как правило, слишком ограничены организацией и могут в упор не видеть важные возможности. В любом случае они редко обладают необходимой властью.
    Если ключевое обучение не происходит ни на вершине, ни внизу, оно должно происходить где-то посередине. Это означает, что в большинстве организаций центр обучения наиболее естественным образом возникает на уровне среднего менеджмента — института с сильно испорченной репутацией. Это хорошо согласуется с нашим наблюдением, что успешно обучающимся организациям всегда свойственно наличие сильных руководителей среднего звена.
    Полезно отметить, что сокращения, когда таковые происходят, почти всегда направлены на средний менеджмент. Иными словами, общеизвестное действо «уменьшения расходов», происходящее каждые несколько лет, часто осуществляется за счёт способностей организации к обучению. После таких экспериментов центр обучения организации может оказаться уничтоженным.

    Команда руководителей

    Разглаживание иерархии организации путём уничтожения среднего звена — отличный рецепт для снижения уровня обучения. Но обратное не обязательно верно: само по себе бережное отношение к руководителям среднего звена не делает обучение более качественным. Есть другой ингредиент, решающий такую задачу, и его редко качественно оценивают и практически никогда не культивируют. Чтобы сформировался жизнеспособный центр обучения, руководители среднего звена должны общаться друг с другом, учиться работать совместно в производительной гармонии. Это исключительно редкое явление.
    Практически в каждой компании есть нечто, что компания называет Командой Руководителей, и такая команда обычно состоит из равных руководителей среднего звена. Как мы ранее говорили, недостаточно назвать группу командой, чтобы она начала проявлять свойства команды. Это по-прежнему будет разобщённый коллектив индивидуумов, не имеющих общих целей, общих ценностей или сочетающихся умений. Обычно это верно для большинства так называемых команд руководителей.
    «Команда» руководителей находится под воздействием хорошей дозы отравы, о которой мы говорили в главах 20 и 27: участники группы вынуждены занимать оборонительные позиции, их гнетёт бюрократия, их задачи фрагментируются, их физически разделяют, заставляют работать сверхурочно и втравливают в конкуренцию друг с другом. При подобном отношении маловероятно, что они объединятся в осмысленное целое.
    Хуже того, у них нет той главной вещи, необходимой для кристаллизации любой команды: общего владения результатами работы. Любые достижения такой группы, вероятнее всего, будут достижениями одного из участников, а не группы в целом. Чем больше руководители увязли в конкуренции, тем более выражен этот эффект. Нам встречались и крайние случаи с правилом «Если увидишь что-то хорошее, хватай; не можешь схватить, убей».
    Команда руководителей — это по большей части некорректное употребление термина, насмешка над тем поведением и отношением, которое присуще настоящей команде. Участники часто встречаются на планёрках, по очереди говорят со своим руководителем. Но у них мало общего.

    Опасность пустого пространства

    Наиболее вероятным центром обучения для любой организации значительных размеров является пустое пространство между руководителями среднего звена. Если это пространство становится серьёзным каналом связи, если руководители начинают действовать вместе и перестраивать организацию, если в результате образуется общий интерес, это делает возможными выгоды обучения. Но с другой стороны, если в пустых пространствах отсутствует всякая связь и общая цель, обучение останавливается (рис. 32.1). Организациям, в которых руководители среднего звена изолированы, выстроены в боевом порядке и испытывают страх, в этом отношении ничего не светит.

    Руководители среднего звена изолированы, запуганы и вынуждены строиться в боевые порядки — звучит знакомо? К сожалению, такова ситуация в большинстве современных организаций, работающих со знаниями. Многие руководители среднего звена говорят, что не склонны объединяться с коллегами, но побаиваются их. Наша коллега Сюзанна Робертсон называет это «опасностью на пустом пространстве». Такое разрушительное напряжение — просто похоронный звон для обучения организации.

    33. Самый страшный грех в руководстве — это…

    Самый страшный грех руководителя — впустую тратить чужое время. Судя по формулировке, легко избежать такого греха, но не на практике. У вас как руководителя есть собственные потребности, и эти потребности могут противоречить вашему намерению сохранять и мудро расходовать время своих подчинённых.

    К примеру

    Вы созываете собрание своих подчинённых, но сами опаздываете (вам пришлось ответить на срочный звонок собственного начальника), так что остальным приходится терпеливо дожидаться. Вы позволяете себе покинуть собрание для кратких, но важных переговоров с клиентом, и без вас собрание теряет фокус. Может даже быть, что и само собрание — пустая трата времени для всех (кроме вас, возможно). Занимаясь консультированием, мы часто оказываемся на собраниях, которые по всем внешним признакам должны служить какой-то рабочей цели, но на практике нужны для чего-то совсем иного:
    В начале собрания несколько минут заняла шутливая болтовня — начальник, Амброуз, отпускал добродушные комментарии в адрес каждого из присутствующих. Каждый попадался на удочку и отвечал таким же беззаботным юморным уколом. Затем наступил резкий перепад в настроении, когда Амброуз взял собрание под контроль. Один за другим, кратко и эффективно разбирались рабочие вопросы. Каждый вопрос обсуждался с одним или несколькими участниками. С каждым человеком происходил краткий диалог, каждый рассказывал о состоянии дел, чтобы Амброуз мог понять, какой прогресс достигнут за неделю. В ходе собрания участники получили примерно поровну времени своего босса, и при этом каждый диалог вёлся двумя людьми, в то время как все остальные молча слушали. Во время выступления Элен я заметил, что Роджер отвлёкся, очевидно, планируя, что ему говорить, когда до него дойдёт очередь. В конце собрания Амброуз установил приоритеты для каждого участника. Что же не так в этой до боли знакомой картине? На мой взгляд, то ощущение, что это вовсе не собрание; это церемония.
    Т. Д.
    Когда вы созываете собрание на N человек, нормально предположить, что все присутствующие находятся в конференц-зале потому, что они должны взаимодействовать друг с другом, чтобы придти к определённым заключениям. Когда же вместо этого участники собрания взаимодействуют лишь с одной ключевой фигурой, причём по очереди, отсутствует понимание необходимости такого собрания; начальник с равным успехом мог бы пообщаться отдельно с каждым подчинённым, не обязывая других слушать.
    В начале мы говорили, что ваша потребность — потребность начальника — удовлетворяется, возможно, за счёт времени некоторых из подчинённых. Это же в порядке вещей? Ведь именно этим занимаются начальники, чтобы владеть ситуацией? Разве это не законная стоимость управления, координирования сложных предприятий? И да, и нет. Собрание не требуется, чтобы получить информацию о состоянии дел, существует много более экономных способов сделать это. Мы наблюдаем удовлетворение потребности начальника не в информации, но в перестраховке. Оно даёт понять, что начальник есть начальник, он или она управляет собранием, явка обязательна, иерархия соблюдена.

    Собрания, посвящённые положению дел, нужны, чтобы подчёркивать положение

    Настоящее рабочее собрание созывается, когда есть реальная потребность в совместном обдумывании некоторых вопросов всеми собравшимися. Смысл собрания в том, чтобы достичь общего мнения. Такое собрание — почти по определению событие спонтанное. Спонтанность предполагает, что это собрание отсутствует в расписании. Любые регулярные сборища, таким образом, попадают под подозрение, что имеют своей целью церемонии, а не достижение консенсуса. Очевидный пример — еженедельные собрания, посвящённые положению дел. И хотя их целью, вроде бы, является доклад о положении дел, настоящий смысл таких собраний в подтверждении положения. И речь не о состоянии работы, а о статусе начальника.
    Организации нуждаются в церемониях. Абсолютно разумно созывать собрания со строго церемониальными целями, особенно на промежуточных проектных финишах, когда приходят новые люди или же чтобы отметить хорошую работу группы. Такие собрания не тратят впустую ничьё время. Они отвечают на реально существующую потребность в признании. Они закрепляют членство в группе — его важность и ценность. Однако церемониальные собрания, закрепляющие лишь начальственность начальника, — пустая трата времени.
    Когда начальники нуждаются в этом особенно сильно, гнёт подобных собраний может расти практически безгранично. Скажем, нам известна организация, где нормой являются ежедневные двухчасовые собрания. Если участники в момент, когда происходит собрание, работают вне офиса, они должны позвонить и участвовать в собрании по громкой связи все два часа. Неявка считается серьёзным проступком и карается серьёзными штрафами.

    Преждевременный набор

    Собрания — не единственный способ впустую тратить чужое время. Когда персонал включают в проект слишком рано, в самом начале, время сотрудников практически всегда тратится впустую. Опять же можно считать, что этого греха легко избежать: просто вычислим, насколько быстро работа займёт новых людей, затем будем нанимать людей с уже известной скоростью. И хотя это кажется абсолютно разумным, политически такое решение часто невозможно.
    Проекты начинаются с планирования и проектирования, и на этой стадии наиболее эффективны маленькие команды. Когда важно проектирование (а так оно и есть для всех проектов кроме примитивных), оно может занимать до половины всего времени проекта. Это позволяет предложить идеальный план набора людей, иллюстрируемый рис. 33.1:
    Если проект рассчитан на два года, то большая часть персонала не поднимется на борт, пока не пройдёт от шести месяцев до года. Ну и что? План набора выглядит немного необычно, но если нужна именно такая динамика, почему нет?

    Проблема становится очевидной, когда проект ограничен временем — что можно сказать о любом проекте. Если клиент и высшее руководство постановили, скажем, что работа должна быть сделана за год, это отсекает большую часть запланированной работы по проекту (рис. 33.2):

    Существует естественное стремление компенсировать потерянное время в самом начале. Ну вот, мы получаем проект в знакомом стиле преждевременного набора (рис. 33.3):

    Разумеется, знай вы, что усилия, приложенные раньше необходимости, окажутся потерянными, вы бы не стали этого делать, правда? Возможно, что все равно стали бы. Вы можете сделать вывод, что шансы успеть к столь жёстким срокам, независимо от динамики набора людей, практически равны нулю. И если вам все равно придётся опоздать, то лучше прямо сейчас подумать, как вы будете выглядеть в случае, если пренебрежёте ранним набором, а руководство решит сократить сроки. Даже если ранний набор окажется пустой тратой ресурсов, ваше политическое положение в конечном итоге будет более приятным, чем если бы вы первые шесть месяцев работали с ограничениями в персонале. Ранний же недо-набор, а на него непременно обратит внимание разочарованное командование, может сделать вас участником Малой лиги[89].
    Насколько часто проекты включают преждевременный набор по политическим причинам? О, не очень часто. Вероятно, не более чем 90% всех проектов страдают от преждевременного набора.
    Не в лучшем свете выступает доминирующая культура в организациях, занятых разработкой: несмотря на все разговоры об умеренности, руководитель подвергается политическому риску, управляя проектом с умеренной динамикой набора персонала, основанной на анализе потребностей и проектных спецификациях[90].

    Снова дробление

    Когда время уходит впустую вследствие ненужных собраний и преждевременного набора, люди знают об этом. Их раздражение объяснимо. Если подобных потерь много, они, вероятно, проинформируют и вас. Так что эти проблемы, пусть и серьёзные, по крайней мере видимы. Однако существует ещё один способ впустую тратить чужое время, и часто он проходит незамеченным, а потому не подлежит коррекции. Он связан с дроблением времени, которое мы упоминали в разговоре о травле команд в главе 20. Идея в том, что дробление времени работника интеллектуальной сферы на многочисленных задачах гарантирует, что ему или ей придётся участвовать в двух или более различных рабочих группах, ни одна из которых не имеет хороших шансов на кристаллизацию в настоящую команду.
    Дробление времени практически наверняка отравляет команду, но имеет ещё и другой коварный эффект: время человека всегда тратится впустую. Сотрудник, у которого множество заданий (немного новых разработок, поддержка устаревшего продукта, поддержка продаж, а может быть, ещё и поддержка пользователей), затрачивает значительную часть рабочего дня на переключение. Это время в большой степени невидимо. Работник откладывает задачу по проектированию, чтобы ответить на телефонный звонок, работает с позвонившим двадцать минут, рассказывая о том, как перенастроить базу данных в одном из ранних продуктов компании, а затем возвращается к проектированию. Если постоять рядом с этим человеком с секундомером, вы навряд ли заметите потерянное время. Потери скрыты в медленном возврате к проектированию, они являются прямым результатом прерванного потока.
    Дробление особенно вредоносно, когда две задачи требуют качественно различных рабочих привычек. Так, смешивание проектирования (требующего много времени на погружение, относительной тишины и качественного времени взаимодействия с небольшой группой людей) с задачей поддержки по телефону (требующей постоянного прерывания, постоянной доступности, быстрой смены фокуса) гарантированно минимизирует ход работы над той из задач, которая требует большего сосредоточения. Время, впустую затрачиваемое на попытки включиться обратно в работу, можно оценить лишь по раздражительности работника. Вы можете никогда не услышать об этой проблеме, потому что столкнувшиеся с ней люди с большой степенью вероятности будут винить только себя самих.

    Уважайте свои вложения

    По какой-то причине моё консультирование в последние несколько лет требовало все более частых поездок в Европу. Я начал летать дневными рейсами из Бостона в Лондон, потому что казалось, что они не так нагружают мой постоянно сбитый с суточного ритма организм. К сожалению, в большинство других европейских столиц из Бостона можно летать только ночными рейсами. Я жаловался на это до тех пор, пока один служащий авиалинии не указал мне вежливо, что его компания неохотно соглашается на простой гигантских инвестиций, каковые представляет собой Боинг 747, только для того, чтобы скоординировать дневные рейсы с востока на запад с дневными же рейсами с запада на восток. В конце концов, 747-й — это ведь куча денег.
    Т. Д.
    Человеческий капитал, вложенный в вашу рабочую силу, также воплощает в себе кучу денег. Если в вашей компании несколько тысяч работников интеллектуальной сферы, размеры вложений в этих людей уже легко могли составить стоимость современного широкофюзеляжного самолёта. Впустую тратить время этих огромных вложений — все равно, что бросать деньги на ветер.

    34. Создание общины

    В этой последней главе мы обратимся к тому, в чем преуспевают лучшие руководители: к созданию общины. Потребность в сообществе входит в фирменное «программное обеспечение» человеческой натуры:
    Когда я учился в школе, моя семья переезжала практически каждый год, и мне редко удавалось закончить учебный год в том городе, где я его начинал. Почти с такой же частотой полностью менялся состав моих друзей, знакомых, учителей. Одной из стабильных вещей были базовые книги для чтения, бывшие в те годы в ходу в школах Новой Англии. Эти книги читали ученики в каждой из моих школ. В них рассказывалось о семье, проживавшей в городке винчестер, и начиналось повествование 1770 годом. Каждый год ученики проходили следующее поколение семьи и к шестому классу уже успевали закончить про Революцию и начало двадцатого века. Персонажи этой семьи давно и прочно забыты, но я сохранил живую память о городке, винчестер был местом, где все друг друга знали, где семьи жили на протяжении многих поколений, где потерянная собака или попавший в беду ребёнок становились общей заботой и где в минуты бедствий соседи помогали друг другу. Думаю, если у меня есть какие-то корни, они в Уинчестере.
    Т. Д.
    Если в глубине вашей души что-то откликается на мысль о таком городке, это, вероятно, потому, что вы не живёте в нем. Прекрасные маленькие уинчестеры всего мира начали меняться и исчезать в двадцатые годы двадцатого века. Большинству из нас сегодня приходится жить в местах, в которых нет общинных укладов. Люди не очень хорошо знают соседей, ездят на работу в другие места, и никто не ожидает, что дети осядут в том же городе. В частности, в спальных районах нет никакого намёка на общину, это одни только спальные места.
    Но мы по-прежнему испытываем сильную потребность в общине. Реальность нашего времени в том, что большинство городов не может удовлетворить эту потребность. Вместо них наибольшие шансы найти свою общину предоставляет нам рабочее место. Если предоставляет…

    Отступление от корпоративной политики

    Община не появляется на работе сама собой. Её необходимо создать. Люди, создающие общины, — это невоспетые герои в эпосе наших рабочих будней.
    Наука создания общин, жизнеспособных и привлекательных для каждого, называется политикой. Поспешим добавить, что речь пойдёт не о бесстыдных уловках корпоративной конкуренции — это патологии политики. Вместо этого мы обратим взор на «благородную науку Политику», как она изначально была описана Аристотелем.
    Аристотель включил Политику в число пяти благородных наук, составляющих Философию. Перечислим эти пять наук:
  • Метафизика: изучает сущее, природу Вселенной и всего её содержимого.
  • Логика: изучает пути познания, выводы, которые можно делать на основе восприятия, а также некоторые разумные правила вывода и умозаключений.
  • Этика: то, что мы знаем о человеке и что можем посредством Логики понять о приемлемых взаимодействиях между парами индивидуумов.
  • Политика: как мы можем логически распространить Этику на более крупные группы. Политика изучает создание и управление такими группами в контексте этического поведения и логического осознания метафизических сущностей человека и общины, состоящей из людей.
  • Эстетика: восприятие символов и образов метафизической реальности, которые приятны настолько, насколько логически последовательны и способны указывать нам на этические взаимодействия и/или политическую гармонию.
    Вы можете наотрез отказываться от любых проявлений низкой офисной политики, но Политика Аристотеля совершенно иная. Аристотелева Политика — ключевой элемент хорошего менеджмента. Отказ от политики в смысле, предложенном Аристотелем, ведёт к катастрофе; это отречение от действительной ответственности руководителя. Аналогичным образом старшие сотрудники на всех уровнях разделяют некоторую ответственность за создание общины. Они старейшины общины, если таковая формируется.

    Почему это важно

    Организация, преуспевшая в создании достойной общины, сохраняет своих людей. Когда чувство общины достаточно сильно, никто не хочет уходить. Вложения в человеческий капитал сохраняются, а высшее руководство обнаруживает, что склонно увеличивать вложения. Когда компания увеличивает вложения в людей, люди работают лучше, лучше относятся к себе и компании. Это ещё больше снижает вероятность, что они уйдут. Закрепление положительных эффектов идёт исключительно на пользу.
    Разумеется, даже лучшее чувство общины-на-работе не гарантирует, что вы сохраните всех своих людей навсегда. Некоторые поймут, что им пора уходить, чтобы продолжить карьеру или по иным причинам. Однако когда люди уходят из такой организации, они выбирают время таким образом, чтобы минимизировать неудобства для общины. Это великое благо для всех, кто занят в проектной работе, потому что сотрудники не уходят посреди проекта. Один лишь этот эффект стоит больше, чем любая модернизация процессов, которую может предпринять ваша организация в ближайшие десять лет.
    До сих пор мы обсуждали лишь осязаемые выгоды, исчисляемые в долларах и центах. Но здесь действует и неосязаемое, нечто, что для вас должно иметь большее значение, чем все остальное. Чтобы понять, что это, загляните всего на секунду в отдалённое будущее, в тот день, когда вы будете близки к кончине. Вы на смертном одре в почтённом возрасте, скажем, ста одного года. Вы не испытываете дискомфорта, всего лишь старость. В этом возрасте все ваши мысли обращены в прошлое. Вы подводите итоги. И спрашиваете себя: что было важным в моей жизни, а что не имело значения? Неудивительно, прямо скажем, что многие ваши заботы, сводившие вас с ума много лет назад (скажем, стабилизация ужасной под-версии 27 продукта WhizBang v6.1.1), не слишком весомы в предсмертной оценке. Нет, с гораздо большей вероятностью вы будете думать о тёплых семейных отношениях, детях и внуках, о доме и воспоминаниях, связанных с ним. Какие-нибудь вещи, имеющие отношение к вашей работе? Да, конечно, было приятно способствовать достижению Информационной Эры зрелости. Было приятно подниматься к вершине компании, практически до предела возможного, и получить свой шанс указывать направления. Было мило. Но не забывайте, что вам также удалось создать настоящую общину внутри этой компании, которую люди любили и уважали и которой были преданы. Вот это действительно достижение. И оно должно отчётливо фигурировать в списке главных достижений вашей жизни. Такое удовольствие — возможно, подобное тому, какое испытывал Микеланджело, когда размышлял о сделанном им — не должно быть как-то связано с материальной ценностью достижения. Потому что это было творение. Это было Искусство, скажете вы себе, и человек, благодаря которому это стало возможным, — Мастер своего Дела.

    Обуздание волшебства

    Ладно, пусть община — хорошо, и построить общину на рабочем месте — превосходная цель. Как это делается?
    Мы не берём на себя смелость утверждать, что существует формула для столь сложной задачи. Формулы нет. Подобно любому произведению искусства, ваш успех в создании общины потребует серьёзного таланта, мужества и творческого подхода. И ещё чудовищных затрат времени. Эту работу вы не сделаете самостоятельно; в лучшем случае вы послужите катализатором. Ваше творение не будет напоминать чьё-либо ещё.
    Так что вместо формулы мы предлагаем пример, всего один пример. Он связан с одной из наших клиентских компаний, с компанией, где один инициативный руководитель сделал шаг вперёд и изменил культуру навсегда. Этот каталитический гений убедил организацию строиться вокруг школы, в состав которой входят детский сад, центр дошкольной подготовки и первые пять классов начальной школы. В эту школу ходят дети сотрудников компании.
    Несомненно, вы способны усмотреть в этом рационализацию, основанную на деньгах, уникальное преимущество компании, нуждающейся в найме программистов и инженеров на сложном рынке труда. Но чтобы увидеть, какова роль школы в создании общины, вам нужно посетить компанию. Нужно увидеть собственным глазами, как каждый день учителя проводят всех учеников через объекты компании. Получается шумный, смешной, торжествующе глупый парад маленьких взвинченных ребятишек, которые со всеми здороваются. Их за километр слышно. В этот момент прекращается всякая работа. Родители обнимают детей. По окончании парада всем обеспечено хорошее настроение.
    Представьте, каково быть человеком, благодаря которому это стало возможным. Представьте, что сможете вспомнить это в возрасте ста одного года.

    Библиография

    {1} Albrecht, 1979. Albrecht, A.J. «Measuring Application Development Productivity.» Proceedings of the Joint SHARE/GUIDE/IBM Application Development Symposium. Chicago: Guide International Corp., 1979.
    {2} Alexander, 1964. Alexander, Christopher. Notes on the Synthesis of Form. Cambridge, Mass.: Harvard University Press, 1964.
    {3} Alexander, 1979. Alexander, Christopher. The Timeless Way of Building. New York: Oxford University Press, 1979.
    {4} Alexander et al., 1975. С Alexander, M. Silverstein, S. Angel, S. Ishikawa, and D. Abrams. The Oregon Experiment. New York: Oxford University Press, 1975.
    {5} Alexander et al., 1977. С Alexander, S. Ishikawa, and M. Silverstein, with M. Jacobson, I. Fisksdahl-King, and S. Angel. A Pattern Language. New York: Oxford University Press, 1977.
    {6} Augustine, 1979. Augustine, N.R. «Augustine's Laws and Major System Development Programs.» Defense Systems Management Review, 1979, pp. 50-76.
    {7} Bailey and Basili, 1981. Bailey, J.W., and V.R. Basili. «A Meta-Model for Software Development and Resource Expenditures.» Proceedings of the 5th International Conference on Software Engineering. New York: Institute of Electrical and Electronics Engineers, 1981, pp. 107-116.
    {8} Bartol, 1983. Bartol, К. «Turnover Among DP Personnel: A Causal Analysis.» Communications of the ACM, Vol. 26, No. 10 (October 1983), pp. 807-811.
    {9} Boehm, 1981. Boehm, Barry W. Software Engineering Economics. Englewood Cliffs, N.J.: Prentice-Hall, 1981.
    {10} Boehm etal., 1984. Barry W. Boehm, Maria H. Penedo, E. Don Stuckle, Robert D. Williams, and Arthur B. Pyster. «A Software Development Environment for Improving Productivity.» Computer, Vol. 17, No. 6 (June 1984), pp. 30-42.
    {11} Brady, 1986. Brady, J. «A Theory of Productivity in the Creative Process.» IEEE Computer Graphics & Applications, May 1986, pp. 25-34.
    {12} Bridges, 1991. Bridges, W. Managing Transitions: Making the Most of Change. Reading, Mass.: Addison-Wesley, 1991.
    {13} Brill, 1983. Brill, Michael, with Stephen T. Margulis, Ellen Konar, and BOSTI. Using Office Design to Increase Productivity. Buffalo, N.Y.: Buffalo Organization for Social and Technological Innovation, 1983.
    {14} Brunner, 1972. Brunner, John. The Sheep Look Up. New York: Ballantine Books, 1972.
    {15} Couger and Zawacki, 1980. Couger, J. Daniel, and Robert A. Zawacki. Motivating and Managing Computer Personnel. New York: John Wiley & Sons, 1980.
    {16} Crosby, 1979. Crosby, Philip B. Quality Is Free: The Art of Making Quality Certain. New York: McGraw-Hill, 1979.
    {17} deBono, 1970. deBono, Edward. Lateral Thinking: Creativity Step by Step. New York: Harper & Row, 1970.
    {18} DeMarco, 1977. DeMarco, Tom. Report on the 1977 Productivity Survey. New York: Yourdon, Inc., September 1977.
    {19} DeMarco, 1978. DeMarco, Tom. Structured Analysis and System Specification. Engle-wood Cliffs, N.J.: Prentice-Hall, 1978.
    {20} DeMarco, 1982. DeMarco, Tom. Controlling Software Projects: Management, Measurement & Estimation. Englewood Cliffs, N.J.: Prentice-Hall, 1982.
    {21} DeMarco, 1997. DeMarco, Tom. The Deadline: A Novel About Project Management. New York: Dorset House Publishing, 1997.
    {22} DeMarco and Lister, 1985. Tom DeMarco, and Tim Lister. «Programmer Performance and the Effects of the Workplace.» Proceedings of the 8th International Conference on Software Engineering. New York: Institute of Electrical and Electronics Engineers, 1985, pp. 268-272.
    {23} Deming, 1982. Deming, W.E. Out of the Crisis. Cambridge, Mass.: Massachusetts Institute of Technology, Center for Advanced Engineering Study, 1982.
    {24} Dittrich, 1984. Dittrich, R. «Open-Plan DP Environment Boosts Employee Productivity.» Data Management, Vol. 22 (1984).
    {25} Forester, 1950. Forester, C.S. Mr. Midshipman Hornblower. New vork: Pinnacle Books, 1950.
    {26} Gilb, 1977. Gilb, Tom. Software Metrics. Cambridge, Mass.: Winthrop Publishers, 1977.
    {27} Gilbert, 1978. Gilbert, Thomas F. Human Competence: Engineering Worthy Performance. New York: McGraw-Hill, 1978.
    {28} Goleman, 1986. Goleman, D. «Concentration Is Likened to Euphoric States of Mind.» New York: Science Times, The New York Times, March 4, 1986.
    {29} Gordon, 1961. Gordon, William J.J. Synectics. New York: Harper & Row, 1961.
    {30} Hodges, 1986. Hodges, Parker. «Salary Survey: Small Change for DP Pros.» Datamation, Vol. 32, No. 18 (Sept. 15,1986), pp. 72-87.
    {31} Jaynes, 1976. Jaynes, Julian. The Origin of Consciousness in the Breakdown of the Bicameral Mind. Boston: Houghton Mifflin, 1976.
    {32} Jeffery and Lawrence, 1985. Jeffery, D.R., and M.J. Lawrence. «Managing Programming Productivity.» Journal of Systems and Software, Vol. 5, No. 1 (January 1985).
    {33} Jones, 1981. Jones, Capers. Programmer Productivity: Issues for the Eighties. IEEE Catalog No. EHO 186-7. New York: Institute of Electrical and Electronics Engineers, 1981.
    {34} Jones, 1986. Jones, Capers. Programming Productivity. New York: McGraw-Hill, 1986.
    {35} Kidder, 1981. Kidder, Tracy. The Soul of a New Machine. Boston: Atlantic Monthly/ Little, Brown, 1981.
    {36} Lawrence, 1981. Lawrence, Michael. «Programming Methodology, Organizational Environment, and Programming Productivity.» Journal of Systems and Software, Vol. 2 (1981), pp. 257-269.
    {37} Lawrence and Jeffery, 1983. Lawrence, Michael, and D.R. Jeffery. «Commercial Programming Productivity-An Empirical Look at Intuition.» Australian Computer Journal, Vol. 15, No. 1 (February 1983), p. 28.
    {38} Machiavelli, 1985. Machiavelli, NiccolT. The Prince, trans. Harvey С Mansfield, Jr. Chicago: University of Chicago Press, 1985.
    {39} McCue, 1978. McCue, Gerald. «IBM's Santa Teresa Laboratory-Architecture Design for Program Development.» IBM Systems Journal, Vol. 17, No. 1 (1978), pp. 320-341.
    {40} Mills, 1983. Mills, Harlan D. «Software Productivity in the Enterprise.» Software Productivity. New York: Dorset House Publishing, 1988.
    {41} Morrissey and Wu, 1980. Morrissey, J.H., and S.-Y. Wu. «Software Engineering: An Economic Perspective.» Proceedings of the 4th International Conference on Software Engineering. New York: Institute of Electrical and Electronics Engineers, 1979, pp. 412-422.
    {42} Orr, 1990. Orr, Kenneth T. The One Minute Methodology. New York: Dorset House Publishing, 1990.
    {43} Parkinson, 1954. Parkinson, C. Northcote. Parkinson's Law and Other Studies in Administration. New York: Ballantine Books, 1979.
    {44} Parsons, 1974. Parsons, H.M. «What Happened at Hawthorne?» Science, Vol. 183 (March 8,1974), pp. 922-932.
    {45} Robbins, 1977. Robbins, Tom. Even Cowgirls Get the Blues. New York: Bantam Books, 1977.
    {46} Sackman et al., 1968. Sackman, H., W.J. Erikson, and E.E. Grant. «Exploratory Experimental Studies Comparing On-line and Off-line Performance.» Communications of the ACM, Vol. 11, No. 1 (January 1968), pp. 3-11.
    {47} Satir, 1991. Satir, V., J. Banmen, J. Gerber, and M. Gomori. The Satir Model: Family Therapy and Beyond. Palo Alto, Calif.: Science and Behavior Books, 1991.
    {48} Soloway and Iyengar, 1986. Soloway, Elliot, and Sitharama Iyengar, eds. Empirical Studies of Programmers. Norwood, N.J.: Ablex Publishing Corp., 1986.
    {49} Tajima and Matsubara, 1984. Tajima, D., and T. Matsubara. «Inside the Japanese Software Industry.» Computer, Vol. 17 (March 1984).
    {50} Thomsett, 1980. Thomsett, Rob. People & Project Management. Englewood Cliffs, N.J.: Prentice-Hall, 1980.
    {51} Townsend, 1970. Townsend, R. Up the Organization. New York: Alfred A. Knopf, 1970.

    [1] Исследования проектов Демарко/Листера описаны в работах DeMarco, 1977 {18}; DeMarco, 1978 {19}; DeMarco, 1982 {20}; DeMarco и Lister, 1985 {22}.
    [2] Количество провальных проектов, требовавших от двадцати пяти человеко-лет работы, взято из работы Jones, 1981 {33}.
    [3] В этой книге термины «работники интеллектуального труда», «участники разработки», «работники интеллектуальной сферы» употребляются для обозначения людей, которые зарабатывают на жизнь головой.
    [4] К сожалению, не существует национального бюро фактов, собирающего и публикующего конкретные данные о времени, затрачиваемом разработчиками на такую деятельность, как стратегическое мышление и исследование новых методов. Цифра в пять процентов, использованная в тексте, получена в результате экспериментов, в которых технические работники специально для наблюдателя думали вслух во время решения своих задач или же позволяли наблюдать за собой через одностороннее стекло. Подобные иследования описаны в работе Soloway и Iyengar, 1986 {48}.
    [5] Статистика по книгам позаимствована из частной переписки с покойным Карлом Карлстромом (Karl Karlstrom), главным редактором отдела учебной литературы издательства Prentice-Hall, 1981.
    [6] Стихи, а также название главы взяты с альбома Билли Джоэла «The Stranger» (1977); перепечатаны с разрешения.
    [7] Подробнее о проекте Data General Eagle в работе Kidder, 1981 {35}.
    [8] О превалирующих стандартах качества программного обеспечения см. Jones, 1981 {33}.
    [9] Tajima и Matsubara, 1984 {49}, стр. 40.
    [10] См. Crosby, 1979 {16}.
    [11] Подробнее этот известный закон описан в работе Parkinson, 1954 {43}.
    [12] Австралийский штат. — Примеч. перев.
    [13] Наиболее свежие цифры исследований в Новом Южном Уэльсе приводятся в работе Jeffery и Lawrence, 1985 {32}.
    [14] См. Boehm, 1982 {9}.
    [15] Таблицы 5.1 и 5.2 являются адаптацией данных, полученных Джеффри и Лоуренсом, 1985 {32}.
    [16] Цитата из Jones, 1986 {34}, стр. 213.
    [17] Таблица 5.3 из работы Jeffery и Lawrence, 1985 {32}.
    [18] Вы правы в своём беспокойстве, что 24 проекта, обошедшиеся без предварительных оценок, могли быть особенными в другом отношении: более короткими или с участием старших сотрудников. Мы исследовали подобные возможности и не обнаружили ничего похожего.
    [19] Данные о (ничтожно малом) приросте производительности в отрасли разработки программного обеспечения взяты из работы Morrissey и Wu, 1980 {41}.
    [20] Обоснование необходимости окон на рабочем месте приводится в работе Alexander, 1977 {5}. Более подробно об окнах см. в главе 13.
    [21] помехи
    [22] Выкладки данных открытых исследований производительности с 1977 по 1981 годы представлены в работе DeMarco, 1982 {20}. Военные манёвры разработчиков описаны подробно в работе DeMarco и Lister, 1985 {22}.
    [23] Рисунок 8.1 с вариациями производительности и три основных правила происходят из трех источников: Boehm, 1981 {9}, стр. 435-437, 447; Sackman и др., 1968 {46}, стр. 3-11; Augustine, 1979 {6}. Последующий анализ, проведённый Майклом Лоуренсом из Университета Нового Южного Уэльса, придаёт этим трём правилам ещё больший вес (см. Lawrence, 1981 {36}).
    [24] Рисунок 8.2, отражающий вариации производительности в военных манёврах разработчиков 1984 года, взят из работы DeMarco и Lister, 1985 {22}.
    [25] Более подробно об очень слабых связях производительности и таких факторов, как зарплата и опыт, можно узнать из работы Lawrence и Jeffery, 1983 {37}.
    [26] 10 к 1
    [27] Цитата Харлана Миллза из работы Mills, 1983 {40}, стр. 266
    [28] Не мы одни наблюдаем связь рабочего места и производительности. Дополнительные соображения по теме можно найти в работе Boehm и др., 1984 {10}.
    [29] Данные по стоимости пространства позаимствованы из работы Brill, 1983 {13}.
    [30] Имеются в виду окна, расположенные по внешнему периметру здания. — Примеч. перев.
    [31] См.Brunner, 1972 {14}.
    [32] Цитата из журналаDataManagement, см. Dittrich, 1984 {24}.
    [33] Подробности по исследованию в IBM см. в работе McCue, 1978 {39}.
    [34] Рисунок 9.1 из работы DeMarco и Lister, 1985 {22}.
    [35] Том Гилб не единственный и даже не первый человек, обративший внимание на измеримость. См., к примеру, главу 2 работы Gilbert, 1978 {27}.
    [36] Схемы измерения производительности см. в работах Albrecht, 1979 {1}; Bailey и Basili, 1981 {7}; Boehm, 1981 {9}; Jones, 1986 {34}; DeMarco, 1982 {20}.
    [37] Упомянутая услуга оценки предоставляется компанией Quantitative Software Management, McLean, VA.
    [38] Более подробно об идее измерения отдельных характеристик «вслепую» см. DeMarco, 1982 {20}.
    [39] Таблицу 10.1 см. в работе McCue, 1978 {39}.
    [40] Подробнее о потоке рассказано в работах Goleman, 1986 {28}; Brady, 1986 {11}.
    [41] ESS—ElectronicSwitchingSystem(электронный коммутатор).
    [42] Корнелльский эксперимент не был задокументирован, а потому обрёл статус слуха, но только не для тех из нас, кто на эксперименте присутствовал. Сравнительная оцеяка влияния музыки на способность концентрироваться приводится в работе Jaynes, 1976 {31}, стр. 367-368.
    [43] Перепечатка с разрешения из работы Alexander, 1979 {3}, стр. 7
    [44] Перепечатка с разрешения из работы Alexander и др., 1975 {4}, стр. 10-11.
    [45] Рисунок перепечатан из работы Alexander и др., 1975 {4}, стр. 46.
    [46] Перепечатка с разрешения из Alexander и др., 1977 {5}, стр. 847-851.
    [47] Рисунок перепечатан из работы Alexander и др., 1977 {5}, стр. 846.
    [48] Рисунок перепечатан из работы Alexander и др., 1975 {4}, стр. 125.
    [49] Сведения о стоимости обеспечения каждого работника окном взяты из частной беседы с Майклом Бриллом (Michael Brill), президентом BOSTI, март 1987.
    [50] Район Нью-Йорка.
    [51] рабочей группе
    [52] Перепечатка с разрешения из работы Alexander и др., 1977 {5}, стр. 697-699.
    [53] Типичные показатели текучести кадров можно найти в работе Bartol, 1983 {8}.
    [54] Просто пугает, насколько молодыми могут быть люди, создающие продукты. Исходные данные см. в работе Hodges, 1986 {30}.
    [55] См. Townsend, 1970 {51},стр. 64.
    [56] речь идёт о применении методов, спущенных сверху
    [57] Кен Орр отыгрался на Методологиях «С большой М» в своей замечательной пародии «The One Minute Methodology» (Методология за одну минуту). См. Orr, 1990 {42}.
    [58] Оригинальный взгляд на эффект Готорна см. в работе Parsons, 1974 {44}.
    [59] Percina tanasi, вид окунеобразных, внесённый в Красную книгу. — Примеч. перев.
    [60] Персонаж комиксов про Флэша Гордона, воплощение чистого зла. — Примеч. перев.
    [61] Жестокий работорговец из романа Гарриет Бичер Стоун «Хижина дяди Тома». — Примеч. перев.
    [62] См. deBono, 1970 {17}. Материалы о де Боно см. на http://www.debono.ru. — Примеч. ред.
    [63] См. Jones, 1981 {33}.
    [64] См. Thomsett, 1980 {50}.
    [65] ИзкнигиТомаРоббинса.См. Robbins, 1977 {45}, стр. 280.
    [66] Название раздела, посвящённого замыканиям, происходит из выступления Нэнси Мибон (Nancy Meabon) на конференции Feedback '86, спонсированной компанией Ken Orr & Associates и прошедшей в Канзас-Сити в октябре 1986 г.
    [67] Прадедом игровых манёвров в бизнесе является Роберт Чейз (Chase), создавший упражнение Hotel and Club Management Simulation Exercise (Симуляция управления отелем и клубом), которое проводится под покровительством Колледжа гостиничного администрирования Статлера при Университете Корнелла
    [68] одна из участниц
    [69] Наиболее авторитетный источник в области мозговых штурмов — захватывающая книга Эдварда деБоно «Lateral Thinking: Creativity Step by Step», 1970 {17}. Автор демонстрирует связь творчества и юмора при помощи набора простых упражнений. Прочитав эту книгу, вы ищете в себе вспышки творчества всякий раз, когда смеётесь.
    [70] http://www.outwardbound.com. — Примеч. перев.
    [71] Побережье Атлантики, США. — Примеч. перев.
    [72] Горный массив Аппалачи, США. — Примеч. перев.
    [73] IntegratedDataManagementSystemилиIntegratedDocumentManagementSystem. — Примеч. перев.
    [74] Авторы употребляют слово intrapreneur, появившееся в английском языке сравнительно недавно. Оно образовано от intra— и французского entrepreneur и обозначает руководящего сотрудника компании, отвечающего за новые начинания, предпринимаемые для создания новых продуктов. Другими словами, интрапренер — это внутрикорпоративный предприниматель. — Примеч. перев.
    [75] Во время немецкой оккупации сороковых годов одна весьма активная организация датского сопротивления называла себя «Хольгер Датчанин».
    [76] Теория Джерри Вейнберга относительно сверхурочных стала известна из разговора с ним во время совместного консультирования в Форт-Коллинз 25 сентября 1990 года.
    [77] помимо прочего
    [78] См. Deming, 1982 {23}, стр. 24.
    [79] Совет читателям: этот раздел читайте вслух, по возможности копируя голос Дарта Вейдера.
    [80] Дарт Вейдер (Darth Vader) и Люк Скайуокер (Luke Skywalker)— персонажи «Звёздных войн» (http://sw-en.narod.ru/peo/ vader.html). — Примеч. ред.
    [81] Злобный смех
    [82] См. Machiavelli, 1985 {38}, стр. 23.
    [83] Рисунок 30.1 основан на частной переписке с Джерри Джонсоном в 1992 г., посвящённой его работе с Д. Своггером (G. Swogger) над «Resistance Continuum» (Спектр сопротивляемости).
    [84] Наблюдения касательно превознесения старых вещей см. в работе Bridges, 1991 {12}, стр. 30.
    [85] Рисунок 30.3 основан на семантике содержания работы Satir, 1991 {47}.
    [86] Американка Пикабо Стрит — одна из самых быстрых лыжниц мира в скоростных спусках, обладательница серебра и золота Олимпийских игр и многократная победительница чемпионатов мира. — Примеч. перев.
    [87] См. также статью ТомаДемарко«Human Capital, Unmasked» (Человеческийкапиталбезмаски) в The NewYork Times, Vol, CXLV, No. 50,397, Section 3, Money & Business (April 14, 1996),стр. 13.
    [88] Предложение Николаса Негропонте (Nicholas Negroponte) было сделано на Камденской конференции по телекоммуникациям в октябре 1997 года в ходе его выступления, озаглавленного «Конвергенция технологий».
    [89] Детская бейсбольная лига. — Примеч. перев.
    [90] В действительности «гибкий» найм на стадиях ключевого анализа и проектирования может быть опасен для вашего здоровья, как показано в книге Демар-ко «The Deadline: A Novel About Project Management» (Срок сдачи: Новелла о руководстве проектами), Dorset House, 1997 {21}. Главный герой, Томпкинс, тайно использует «лёгкую» команду на стадии анализа и проектирования, хотя ему грозит смертная казнь, если он не сдаст продукт к нереальному сроку.

    «Человеческий фактор: успешные проекты и команды»: Символ-Плюс; 2005
    ISBN 5-93286-061-8, 0-932633-43-9

    Перевод: М. Зислиса

    Специально для www.natahaus.ru